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DIGITALE LETTERTYPES TEKENEN 2.1, UITGAVEDATUM 15 NOVEMBER 2016
De gebruikte versie van Glyphs op het moment van uitgave was 2.1.1 (augustus 2015).
De gebruikte versie van FontLab op het moment van uitgave was 5.1.4 (maart 2013).
De gebruikte versie van RoboFont op het moment van uitgave was 1.6 (november 2014).

Deze cursus weerspiegelt het hedendaagse digitaal uitwerken van lettertypes in eenvoudige 
en begrijpbare woorden. In plaats van elke knop in een programma te bespreken 
wordt een zo breed mogelijk overzicht opgebouwd van de vereiste kennis om een goed 
lettertype te ontwikkelen en te gebruiken. Daarvoor wordt er stap voor stap verteld wat 
een digitaal lettertype is en hoe het werkt. Theorie over het uitwerken van een digitaal 
lettertype wordt afgewisseld met theorie over letterontwerp of uitleg over de benodigde 
programma’s. In deze cursus wordt het programma Glyphs behandeld, af en toe aangevuld 
met FontLab en RoboFont om op verschillen tussen de programma’s te duiden.

Deze Nederlandstalige handleiding voor starters is oorspronkelijk opgesteld door Maarten 
Renckens in de zomer van 2014 samen met docente Ann Bessemans voor de opleiding 
typografie aan toenmalige MAD-faculty te Hasselt, intussen de PXL-MAD (Media, Arts 
and Design) te Hasselt. Deze cursus werd toen goedgekeurd door de ontwikkelaars van 
Glyphs. Nadien is deze handleiding in eigen beheer verdergezet en uitgebreid voor de 
onderzoeksgroep READSEARCH van diezelfde typografische opleiding. Ze dient in eerste 
plaats voor de cursus gegeven aan de PXL-MAD. Daarnaast is het een naslagwerk waar 
studenten een algemene basiskennis over het maken van digitale lettertypes kunnen 
terugvinden.

Binnen de school is de meest actuele versie van dit document in digitaal formaat terug te 
vinden op de interne server apple.pxl.be. Online is deze cursus is in digitaal formaat te 
downloaden op cursus.artengar.com en ook op de iTunes Store van Apple. Alle materiaal 
wordt gratis ter beschikking gesteld en mag naar believen herverdeeld worden, mits een 
correcte bronvermelding.

http://www.pxl.be/Pub/Departementen/MAD.html
http://www.pxl.be/Pub/Departementen/MAD.html
afp://apple.pxl.be
http://cursus.artengar.com


VOORWOORD BIJ DE TWEEDE EDITIE
De tweede editie van deze cursus is een grotendeels herschreven werk. Alle ervaringen met de 

eerste editie zijn verwerkt zodat er een veel diepgaander geheel ontstaat dat studenten 
sneller op weg zal helpen in de wereld van de digitale letters.

Opnieuw wil ik een aantal personen danken die mij nogmaals geholpen hebben bij het tot stand 
komen van dit werk. Allereerst mijn collega’s Ann Bessemans en Kevin Bormans voor de 
waardevolle gesprekken over fontdesign. Ten tweede mijn leerlingen binnen fontdesign 
die aangaven welke onderdelen zij het moeilijkste vonden. En tenslotte niet in het minst 
Marleen Driesen en Kevin Bormans voor het taalkundig nalezen en Wouter Vanmontfort 
voor de technische ondersteuning in het hoofdstuk over Python.

Dit geheel is met de grootst mogelijke zorg samengesteld. Mochten er nog fouten in 
deze uitgave geslopen zijn, dan zijn deze welkom op: maarten.renckens@pxl.be of 
cursus@artengar.com.

VOORWOORD BIJ DE EERSTE EDITIE
Deze cursus is in eerste instantie geschreven door Maarten Renckens met en voor Ann 

Bessemans, docente typografie aan de MAD-faculty (Media, Arts and Design faculty, www.
mad-fac.be), een afdeling van de Hogeschool PXL (www.pxl.be). Ze is nadien goedgekeurd 
door de ontwikkelaars van Glyphs zelf. Ook wil ik verder iedereen bedanken wie geholpen 
heeft bij het tot stand laten komen van deze cursus: Ann Bessemans voor haar goed advies 
en Marleen Driesen en Rainer Erich Scheichelbauer voor het nalezen en corrigeren van 
de tekst. Daarnaast nog dank aan vele anderen die tips gaven om het beste resultaat te 
bereiken.

mailto:maarten.renckens%40pxl.be?subject=
mailto:cursus%40artengar.com?subject=Feedback%20cursus%20Glyphs
http://www.mad-fac.be/
http://www.mad-fac.be/
http://www.pxl.be
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Letters zijn belangrijk voor mensen. Het communiceren via en weergeven van gedachten in 
een ‘symbolentaal’ is wellicht één van de meest geniale uitvindingen van de mensheid 
(Bessemans, 2012). Zonder letters zou communicatie veel moeilijker verlopen. Het 
Latijnse, Griekse en Hebreeuwse schrift zijn naast vele andere allemaal voorbeelden van 
‘symbooltalen’. Het zijn stuk voor stuk verschillende mogelijkheden om te communiceren 
en gedachten over te brengen tussen mensen. In het Latijnse schrift zijn bijvoorbeeld 
zesentwintig verschillende karakters aanwezig. Elk van deze karakters heeft een naam die 
overeenkomt met de bijbehorende uitspraak (Aa, Bee, Cee, Dee,…). Individueel hebben 
deze karakters weinig betekenis. Slechts als zij in bepaalde combinaties gebruikt worden 
en zo een woord vormen krijgen zij een specifieke betekenis. Uiteindelijk zijn het deze 
woorden die het mogelijk maken om ideeën van de ene persoon naar de andere persoon 
over te brengen.

Schriften en alfabetten zijn niet van de ene dag op de andere ontstaan: de 
ontstaansgeschiedenis omvat duizenden jaren. Letters ontstonden en evolueerden, wat 
sporen naliet in de vorm van de letters. In verschillende regio’s ontstonden varianten 
op de lettervormen of splitste zich soms een volledig schrift af. Daarnaast gaf het steeds 
veranderende schrijfmateriaal nieuwe mogelijkheden. In 1470 ontwikkelde Nicolas Jenson 
het eerste Romeinse lettertype, gebaseerd op de Karolingische miniscuul. Dit Jenson-
Eusebius lettertype werd al spoedig populair in Italië en daar buiten, als reactie tegen de 
toen alomtegenwoordige Blackletter. Onbewust bepaalde hij toen het archetype van elke 
letter, een basisvorm waaraan elke letter voldoet. Sinds die tijd zijn de lettervormen amper 
nog gewijzigd (Bessemans, 2012). Of de letters nu ontworpen worden om in lood gegoten 
te worden, gebruikt worden op de matrijzen van een LinoType of InterType, uitgesneden 
zijn voor een fotozetmachine of bestaan als data opgeslagen op een computer, de 
basisvormen blijven bestaan.

Ondanks het bestaan van deze basisvormen als richtlijn zijn er vele verschillende lettertypes 
in omloop en verschilt elk lettertype in uitwerking. Het ontwikkelen van letters gaat dan 
ook gepaard met het maken van vele ontwerpbeslissingen. De context is hiervoor zeer 
belangrijk: wordt het ontwerp een displaylettertype om grote koppen mee te zetten en 
moet het dus opvallen? Of wordt het een lettertype om leesteksten mee te zetten? Mag 
de aandacht getrokken worden naar de vorm van de individuele letters of zouden de 
letters zo helder moeten zijn als een wijnglas opdat de inhoud beter zichtbaar is (Warde 
Beatrice, 1956). 

Dat letters bruikbaar zijn in een zeer uitgebreide context maakt het letterontwerp fijn maar 
ook zeer complex. De letterontwerper zal alle mogelijkheden tegen elkaar afwegen en 
dan gericht een beslissing maken over de vorm van het lettertype. Het bereiken van een 
optimale lettervorm gaat dan ook gepaard met zeer veel ontwerpparameters. Enkele 
voorbeelden zijn de x-hoogte, het ritme (de opeenvolging van verticale letterstroken), 
het verloop van de rondingen enz. Zelfs de vorm van de schreven en vlaggen kan als een 
parameter beschouwd worden omdat deze uniek zijn in elk lettertype. En het veranderen 
van één enkele parameter heeft niet alleen een invloed op het uiterlijk van het lettertype, 
maar heeft meestal ook een invloed op andere parameters. Zo zal bijvoorbeeld een 
verandering van de strookdikte ook een verandering vragen in de schreven, de witruimten 
rondom, misschien ook in het contrast enz. Veranderingen in de rondingen en de 
contrasten van de letter a komen meestal terug in de vlag van de letter f. Kennis over al 

1.  LETTERS BINNEN EEN CONTEXT

1.1.  GESCHIEDKUNDIGE CONTEXT

1.2.  CONTEXT VAN DE LAYOUT
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deze parameters en hoe zij zich ten opzichte van elkaar verhouden is belangrijk, omdat 
zij de ontwerper een kader geven om op een correcte manier letter(type)s te ontwerpen 
(Maarten Renckens, Ph.D.).

Daarnaast hebben deze parameters niet enkel invloed op het uiterlijk van een letter(type) maar 
ook op de readability, de legibility en de noticeability van een lettertype en daarmee dus 
ook weer op het uiteindelijke gebruik. Het zijn kernbegrippen die een letterontwerper 
steeds in het achterhoofd houdt: als het lettertype door ontwerpbeslissingen niet meer 
leesbaar is op kleine grootte, dan zal het niet meer gebruikt worden om tekst te zetten.

Readability is in het Nederlands te vertalen als leesbaarheid. Er zijn drie mogelijke definities 
van readability. “De kwaliteit van de typografische opstelling op de pagina” komt overeen 
met de typografische gelaagdheid en ordening van het zetwerk. Een tweede definitie is 
”Het leesgemak waarmee een tekst gelezen wordt”. Dit heeft minder te maken heeft met 
de vormgeving maar meer met de schrijfstijl van de auteur én de begrijpbaarheid van het 
onderwerp, dus hoe goed de lezer met het onderwerp overweg kan. Walter Tracy (1986) 
verwoordt readability als ”Het visuele comfort dat letters geven wanneer ze toegepast 
worden in doorlopende tekst.” Dit komt opnieuw overeen met hoe goed de pagina 
layout oogt en hoe gemakkelijk daar de typografische gelaagdheid uit af te leiden is: titel, 
hoofdstukken, leestekst,…

Legibility wordt in de Nederlandse taal vertaald als leesbaarheid, net zoals readability. In de 
Nederlandse taal is er geen onderscheid en daarom worden de Engelstalige termen 
behouden. Ook legibility beschikt weer over drie mogelijke definities: ”De intrinsieke 
karakteristieken in en de gewenste kwaliteit van lettertypes.” Robert Bridges omschrijft 
legibility als “de zekerheid van ontcijfering.” wat te illustreren is door de combinatie:  lll.  
Zonder de context weet niemand of dit een drie is, een honderdenelf of het Engelse woord 
‘ill’ (ziek). Walter Tracy (1986) verwoordt legibility als “De onderscheidbaarheid van letters 
en de duidelijkheid van een letter of lettertype.” Alle definities hebben gemeen dat de 
legibility de vormkenmerken van het lettertype betreft.

Tenslotte is er de noticeability, welke zeer sterk gerelateerd is aan de readability en de legibility. 
Noticeability wordt gedefinieerd als “de mate waarin de lettervorm of het gehele 
letterbeeld zich aan de toeschouwer opdringt.” Sommige lettettypes zijn zo uniform 
mogelijk terwijl anderen zeer sprekend zijn. En soms dient een lettertype gewoon om op 
te vallen en in dat geval doen de readability en de legibility er niet zo toe. De noticeability 
omschijft dan hoe veel het lettertype afwijkt van de archetype letters en beschrijft de 
uitgesprokenheid van de specifieke vormkenmerken van dit lettertype.

Om alle parameters optimaal op elkaar af te stellen, een perfecte mix te creëren tussen de 
readability, de legibility en de noticeability én het ontwerp tevens af te stellen op het 
beoogde gebruik is een brede kijk op het letterontwerp nodig. Door te studeren krijgt de 
letterontwerper het benodigde inzicht, door te schetsen en te experimenteren krijgt de 
letterontwerper de benodigde vaardigheden om in zijn werk te slagen. In de specialisatie 
typografie van de opleiding grafisch ontwerp aan de PXL-MAD wordt deze combinatie 
van theorie en praktijk zo diep mogelijk doorgevoerd waardoor de studenten een zo ruim 
mogelijke inzicht krijgen over typografie en het letterontwerp. De eerste Bachelor geeft 
een basiskennis over letters in het algemeen: de anatomie van de letters (uit de ‘Cluster 
Typografie’) gaat hand in hand met de eerste ontwerpopdrachten (uit het Atelier). De 
vaardigheden in het letterontwerp worden verdiept in de tweede Bachelor met een 
doorgedreven kennis over de typografie (ook in de ‘Cluster Typografie’ en het Atelier), 
aangevuld met de digitale technieken (digitale lettertypes uitwerken). Deze cursus richt 
zich op de laatste nieuwe technieken binnen het letterontwerp: de computer. In de 
derde Bachelor wordt de kennis over het letterontwerp en de typografie aangevuld met 
inzichten over leesbaarheidsonderzoek in zowel de Cluster Typografie als het Atelier. De 
Masteropleiding sluit dit geheel af voor de studenten die zich verder willen verdiepen: de 
masterstudio Typo & Type to Read biedt een vrije en experimentele leeromgeving terwijl 
het masterproject en de masterscriptie de student de kans geven zich te verdiepen in zijn 
eigen interessegebieden. Al deze vakken zijn gerelateerd aan elkaar, geen enkel vak is een 
losstaand geheel.

1.3.  EDUCATIEVE CONTEXT
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De naam van dit programma is een woord overgenomen uit de typografische wereld: glyphs1 
zijn de vormen van elk individueel karakter (letter) in een font2. Dat is ook exact wat er in 
dit programma gedaan zal worden: glyphs van een font vormgeven en bundelen tot een 
digitaal bestand zodat het bruikbaar is voor het typwerk op de computer.

Glyphs (2011) is een tamelijk recent programma t.o.v. FontLab of Fontographer en dit heeft 
enkele gevolgen. Om te beginnen richt het zich voornamelijk op de laatste nieuwe 
standaard in de typografie: de OpenType. Andere standaarden zoals TrueType zijn wel 
(gedeeltelijk) ondersteund. In tegenstelling tot de oudere concurrenten heeft Glyphs zich 
aangepast aan de hedendaagse vormgeving van het besturingssysteem OS X. Jammer 
genoeg is het programma enkel uitgebracht voor OS X, en (nog) niet voor Windows, Unix 
of Linux. Verdere informatie is terug te vinden op de website www.glyphsapp.com.

Glyphs is te viden op de website www.glyphsapp.com. Glyphs 2 vereist OS X 10.9 (Mavericks) of 
later. Voor oudere versies van OS X is er wel nog steeds de beschikking over Glyphs 1 (enkel 
nog te vinden op de website www.glyphsapp.com).

Na het downloaden staat er een zip-map op de computer. In deze map bevindt zich de app 
Glyphs. Sleep deze app in de Finder naar de map Programma’s. Zo eenvoudig is het 
installeren. Om de app later eventueel te verwijderen ga dan opnieuw naar de map 
Programma’s en verplaats de app Glyphs naar de prullenmand.

Uh? Glyphs kopen? Waarom zou ik niet een illegale versie van Glyphs zoeken en downloaden? 
Dat kan je beter niet doen: er gaan illegale versies rond die niet goed werken (er gaat 
bijvoorbeeld een versie rond die geen bestanden kan openen of importeren). Stel jezelf 
trouwens eens de vraag of jij graag zou hebben dat iemand jouw werk zomaar steelt nadat 
je er jarenlang aan werkte? De prijzen van de legale versies zijn zeer democratisch en zijn 
dus zeker aan te raden.

Ten eerste is er een proefversie van dertig dagen beschikbaar op de website www.glyphsapp.
com. Deze proefversie beschikt over alle mogelijkheden van de volledige versie.

De volledige versie van Glyphs is ook te koop op de website www.glyphsapp.com. Na betaling 
wordt een registratiebestand JouwNaam.glyphsLicense toegestuurd per email. Met dit 
bestand is Glyphs te activeren.

Studenten krijgen korting op de prijs. Wie recht heeft op deze korting vraagt deze aan via www.
glyphsapp.com/get-glyphs. Dit is een volwaardige licentie die bovendien nooit vervalt, ook 
niet na afloop van de schoolcarrière. Als student is het mogelijk om het programma direct 
in zijn geheel aan te kopen, maar daarnaast is er ook een licentie van een half jaar. Deze 
is dan tweemaal voor dezelfde prijs te verlengen, waarna de licentie verandert naar een 
volledige licentie voor altijd.

Buiten de eerste opties is er ook nog Glyphs Mini. Dit is een afgeslankte versie, die ondanks het 
ontbreken van veel functies zeer veel mogelijkheden biedt om een degelijk lettertype te 
maken. Deze versie is enkel beschikbaar in de App Store van Apple.

1. Glyph is de Engelse term voor glief of gliefen. Omdat deze Engelstalige term ook in het Nederlands ingang gevonden heeft en vaak 
gebruikt wordt, houden we deze in de cursus aan.

2. Om een overzicht te behouden over de typografische termen: Lettergroepen zijn een verzameling van lettertypes die dezelfde 
kenmerken bevatten, zoals bijvoorbeeld de schriften of de lettertypes met schreven. Lettertypes of letterfamilies zijn de 
overkoepelende term voor de verschijningsvormen die een letter kan aannemen, aangeduid door een naam zoals Verdana 
of Myriad Pro. Een font is één van de varianten die bestaan van elk lettertype, ook wel de gradatie, de vetheidsgraad of de 
lettersoort genoemd. In één lettertype kunnen er meerdere fonts geplaatst worden, zoals de Roman, de Italic. Benamingen 
kunnen afwijken. Zo wordt er voor de Roman ook wel Normaal, Normal, Medium of Regular gebruikt.

2.  WAT IS GLYPHS?

2.1.  GLYPHS INSTALLEREN

2.2.  GLYPHS EN DE LICENTIES

http://www.fontlab.com/font-editor/fontlab-studio/
http://www.fontlab.com/font-editor/fontographer/
http://www.glyphsapp.com
http://www.glyphsapp.com
http://www.glyphsapp.com
http://www.glyphsapp.com
http://www.glyphsapp.com
http://www.glyphsapp.com
http://www.glyphsapp.com/get-glyphs
http://www.glyphsapp.com/get-glyphs
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Er worden regelmatig nieuwe (grote en kleine) updates uitgebracht van Glyphs. Glyphs vraagt 
éénmaal of er gecontroleerd moet worden op updates. Indien ingeschakeld wordt er 
tijdens het opstarten van Glyphs een bericht getoond wanneer er een nieuwe update 
beschikbaar is. De instellingen van de updates zijn terug te vinden in de voorkeuren van 
het programma. Ga naar het menu Glyphs -> Preferences (voorkeuren) en op de eerste 
tab zijn alle voorkeuren in verband met Updates terug te vinden:

De eerste optie, Automatically check for updates, geeft aan of de app automatisch mag 
zoeken naar updates. De tweede optie, Show cutting edge versions, geeft aan of er bij 
de updates ook beta-software gedownload mag worden. Beta-software zijn programma’s 
die nog niet volledig voltooid zijn, en die mogelijk zullen vastlopen. Deze optie is vooral 
interessant wanneer er een onderdeel uit Glyphs niet naar behoren werkt. Door de beta te 
downloaden kan er controleerd worden of de ontwikkelaars dit reeds opgelost hebben in 
een toekomstige versie van Glyphs.

Doet er zich een probleem voor met Glyphs, dan zijn er altijd de forums waar iedereen terecht 
kan: www.glyphsapp.com/forums. Communicatie gebeurt op deze site in het Engels of 
in het Duits. De ontwikkelaars van Glyphs, Georg Seifert en Erich Scheichelbauer Rainer, 
lezen deze websites regelmatig zelf na en komen waar mogelijk te hulp. Een probleem 
of onderdeel van het programma dat niet naar behoren werkt kan op deze manier snel 
gerapporteerd en opgelost worden.

2.3.  NIEUWE UPDATES

2.4.  PROBLEMEN RAPPORTEREN

http://www.glyphsapp.com/forums
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De eerste keer dat het programma Glyphs start ziet dit er als volgt uit: bovenaan de menubalk 
en één zwevend venster dat verschillende onderdelen bevat. In het venster zijn enkele 
onderdelen te herkennen die hier één voor één besproken worden: de werkbalk (Toolbar), 
de navigatie, de zijbalk (Sidebar) en een overzicht van de aanwezige glyphs. 

 
 

Het overgrote deel van het venster is een overzicht van alle glyphs aanwezig in het font. 
Standaard bevat een font in Glyphs zesentwintig kapitalen en zesentwintig onderkasten 
uit het Latijnse alfabet, samen met een spatie. Onderaan staan een plus- en een minteken 
om glyphs toe te voegen of te verwijderen. De naam van een glyph is te veranderden 
door de glyph te selecteren en daarna op de naam te klikken. Onderaan het venster 
staat informatie over het lettertype: het totaal aantal geselecteerde glyphs en hoeveel 
glyphs het totale font bevat. Daarnaast is er een kader waarmee er in het font gezocht 
kan worden: als er enkele duizenden lettervormen getekend zijn, is het gemakkelijker om 
er eentje terug te vinden via een zoekopdracht. De ronde knop aan de rechterzijde kan 
verschoven worden om in te zoomen op het overzicht van glyphs.

3.  HET UITERLIJK VAN GLYPHS
3.1.  DE EERSTE KEER OPSTARTEN
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De eerste knop op de menubalk bovenaan is het altijd aanwezige Apple-logo, gevolgd door 
de naam van het programma waaronder zich de algemene functies van elk programma 
bevinden, zoals informatie over het programma, het zoeken naar updates, de voorkeuren 
(preferences) of het stoppen van het programma.

Hierna volgen de menu-items waarmee er aan het font gewerkt wordt. Het eerste item is 
het altijd voorkomende menu File (afwisselend Bestand of Archief in het Nederlands). 
Onder dit menu zijn opties te vinden gerelateerd aan bestanden in het algemeen. Er is de 
mogelijkheid om een nieuw bestand te creëren, bestaande bestanden te openen, recent 
geopende bestanden terug te vinden, bestanden te sluiten, op te slaan, informatie over 
bestanden op te vragen, bestanden te importeren, te exporteren, af te drukken en andere 
algemene commando’s.

Hierop volgt het menu Bewerk (Edit), waar zoals gewoonlijk de opties ongedaan maken (Undo) 
en opnieuw (Redo) terug te vinden zijn. Ook de opties kopiëren (Copy) en plakken (Paste) 
zijn hier terug te vinden samen met de zoekoptie (Find), een menu om speciale tekens in 
te voeren enz.

De volgende drie menu’s zijn specifiek om met het programma te werken: Glyph (Glyphs), 
Paden (Paths) en Filter (filter). Deze menu-items worden later nog besproken.

Daarna volgt het menu Weergave (View). Dit doet letterlijk wat het zegt: beheren wat er op het 
computerscherm wordt weergegeven. Hier is het onder andere mogelijk om op het beeld 
in te zoomen en hulplijnen en andere visuele elementen aan of uit te schakelen.

Het menu Script (Script) is leeg in het begin. Met een beetje kennis over programmeren is het 
mogelijk om repetitieve taken vast te leggen in een script en door de computer te laten 
uitvoeren. Die zelf geschreven scripts komen dan in dit menu terecht. Dit onderdeel wordt 
behandeld in “2*  Macro’s en scripts” op pagina 67.

De menu’s Venster (Window) en Help (Help) tenslotte werken opnieuw zoals de overige 
OS X programma’s: in het eerste menu zijn de openstaande vensters te beheren of 
bijkomende vensters te openen. In het menu Help is er snel toegang tot informatie over 
het programma.

Vele van deze menu’s beschikken over sneltoetsen. Dit is sneller dan elke keer met de muis 
naar boven te bewegen en het gewenste item in een menu te zoeken. Zie hiervoor het 
hoofdstuk “5*  Sneltoetsen in Glyphs” op pagina 89.

Op de werkbalk bovenaan het programma bevinden zich slechts enkele knoppen. De eerste 
knop opent een venster met de fontinformatie. Dit venster wordt later in dit hoofdstuk 
besproken en nog uitgebreider in hoofdstuk “4.  Aan een font beginnen” op pagina 14. 
De tweede en derde knop veranderen de weergave van het font. Zo kan er gewisseld 
worden tussen miniaturen van alle glyphs en Cover Flow samen met een lijst van alle 
glyphs die in het font aanwezig zijn. Deze lijst is handig omdat er zeer snel zeer veel 
informatie uit af te leiden is, zoals in de volgende afbeelding getoond wordt. De middelste 
reeks van knoppen op de werkbalk zijn nu grijs: dit zijn de gereedschappen die actief 
worden zodra er begonnen wordt met het tekenen van een glyph. De laatste knop toont of 
verbergt de zijbalk.

3.2. DE MENUBALK 

3.3.  DE WERKBALK

De lijstweergave van Glyphs, 
waar er meer details 
weergegeven worden van 
iedere glyph.
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Net zoals in vele programma’s voor OS X bevat Glyphs een verticale balk aan de linkerzijde. 
Hiermee is er de mogelijkheid om slechts specifieke delen uit het font weer te geven. 
Standaard toont Glyphs alle glyphs uit het lettertype: dit bevindt zich bovenaan in het item 
Alles (All).

Daaronder bevinden zich andere categorieën, zoals alle letters (Letter), alle nummers (Number), 
leestekens enz. Door op de pijltjes te klikken verschijnen er verdere verfijningen. Behalve 
per categorie kunnen glyphs hier opgedeeld worden per taal waarin ze voorkomen. Zo is er 
o.a. het Latijnse, Cyrillische en Griekse schrift.

Daarnaast zijn er filters: eigen groeperingen van glyphs die de gebruiker aanmaakt. Zo is het 
bijvoorbeeld mogelijk om alle glyphs met een accent samen te plaatsen. Filters aanmaken, 
wijzigen en verwijderen gebeurt met het tandrad onderaan. De optie List Filter (filter op 
basis van een lijst) maakt het mogelijk glyphs op te sommen die bij elkaar weergegeven 
moeten worden. De optie Custom Filter (aangepaste filter) kan glyphs groeperen op basis 
van een bepaald kenmerk, zoals bijvoorbeeld een kleur die aan een glyph toegekend is (zie 
later). Hier is het bijvoorbeeld mogelijk om alle glyphs met een rode kleur uit het font 
weer te geven in een lijst. Deze custom filters passen zichzelf automatisch aan: als er een 
nieuwe glyph met een kleur toegevoegd wordt, wordt deze automatisch in eerder 
gecreëerde lijsten bijgeplaatst.

Verder bevat de zijbalk nog een klein palet met de glyph eigenschappen 
(Glyph Properties). De hierop weergegeven informatie verandert 
naargelang de glyph of glyphs die geselecteerd zijn in het font. In 
dit kleine palet wordt bovenaan de naam van de geselecteerde 
glyph vermeld. De naamgeving wordt besproken in “6.  Glyphs 
toevoegen” op pagina 35. Onder de naam staan de waarden 
van de witruimte links en rechts, samen met de totale breedte 
van de glyph, inclusief de witruimten links en rechts. Deze worden 
besproken in “8.1.  De letters spatiëren (stellen)” op pagina 44. 
De Kerning groups (kerninggroepen) daaronder worden besproken 
in “8.3.  Witruimten corrigeren: de kerning” op pagina 47. De 
optie export toont of de geselecteerde glyph in het uiteindelijk geëxporteerd font terecht 
komt en is meestal aangevinkt. Als voorlaatste kan er onderaan een kleur toegekend 
worden aan de geselecteerde glyph(s). Kleuren toekennen aan een glyph heeft geen 
functie in het latere font maar dient enkel om bepaalde glyphs gemakkelijker terug te 
vinden. Zo bestaat er de techniek om alle voltooide glyphs groen te kleuren en glyphs die 
fouten bevatten rood te kleuren. Iedereen ontwikkelt zijn eigen kleurencode. Ten slotte 
staat er onderaan de Unicode van de glyph. Vele glyphs hebben een wereldwijd geldende 
code, waaraan zij herkenbaar zijn1.

De eigenschappen van een glyph zijn ook terug te vinden in andere onderdelen van het 
programma. Daarom is dit paneel als het niet nodig is altijd te verbergen met de tweede 
knop onderaan.

1. Zie de website unicode.org. Deze organisatie houdt zich bezig met alle glyphs in alle  schriften en talen ter wereld te inventariseren er er 
een unieke code aan toe te wijzen. Deze code bestaat uit 4 letters en/of cijfers.

3.4.  DE NAVIGATIEBALK

http://www.unicode.org/
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De glyphs die standaard aanwezig zijn in een nieuw font zijn leeg: zij bevatten geen vorm. 
Enkel een grijze letter geeft een indicatie van de vorm die er zou moeten staan. Door te 
dubbelklikken op een glyph2 verdwijnt het overzicht, verschijnt er een grote grijze letter en 
een tabbalk bovenaan. Deze ruimte waarin aan de letter gewerkt wordt is in deze cursus 
benoemd als de werkruimte (Edit view).

Hoe het tekenen van glyphs in zijn werk gaat, wordt in het volgende hoofdstuk uitgelegd: 
“4.  Aan een font beginnen” op pagina 14. Merk alvast op hoe de gereedschappen 
in de werkbalk zwart kleuren: zij zijn vanaf nu bruikbaar. Ook de knoppen onderaan het 
venster veranderen: de knoppen die nu verschijnen hebben betrekking op hoe de glyph(s) 
weergegeven worden in de werkruimte.

Teruggaan naar het overzicht met alle letters kan via verschillende manieren: door in de tabbalk 
die net onder de werkbalk verschenen is op de eerste tab (met de naam Font ) te klikken, 
of via het menu View -> Close Tab (tabblad sluiten), of via het menu View -> Show 
previous tab (vorig tabblad tonen).

Het uitzicht van het venster van Glyphs verandert dus regelmatig. Enerzijds dient het venster om 
een overzicht van de aanwezige glyphs weer te geven. Daarin zijn de glyphs herkenbaar 
die reeds getekend zijn (zwarte lettervormen) en de glyphs die nog niet getekend zijn 
(grijze lettervormen). Anderzijds verandert hetzelfde venster in een werkruimte. Dit geeft 
één of meerdere glyphs weer en biedt de mogelijkheid om alle kenmerken van de glyph, 
zoals de bepaalde waarden of de vorm, te bewerken.

2 Meerdere glyphs tegelijkertijd openen in een werkruimte is ook mogelijk. In het overzicht kunnen er meerdere glyphs 
geselecteerd worden door te klikken en te slepen. Een bestaande selectie kan ook uitgebreid worden door tijdens het klikken de 
command- of de shifttoets in te houden. Dubbelklik op alle geselecteerde glyphs om deze allemaal in de werkruimte te openen.

3.5.  GLYPHS WEERGEVEN

De werkruimte van Glyhs 
waarin de letters getekend 
worden. Let ook op de tabs 
die het mogelijk maken 
om tussen verschillende 
werkruimten en het 
overzicht met alle Glyphs te 
wisselen.
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Er staan maar weinig knoppen in het venster van Glyphs. Dit komt 
de eenvoud ten goede. Alle extra opties zitten weggestopt in 
een zijbalk die verborgen kan worden met de knop rechts op de 
werkbalk.

Het eerste onderdeel van dit palet dient als spiekbriefje: hier kunnen 
enkele afmetingen voor de glyphs neergeschrijven worden 
door op de stippellijntjes te klikken. De in dit venster ingegeven 
maten hebben geen enkele invloed op het font; zij zijn enkel een 
herinnering tijdens het ontwerpen.

Verder geeft dit palet een overzicht van alle aanwezige hulpmiddelen om 
(letter)vormen te tekenen. De Layers (lagen) worden besproken in 
hoofdstuk “7.  Werken met achtergrond en lagen” op pagina 42. 
De overige knoppen, die dienen voor het bewerken van de glyphs, 
komen aan bod in het hoofdstuk “4.  Aan een font beginnen” op 
pagina 14.

3.6.  DE ZIJBALK
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De eerste knop op de werkbalk geeft toegang tot de fontinformatie: een venster dat alle 
informatie over het lettertype bevat. Dit venster is niet continu nodig maar is eerder de 
samenvatting van alle gegevens uit het font. Het bestaat uit vijf tabbladen, waarvan de 
eerste tab actief is.

In deze eerste tab krijgt het font (en eigenlijk het volledige lettertype) een naam (Family Name) 
en worden de gegevens van de ontwerper (Designer) en verkoper (Manufacturer) 
ingevuld. Dit gebeurt best voordat er aan een font begonnen wordt en het maakt nadien 
ook het bewaren van het bestand gemakkelijker. Onderaan dit venster staat een lege lijst 
voor Custom Parameter. Klik op het plusteken om items toe te voegen. Uit de keuzelijst 
zijn termen uit de typografische wereld herkenbaar die in het font opgenomen kunnen 
worden als extra informatie. De parameter glyphOrder zal bijvoorbeeld na het exporteren 
de glyphs in een andere volgorde plaatsen dan dat ze nu weergegeven worden. Na het 
selecteren van een Custom Parameter is het mogelijk om gegevens toe te voegen in het 
veld aan de rechterzijde. Geen van deze parameters zijn een directe vereiste om in te 
voegen. De vier andere tabbladen in dit venster komen vanaf het volgende hoofdstuk 
regelmatig aan bod.

3.7.  FONTINFORMATIE
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WERKEN IN FONTLAB 5
In tegenstelling tot Glyphs bestaat FontLab 5 uit zeer veel losse werkbalken en vensters. Het 

programma toont eerst een overzicht van alle in het font aanwezige glyphs. Dubbelklik op 
een glyph om deze te bewerken. Elke glyph verschijnt in een apart venster.

Via het menu Window -> Panels worden bijkomende paletten & werkbalken ingeschakeld, 
de beste werkomgeving kan pas bepaald worden na wat ervaring. Wanneer de beste 
werkomgeving gevonden is kan deze in het menu Window -> Workspace bewaard worden.
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WERKEN IN ROBOFONT
Net zoals FontLab bestaat Robofont uit verschillende vensters met elk een eigen functie. Het 

eerste venster is het overzicht met een lijst van alle aanwezige glyphs. De knoppen 
linksboven op de werkbalk openen verschillende andere vensters, terwijl de knoppen 
rechtsboven een zoekbalk en een zijbalk openen. In deze zijbalk kan de gebruiker naar 
eigen behoefte glyphs in groepen onderbrengen, net zoals in het programma Glyphs. Dit 
gebeurt met de opties verborgen achter het tandrad linksonder in het venster.

Klik dubbel op een glyph om deze te bewerken. Een nieuw venster verschijnt met nieuwe 
knoppen op de werkbalk. De gereedschappen linksboven veranderen de vorm van de 
glyph. In een andere laag tekenen kan met het menu rechtsboven in dit venster. Via het 
menu Window -> Inspector is er toegang tot een paneel waarin alle gegevens over deze 
letter af te lezen zijn of veranderd kunnen worden.
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Weten waar alle opties in een programma verborgen zijn is belangrijk. Meestal staat in 
Glyphs alles kant en klaar om te beginnen aan een font, maar hier en daar moet er iets 
veranderen om een optimaal resultaat te verkrijgen. Dit hoofdstuk behandelt allereerst 
de algemene instellingen die in elk font ingegeven moeten worden. Daarna volgen 
meer optionele stappen zoals het importeren van reeds bestaand werk, het invullen van 
aangepaste waarden en ten slotte het gebruiken van (ingescande) tekeningen als een 
achtergrond.

Alle goede lettertypes met alle bijhorende fonts vertrekken van ideeën, conceptnota’s, 
experimenten enz. Eerst wordt er beslist wat het doel is van het lettertype en waarvoor 
het gebruikt zal worden. wordt het een displaylettertype of wordt het een lettertype voor 
leesteksten? Er worden handmatig schetsen gemaakt, vaak op millimeterpapier, totdat 
er een indicatie is hoe het lettertype er ongeveer uit zal zien. Daarna wordt er pas op de 
computer gewerkt. (In de realiteit zijn fouten nog altijd beter te zien op papier dan op een 
computerscherm.)

Wie voorbereid wil zijn op gemakkelijk digitaal werk, tekent de schetsen op millimeterpapier 
10cm hoog, zodat er een onderverdeling is van 10 vakjes (tenzij er een reden is om daar 
van af te wijken). Deze onderverdeling vergemakkelijk nadien de overstap naar het digitale 
werk.

4.  AAN EEN FONT BEGINNEN

4.1.  HET HANDMATIGE WERK

Het lettertype Matilda:
ontwerpschetsen
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Vóórdat er ook maar iets aan het font gedaan wordt dient het een naam te krijgen. Dit maakt 
het gemakkelijker om het bestand nadien terug te vinden. Ga naar de fontinformatie (de 
eerste knop op de werkbalk of via het menu File -> Font Info…) en vul op de eerste tab 
alle velden in. Onder Custom Parameter kan extra informatie ingevuld worden maar dit 
is ook nog mogelijk later in het ontwerpproces. Voorbeelden hiervan zijn glyphOrder, de 
volgorde waarin de glyphs in het uiteindelijke font zullen staan, of sampleText, een tekst 
die opgegeven kan worden en waarin (sommige) andere programma’s het font tonen 
wanneer latere gebruikers het bekijken. Bewaar daarna het bestand met het menu File -> 
Save… op de computer zodat het niet verloren kan gaan.

In de namen van fonts zijn geen vreemde tekens zoals bijvoorbeeld Ô en ê toegelaten. Gebruik daarom enkel standaard letters en spaties.

4.2.  ALGEMENE INSTELLINGEN
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FONTLAB
De informatie over een font is terug te vinden onder het menu File -> Font Info… In FontLab is 

de in te vullen informatie verspreid over de elf eerste menu-items. Bepaalde onderdelen 
automatisch invullen is mogelijk door op de diamant te klikken.

ROBOFONT
De derde knop op de werkbalk geeft toegang tot de Fontinformatie. De in dit hoofdstuk 

besproken gegevens zijn terug te vinden in de tab General (Algemeen). Het tabblad 
Miscellaneous (diversen) bevat dezelfde gegevens maar dan aangepast aan andere 
lettertypestandaarden. RoboFont vult deze automatisch in indien gewenst.
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Projecten aangevangen in een ander programma, zoals een font gecreëerd in FontLab of 
Fontographer, kunnen in Glyphs afgewerkt worden mits zij in het programma Glyphs 
geopend kunnen worden. Maak eerst een kopie van de originelebestanden, zodat er niets 
verloren kan gaan. Er mag ook niets gestolen worden, dus let op wie de rechten heeft op 
een bepaald bestand. Hoe zou jij het vinden als men later jouw bestanden zou stelen?

INSTELLINGEN IN GLYPHS
Glyphs werkt met een eigen systeem van naamgeving dat vele glyphs herkenbaarder maakt. 

Als de namen van glyphs uit bestaande bestanden niet mogen wijzigen, verander dan op 
voorhand twee instellingen. Als de naamgeving niet belangrijk is dan kunnen volgende 
stappen overgeslagen worden.

De eerste plaats om de eigen naamgeving van Glyphs uit te schakelen is onder het menu Glyphs 
-> Preferences en dan onder de tab User Settings (gebruikersinstellingen). Vink de eerste 
optie aan, zodat er tijdens het importeren geen namen veranderen:

In hierna geïmporteerd bestaand werk blijven de bestaande namen behouden. Open daarna de 
fontinformatie en ga naar de laatste tab: Other Settings (andere instellingen). Schakel Use 
custom naming (Gebruik aangepaste namen) in. Glyphs zal dan zijn eigen naamgeving 
niet gebruiken in het actieve bestand.

4.3.  BESTAANDE BESTANDEN IMPORTEREN
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BESTANDEN EN GEGEVENS IMPORTEREN
Er zijn verschillende bestanden waarmee Glyphs overweg kan. De keuze is afhankelijk van wat 

er ter beschikking is. Niet alle programma’s kunnen elk type van bestand aanmaken en 
Glyphs kan ook niet zo maar alle soorten bestanden openen.

Het importeren van technische gegevens kan via het menu File -> Import. Kies contouren 
(Outlines), Metrics (Metrics) of Features (Features)1 om te importeren in het actieve font. 
Glyps importeert deze gegevens dan in het actieve project.

Glyphs kan ook overweg met UFO-bestanden (Unified Font Object). Dit is “een cross-platform, 
programma-onafhankelijk toekomstgericht bestandsformaat om font-gegevens te bewaren 
en dat door mensen gelezen kan worden” (Leming, van Rossum, van Blokland 2015). Open 
dit soort bestanden in Glyphs met het menu File -> Open… Daar veel font-programma’s 
font-gegevens kunnen opslaan als een ufo-bestand, is dit de gemakkelijkste manier om 
bestanden naar een ander programma over te zetten.

Voor lettertypes ontwikkeld in FontLab bestaat er ook het ‘export script,’ dat openstaande 
bestanden uit FontLab bewaart als een Glyphs-bestand. Dit script staat op https://github.
com/schriftgestalt/Glyphs-Scripts/blob/master/Glyphs%20Export.py. Installeer dit script 
in FontLab en activeer het zodat het actieve bestand omgezet wordt naar een Glyphs-
bestand.

Mochten de originele bestanden van een project er niet meer zijn dan is het mogelijk om 
bestaande font-bestanden te importeren. Glyphs kan overweg met OpenType (.otf) en 
TrueType (.ttf) fonts. Deze kunnen geopend worden door in Glyphs het menu File -> 
Open… te gebruiken of door in de Finder rechtermuisklik -> open met -> Glyphs uit te 
voeren op het gewenste bestand.

Let wel dat bestanden importeren niet altijd feilloos verloopt. OpenType en TrueType bestanden bijvoorbeeld zijn niet meer bedoeld 
om nog bewerkt te worden, zij zijn enkel geschikt om de (letter)vormen te bepalen wanneer er in een ander programma 
getypt wordt. Niet alle gegevens kunnen uit alle bestanden gehaald worden en bepaalde data kan verloren gaan, voornamelijk 
spatiëring, kerning en Features.

1. Ook de termen Metrics (~maatsystemen) en Features (~eigenschappen, mogelijkheden) verwijzen naar begrippen die in het 
Nederlands (binnen de typografie) nooit vertaald worden worden.  De Engelstalige woorden blijven aldus behouden in deze 
Nederlandse cursus.

https://github.com/schriftgestalt/Glyphs-Scripts/blob/master/Glyphs%20Export.py
https://github.com/schriftgestalt/Glyphs-Scripts/blob/master/Glyphs%20Export.py
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Houd nu de ontwerpschetsen van het lettertype in de buurt. Glyphs wil enkele maten uit die 
schetsen kennen die typerend zijn voor het ontwerp dat uitgewerkt wordt: de UPM, het 
grid, de x-hoogte, de kapitaalhoogte en de stok- en staarthoogte.

De eerste waarde, de UPM, is gerelateerd aan de hoogte van het lettertype. Het probleem 
is echter dat deze hoogte nooit een vast gegeven is: als een gebruiker een korps van 9 
punten opvraagt is de totale hoogte anders dan wanneer een gebruiker een korps van 14 
punten vraagt. Daarom wordt de hoogte van het font uitgedrukt in de Em grootte. De Em 
grootte is (ongeveer) gelijk aan de totale grootte van de glyph: van stok tot staart. De 
ontwerper mag hier iets van afwijken, maar dit is niet zonder risico: alles wat buiten de 
Em grootte komt zal overlappen met de vorige of volgende tekstregel als er geen extra 
regelafstand ingevoegd wordt door de vormgever. 
 

 

Deze Em grootte wordt daarna nog eens onderverdeeld in een aantal gelijke delen: de Units 
per Em met als afkorting UPM. Standaard staat de UPM op 1000 units, wat duizend 
onderverdelingen in de hoogte van het font betekent. Als de ontwerpschetsen zeer 
complex zijn, is het mogelijk op een fijnere onderverdeling te werken, zodat details 
met een grotere precisie uit te tekenen zijn. Dit is in te stellen in de eerste tab van de 
fontinformatie. De totale onderverdeling voor een OpenType lettertype is gelimiteerd 
tot 16.384 UPM (www.microsoft.com/OpenType/OTSpec/head.htm). Een UPM van 1000 
is echter aan te raden om nadien te exporteren als een OpenType (otf) bestand (duizend 
is de standaard) en een UPM van 2048 is aan te raden om nadien te exporteren als een 
TrueType (.ttf) (2048 is daar de standaard).

Deze maten zijn ter informatie. Spring daar verstandig mee om, maar limiteer je niet tot. Mocht een tekstprogramma je glyphs 
verkeerd, te groot, te klein of zelfs volledig niet weergeven, dan is de UPM de eerste plaats om te kijken als deze anders is dan 
1000. Adam Twardoch, ontwikkelaar bij FontLab Ltd, geeft als advies ‘ga niet groter dan noodzakelijk.’ (www.typophile.com/
node/30913#comment-180890) 
Afwijkende getallen in de UPM zouden geen probleem mogen wezen, maar sommige programma’s zullen niet goed reageren. 
Microsoft Word geeft bijvoorbeeld problemen boven de 3000 UPM, en InDesign heeft wel eens problemen als de breedte van 
individuele glyphs boven een totaal van 4095 UPM komt.

Om compatibel te zijn met Type1 lettertypes, dan is de oorspronkelijke maximale verdeling 2000 coördinaten in de negative en 2000 
coördinaten in de positieve richting (partners.adobe.com/public/developer/en/font/T1_SPEC.PDF sectie 3.3). Hoewel in praktisch 
gebruik vaak ±4095 als totale breedte genomen werd.

Het is ook mogelijk om een reeds digitaal uitgetekend font herschalen met de dubbele pijltjes die achter de UPM wordt weergegeven (tip: 
bekijk dat schalen procentueel).

Daarna wordt de UPM gebruikt om het uiteindelijke grid op te stellen. Met 1000 units per Em 
zal elk onderdeel van het grid 1/1000e van de Em grootte zijn. Een andere waarde in de 
UPM zal een andere onderverdeling van het grid opleveren. 

Visueel is dit grid enkel zichtbaar na veel inzoomen in de werkruimte (10.000 maal, zo fijn 
is het). Voor het tekenwerk is het mogelijk om een beter geschikt grid in te stellen. Dit 
gebeurt in de fontinformatie onder de tab Other Settings (Andere instellingen). De optie 
gridspatiëring (Grid spacing) geeft aan om de hoeveel UPM een dikke gridlijn getekend 
wordt. De onderverdeling (subdivision) geeft aan in hoeveel delen dit dikke grid nogmaals 
onderverdeeld wordt.

4.4.  DE WAARDEN VAN UPM, GRID EN METRICS

De Em omscrhijft de totale 
hoogte van het font, 
onafhankelijk van het korps. 
Wat hier buiten valt overlapt 
een andere regel in zetwerk. 
Het is aan de ontwerper om te 
bepalen of dit fijn oogt.

http://www.microsoft.com/OpenType/OTSpec/head.htm
http://www.typophile.com/node/30913#comment-180890
http://www.typophile.com/node/30913#comment-180890
http://partners.adobe.com/public/developer/en/font/T1_SPEC.PDF
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Vul bijvoorbeeld in Grid Spacing het getal 100 in zodat er tien onderverdelingen over de totale 
hoogte van de glyph verschijnen, net zoals op het millimeterpapier. Klik terug in het andere 
venster om de verandering te zien zoals op onderstaande afbeelding:

Dit grote grid is een goed visueel hulpmiddel, maar niet geschikt om op te werken. Probeer nu 
maar eens met het tweede gereedschap in het midden van de werkbalk te tekenen: waar 
je ook klikt, zelfs in het midden van het grid, het punt dat je tekent zal geplaatst worden 
op een kruispunt in dit véél te grote grid2. Om fijn te kunnen tekenen kan dit grote grid 
nogmaals verdeeld worden in kleinere delen. Doe dit met de subverdeling (Subdivision) in 
de fontinformatie. Geef bijvoorbeeld een waarde 10 in en klik opnieuw in het venster met 
de werkruimte. Zoom in om het veel fijnere grid te zien waar gemakkelijker op te tekenen 
is. Het grid met deze waarden komt nu overeen met het grid van het millimeterpapier. Dat 
werkt gemakkelijk. Speel hier elke keer opnieuw mee totdat er een bruikbaar mogelijk grid 
ontstaat voor elk project.

Het is mogelijk om het grid kleiner te maken dan 1 UPM (een kommagetal dus) door de subverdeling nog groter te maken. Dit geeft een 
zeer fijn grid om op te werken, en het is een betere oplossing dan de UPM te veranderen.

2. In Glyphs wordt dus niet getekend op de UPM. In Glyphs wordt getekend op het grid, dat op zijn beurt wel gebaseerd is op de UPM.

Volgens deze instellingen 
wordt er om de 100 units een 
gridlijn getrokken.

Binnen een UPM van 1000 
vertaalt zich dit in een glyph 
dat in tien gelijke delen 
verdeeld wordt.
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Nadat de waarde van de UPM is ingesteld volgen ook de waarden van de x-hoogte (x-Height), 
kapitaalhoogte (Cap Height), stokken (Ascender), en staarten (Descender). Dit gebeurt in 
de tweede tab van de fontinformatie, in de kolom Metrics (Metrics):

Meet op de schetsen de waarden van deze gegevens en vul deze in. Mits de waarde van de UPM 
1000 is en er op het millimeterpapier tien centimeter hoog getekend is, is dat gemakkelijk: 
elke millimeter komt overeen met een waarde van 10 UPM. Elke waarde kan meestal 
gevonden worden in rechte toppen zoals bijvoorbeeld de bovenzijde van de letter x of de 
letter H, maar niet in de overshoot3 van ronde letters.

Enkele opmerkingen dienen in acht genomen te worden, bijvoorbeeld dat Glyphs een negatieve 
waarde vereist voor de staart (Descender). Daarnaast geldt de richtlijn dat de som van 
de absolute waarden (de waarde zonder de min) van de stok (Ascender) en van de staart 
(Descender) overeen komt met de UPM. Wijk hier enkel van af als nodig: het kan (iets) 
kleiner zijn, maar groter is een risico. Wanneer er over de UPM heen gegaan wordt, 
kunnen tekstregels elkaar gaan overlappen. Online zijn er hevige discussies te vinden 
over de beste interpretaties. Daarnaast zijn deze waarden op verschillende manieren 
geïnterpreteerd doorheen de tijd. Zeer handige informatie over al deze waarden is terug te 
vinden op www.glyphsapp.com/tutorials/vertical-metrics. Controleer de ontwerpschetsen 
op fouten en daarna is het bestand klaar om de glyphs te tekenen.

Onderaan de tweede tab in de fontinformatie is er opnieuw een veld genaamd Custom Parameter terug te vinden. Voeg hier eventueel 
bepaalde parameters toe zoals de afstand waarop het font onderlijnd zal worden.

3. Een curve lijkt visueel iets kleiner dan een rechte zijde. Om dit te corrigeren bestaat er de overshoot waar ronde curves iets verder 
doorlopen dan rechte zijden. Een letter o loopt bijvoorbeeld iets onder de basislijn en iets boven de x-hoogte uit.

http://www.glyphsapp.com/tutorials/vertical-metrics
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Sommigen vinden het gemakkelijker om de handmatige schetsen in te scannen en als 
achtergrond in de glyph in te voegen om daar overheen te tekenen. Dat is mogelijk in 
Glyphs door ofwel een afbeelding uit de Finder naar Glyphs te slepen, ofwel via het menu 
Layers -> Add Image… een afbeelding in te voegen.

Afbeeldingen worden niet in het Glyphs-bestand bewaard. Er wordt enkel een link gelegd naar de afbeelding, dus bewaar de afbeeldingen 
op dezelfde plaats als het Glyphs-bestand en vergeet niet beiden tegelijkertijd te verplaatsen als nodig.

De ingescande afbeelding heeft vaak niet het juiste formaat. In het programma Photoshop is dat 
aan te passen: daar is 1 point in gelijk aan 1 UPM in Glyphs. Gebruik dit tijdens het schalen 
en bijsnijden. De grootte in Glyphs veranderen kan door op de afbeelding te klikken en in 
de grijze kader onderaan de schaal te veranderen totdat de afbeelding overeen komt met 
de juiste hoogte op het grid. Houd de muis ingedrukt op de afbeelding en sleep om de 
positie van de afbeelding te veranderen. Het grijze blokje rechts onderaan geeft ook de 
locatie weer in coördinaten van de geselecteerde afbeelding.

TIP: maak de afbeeldingen zo klein mogelijk. Snijd bijvoorbeeld elke individuele glyph uit in een programma zoals Photoshop. Dit werkt 
gemakkelijker en sneller tijdens het tekenen.

Als de afbeelding correct staat, vergrendel deze dan via het slotje in de grijze kader, oftewel via 
rechtermuisklik -> Lock Image. Hierdoor is de afbeelding niet meer vast te nemen en kan 
de afbeelding niet meer per ongeluk verschuiven. De afbeelding ontgrendelen kan altijd 
door er  rechtermuisklik -> Unlock image op uit te voeren.

4.5.  EEN AFBEELDING ALS ACHTERGROND

Een in Glyphs ingevoegde 
en geselecteerde 
achtergrondafbeelding. 
Details zoals de grootte 
kunnen in de grijze infokader 
aangepast worden.



23

FONTLAB
De metrics bevinden zich in File -> Font Info… De tab Metrics and Dimensions bevat de 

UPM. De overkoepelende naam voor de x-hoogte, stokken, staarten,… in FontLab is Key 
dimensions, een item lager.

ROBOFONT
In RoboFont krijgen metrics de naam Dimensions (Dimensies). Hier is de UPM ondergebracht 

in de Fontinformatie, de derde knop in de werkbalk. De tab General (Algemeen) bevat de 
algemene metrics.
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Het voorbereidingswerk zoals beschreven in het hoofdstuk “4.  Aan een font beginnen” op 
pagina 14 maakt het gemakkelijk om correcter te tekenen: de benodigde maten zijn 
ingegeven en er is eventueel een afbeelding als achtergrond ingesteld, wat een goede 
houvast biedt. Dit hoofdstuk behandelt het tekenen van de lettervormen. Teken mee 
gedurende het lezen van deze uitleg, dat is de beste manier om alles onder de knie te 
krijgen.

Begin met het gereedschap Primitieven (Primitives), het vierde gereedschap in het midden 
van de werkbalk. Teken hiermee de Rechthoek (Rectangle) en de Cirkel (Circle) (wissel 
door de muisknop een tijd lang op de knop in te houden). Er zijn twee mogelijkheden om 
te tekenen: klik op de plaats waar de vorm moet beginnen en houd muisknop ingedrukt. 
Beweeg dan naar de plaats waar de vorm moet eindigen en laat daar de muisknop terug 
los. Een tweede tekenmethode is kort klikken in het werkgebied en direct los laten: er 
verschijnt dan een venster met de vraag hoe groot het vierkant of de cirkel exact dient te 
zijn.

Getekende vormen bestaan uit lijnen, genaamd paden (paths). Elk pad loopt van punt naar 
punt, genaamd knooppunten of nodes. Deze punten kunnen blauw of groen zijn. Blauwe 
nodes zijn hoekpunten, groene nodes zijn onderdeel van een curve, het pad loopt hier 
vloeiend doorheen: 

Het gereedschap Selecteren (Select) verplaatst de vorm. Klik en houd de muisknop ingedrukt 
op de node om te verplaatsen. Op deze manier kan het vierkant of de cirkel vervormd 
worden. Selecteer meerdere nodes om deze tegelijkertijd te verplaatsen. Dit kan door te 
dubbelklikken op een lijn, dan is het volledige pad geselecteerd. Of door het inhouden 
van de Shift-toets en vervolgens één voor één op verschillende nodes te klikken. Het is 
ook mogelijk om met het selectiegereedschap buiten de contour te klikken, de muisknop 
ingedrukt te houden en over de gewenste punten heen te bewegen voor los te laten. Alle 
nodes binnen de selectie worden geselecteerd (donkerder gekleurd). 

Alle nodes worden gepositioneerd op het ingestelde grid. De exacte coördinaten van een 
geselecteerde node worden in de grijze kader onderaan weergegeven. Het is mogelijk om 
op deze getallen te klikken en dan een nieuwe waarde in te geven, gevolgd door enter.

Vormen niet gebaseerd op cirkels en rechthoeken kunnen moeilijk met het gereedschap 
Primitieven uitgetekend worden. Het gereedschap Teken (Draw), het tweede gereedschap 
in het midden van de werkbalk, is hier geschikter voor. Dit gereedschap ziet er uit als een 
pen en het kan eender welke vorm uittekenen. Met dit gereedschap wordt punt voor punt 
getekend. Klik om blauwe nodes te plaatsen en klik én sleep om groene nodes te zetten 
waar het pad een vloeiende beweging maakt. Houd tijdens het slepen de optiontoets 
(vroeger de alttoets) ingedrukt om een hoek te maken (blauwe node) dat toch nog 
gebogen paden bevat.

Plaats nieuwe punten recht boven, onder of opzij van het vorige punt door het inhouden van 
de shifttoets vóór het klikken. Door shift in te houden tijdens het slepen zal de getekende 
hoek onder 90° blijven. Twee punten die niet correct uitgelijnd liggen zijn te corrigeren 
door ze te selecteren dan het menu Layers -> Align Selection te gebruiken. Glyphs plaatst 
de punten dan exact horizontaal of verticaal boven elkaar.

Sluit aan op open contouren met het gereedschap pen door opnieuw op de uiteinden te 
klikken. Ook open contouren sluiten gebeurt op deze manier.

5.  GLYPHS TEKENEN
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Dit is het ideale moment om de ontwerpschetsen over te tekenen. Goede schetsen kunnen 
letterlijk gevolgd worden. Wanner dit niet mogelijk is zullen de nodes uitgebreid verplaatst 
worden met het selectiegereedschap (Select), het eerste gereedschap op de werkbalk. In 
Flipperwriting zijn bijvoorbeeld de ontwerpschetsen niet gevolgd. Teken de glyphs strook 
per strook uit, niet de volledige glyph in zijn geheel. Stroken samenvoegen gebeurt tijdens 
de afwerking in “8.  Glyphs afwerken” op pagina 44. Dit volledige proces kan 
geautomatiseerd worden met de plugin TraceImage op https://github.com/schriftgestalt/
Glyphs-Plugins. Zie voor uitbreidingen op Glyphs het hoofdstuk “2*  Macro’s en scripts” op 
pagina 67. 

FOUTEN IN HET TEKENEN
Niet altijd verloopt het tekenen goed. Soms verschijnen er rode circels, of na het overkopiëren 

uit andere programma’s kunnen er groene nodes staan waar er een hoekpunt gemaakt 
wordt. Rode cirkels zijn een waarschuwing: er liggen twee nodes boven elkaar. Hoeken die 
verkeerd lopen herkent Glyphs niet, controleer daarom zelf en corrigeer waar nodig. 

VOORVERTONING
De getekende contouren zijn de omtrekken van de letters. Op het moment dat een lettertype 

gebruikt wordt in een tekstprogramma worden deze contouren opgevuld met een 
kleur naar keuze, meestal zwart. Druk op de spatiebalk om de reeds voltooide (dus de 
gesloten) gesloten contouren zwart weer te geven. Daarmee verandert het gereedschap 
tijdelijk naar het handje (Hand) en kan het beeld verplaatst worden. Het menu View 
-> Fill preview beheert wat weergegeven wordt. Er is keuze tussen contourlijnen of 
een zwart vlak. Alles wat niet in het uiteindelijke bestand terecht zal komen (zoals een 
achtergrondafbeelding) wordt onzichtbaar:

Gebruik tegelijkertijd ook het vergrootglas (zoom) om het beeld groter te maken, of kleiner te 
maken door het inhouden van de optiontoets. Zoomen is tevens mogelijk op een trackpad 
door twee vingers op het trackpad te plaatsen en naar elkaar toe te knijpen of uit elkaar te 
bewegen. Doordat glyphs bestaan uit paden is het mogelijk om (in theorie) oneindig in te 
zoomen zonder kwaliteit te verliezen. In tegenstelling tot een afbeelding is een lettertype 
dus niet gebonden aan de pixels, de kleine onderverdelingen van beeldschermen die ook 
in digitale afbeeldingen terugkomen.

De ruwe schets van de p uit 
FlipperWriting, nog niet perfect 
uitgewerkt. De afbeelding hoeft niet 
perfect gevolgd te worden.

https://github.com/schriftgestalt/Glyphs-Plugins
https://github.com/schriftgestalt/Glyphs-Plugins


26

 

Wanneer het Meetgereedschap (Measurement) actief is worden alle coördinaten van 
alle punten tegelijkertijd weergegeven. Met dit gereedschap worden ook afstanden 
opgemeten tussen twee punten. Klik hiervoor op het beginpunt en beweeg naar het 
tweede punt.

WERKEN MET PADEN
Merk op dat de bocht van de gebogen paden geen vastliggend gegeven is: deze kan aangepast 

worden. Selecteer een node grenzend aan een gebogen pad en zoek naar grijze 
uitsteeksels. Deze lijnen, eindigend op een punt, zijn de elementen die de vorm van de 
curves controleren, genaamd handgrepen (handles). In Illustrator worden dezelfde punten 
de richtingspunten (Direction Handles of gewoon Handles) en richtingslijnen (Direction 
Lines) genoemd. Door deze handgrepen te verplaatsen met het selectiegereedschap 
verandert de loop van de curve. Hoe verder het uiteinde van de handgreep verwijderd 
is van de node, hoe trager de bocht van het pad begint door te buigen. Per gebogen pad 
zijn er twee handgrepen: aan elk uiteinde één. (Soms is er eentje onzichtbaar, dan is die 
te klein om weer te geven.) Beide handgrepen zijn individueel bij te stellen maar het kan 
ook tegelijk gebeuren door met het selectiegereedschap het pad tussen twee nodes op te 
nemen en te verslepen.

Zowel blauwe als groene nodes kunnen beschikken over handgrepen. Het verschil is dat de 
handgrepen in een blauwe node willekeurig kunnen staan en in een groene node altijd 
lijnrecht tegenover elkaar staan. Hierdoor volgt het pad in die node een vloeiende 
beweging. Een groene node kan ook een overgang tussen een recht pad en een bocht 
aanduiden: de bocht loopt dan vloeiend over in een recht pad. 

Het soort node veranderen kan zeer gemakkelijk door er op te dubbelklikken of door de node 
te selecteren en de entertoets in te drukken. Blauw wordt dan groen en omgekeerd. 
Mochten de handgrepen van een groene node niet direct lijnrecht tegenover elkaar staan 
na het veranderen, corrigeer dit dan handmatig met het selectiegereedschap.

Om dit realtime te zien, hebben de ontwikkelaars van Glyphs een nuttig filmpje samengesteld: vimeo.com/43552747. Dit bevat niet enkel 
een live demo, maar ook enkele technieken die dieper ingaan op dit thema.

ANDERE GEREEDSCHAPPEN
Tijdens het tekenen zijn er ook nog de gereedschappen Roteren (Rotate) en Schalen 

(Scale), respectievelijk het vijfde en zesde gereedschap op de werkbalk. Selecteer een 
aantal paden en daarna kunnen deze geroteerd, vergroot en verkleind worden. Deze 
gereedschappen worden meestal niet gebruikt: de zijbalk die nadien nog besproken wordt 
kan ook roteren en schalen. Het achtste gereedschap is Annotation (Aantekeningen). 
Plaats daarmee notities bij de glyphs, zoals bijvoorbeeld een to do lijstje.

Houd de spatiebalk in om de 
contouren op te vullen en het beeld 
te verplaatsen.

http://vimeo.com/43552747
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ONDERDELEN VERWIJDEREN
Onderdelen verwijderen gebeurt door de gewenste nodes met het selectiegereedschap 

te selecteren en dan de backspace in te drukken. Dit is echter ook mogelijk met 
het gereedschap Gum (Erase), het derde gereedschap op de werkbalk. Klik met dit 
gereedschap op de node of op de handgreep dat dient te verdwijnen. De paden die in de 
verwijderde node samenkomen verdwijnen niet. Zij zullen eerder een doorlopende lijn 
worden, tenzij de optiontoets (alttoets) tegelijkertijd ingehouden wordt. In onderstaand 
voorbeeld wordt de groene node verwijderd met de gum. daarna worden de handgrepen 
verwijderd om een loodrechte lijn te bekomen: 
 

PUNTEN TOEVOEGEN
Nodes toevoegen is mogelijk door met het gereedschap Teken op een pad te klikken. Dit nieuwe 

punt positioneert zich dan op de plaats waar er geklikt wordt. Alle handgrepen passen zich 
aan aan de paden.

Ten slotte zijn er nog de paden die niet over handgrepen beschikken: rechte lijnen zoals 
getekend met het gereedschap Rechthoek. Houd de optiontoets ingedrukt tijdens het 
klikken op deze rechte lijn (terwijl er geen andere selectie actief is). Dan verschijnen er 
handgrepen en is het pad buigbaar.

OPEN EN GESLOTEN PADEN
Soms is het handiger werken als een pad open is. Dit kan door met het gereedschap Teken op 

een node te klikken. Die node splitst zich op in twee punten, weergegeven als twee boven 
elkaar liggende lijntjes. Deze punten verplaatsen kan met het selectiegereedschap. 

Een pad dient altijd gesloten te zijn voordat er een effen kleur aan toegekend kan worden. Om 
een pad terug te sluiten, klik dan met het gereedschap Teken op een van de eindpunten, 
waardoor nieuw getekende paden op het reeds bestaande pad zullen aansluiten. Om 
volledig te sluiten, klik op het tweede eindpunt.
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GLYPHS IN VERSCHILLENDE DELEN
Teken nu alle onderdelen van alle glyphs. De lettervormen bestaan dan uit verschillende 

onderdelen die elkaar overlappen, zoals deze p die bestaat uit een rechte lijn een curve. 
(Als voorbeeld! Afhankelijk van de vorm, kunnen er meer of minder onderdelen zijn.) 
Dat een glyph uit meerdere onderdelen bestaat is geen probleem, zij kunnen handmatig 
worden samengevoegd met het menu Filter -> Remove Overlap. Maar nog beter is om 
de aparte delen te laten bestaan: aanpassingen maken aan een glyph is gemakkelijker 
en Glyphs kan deze losse onderdelen samenvoegen op het moment van export. Zie het 
onderdeel “5.3.  Onderdelen van glyphs uitwisselen” op pagina 29

Rechts in het programma Glyphs staat de zijbalk. In- of uitschakelen kan 
met het menu Window -> Palette ofwel met de laatste knop op de 
werkbalk. In de zijbalk staan extra hulpmiddelen om de paden vorm 
te geven.

Het eerste onderdeel dient als spiekbriefje: schrijf hier enkele maten neer 
die regelmatig terugkomen in de glyphs.

Het tweede deel, Corrigeer Curve (Fit Curve), herpositioneert de 
handgrepen van de curves waardoor het verloop van de curves 
controleerbaar wordt. Selecteer het pad dat afgerond moet worden 
en klik op één van de vierkantjes van de zijbalk. Het eerste 
vierkantje komt overeen met het eerste percentage, het laatste 
vierkantje komt overeen met het laatste percentage. 

          
Klik op het eerste vierkantje: De handgrepen nemen een minimale lengte 

aan: ∆x en ∆y zijn nul. Klik nu op het laatste vierkantje: Glyphs trekt 
de handgrepen door tot zij elkaar raken. Dit is de maximale lengte 
van elke handgreep, dus 100%. De vierkantjes er tussen zijn een 
evenredige verdeling tussen beide percentages. Pas de percentages 
aan om een fijnere onderverdeling te verkrijgen. Corrigeer Curve 
geeft controle over de ronding van de curve, maar merk op dat de 
richting van de handgrepen niet verandert. Breid dit deel van de 
zijbalk uit (het driehoekje vooraan) om beide handgrepen van elke 
curve individueel te herpositioneren.

Het deel Lagen (Layers) biedt een overzicht over alle aanwezige lagen: de ontwerpgeschiedenis 
van de openstaande glyph. Zie ook hoofdstuk “7.  Werken met achtergrond en lagen” op 
pagina 42.

Het laatste deel, Transformations (Transformaties), laat toe om geselecteerde paden te 
verplaatsen en te vervormen. Kies eerst vanaf welk punt dit gebeurt: het middenpunt, een 
hoekpunt, de basislijn enz. De opties zijn spiegelen, schalen, roteren, schuintrekken onder 
een bepaalde hoek, uitlijnen ten opzicht van elkaar ofwel samenvoegen of aftrekken.

5.1  DE ZIJBALK

Achtereenvolgens:
nodes op 0%,
nodes op 100%,
nodes op ongeveer 55%.
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Een hoek, aslijn of ander detail dat regelmatig terugkomt kan aangegeven worden met een 
hulplijn. Rechtermuisklik op een lege plek in de glyph en kies Add Guideline (Voeg hulplijn 
toe). In de grijze infokader kan de positie en de hoek veranderd worden. Selecteer de 
hulplijn rechtermuisklik -> Make Global Guideline om de hulplijn in elke glyph zichtbaar te 
maken. De hoek van een hulplijn kan ook bepaald worden door op de hulplijn te klikken en 
te slepen. Een andere mogelijkheid is om twee nodes te selecteren en dan een hulplijn te 
creëren; Glyphs zal de hulplijn door de twee geselecteerde nodes trekken. 

Glyphs bestaan uit verschillende stroken. Er zijn twee cases waarvoor dit handig is. Teken 
bijvoorbeeld de ronding uit een van de glyphs b, d, p, q (en in sommige lettertypes ook de 
a en c) eenmaal en hergebruik deze in al deze glyphs. In glyphs met rechte onderdelen 
kunnen de stokken en staarten hergebruikt worden om delen van andere glyphs samen te 
stellen zoals de b, d, h, k, l, p en de q. Selecteer het benodigde onderdeel volledig door er 
dubbel op te klikken. Selecteer kleinere onderdelen van de glyph door één voor één de 
gewenste nodes te selecteren. Kopiëer de geselecteerde onderdelen met het menu Edit -> 
Copy (kopiëren) naar het klembord1. Open daarna een andere glyph, en plaats de 
onderdelen opnieuw door het menu Edit -> Paste (plakken) te kiezen. Dit gaat sneller met 
sneltoetsen, zoals besproken in het hoofdstuk “5*  Sneltoetsen in Glyphs” op pagina 89. 
Doordat de verschillende stroken van de glyphs nog los staan ten opzichte van elkaar 
kunnen deze stroken gemakkelijk verschoven of aangepast worden aan de nieuwe glyph. 

1. Het klembord is een onderdeel van elke computer. Elk via het menu Edit -> Copy gekopieerd onderdeel wordt daar bewaard zolang er 
geen nieuw gegevens naar het klembord gekopiëerd worden. De gebruiker kan de gegevens uit het klembord bereiken via het 
menu Edit -> Paste. Het is dit klembord dat het mogelijk maakt om gegevens van het ene programma naar het andere programma 
over te brengen, of gegevens binnen programma’s op een andere positie te plaatsen. De inhoud van het klembord is ten alle 
tijden op te vragen. Ga hiervoor naar het programma Finder en kies het menu Edit -> Show Clipboard. In het Nederlands is dit het 
menu Bewerk -> Toon klembord. 

5.2.  HULPLIJNEN 

Een hulplijn in elke glyph 
zichtbaar maken door in het 
contextmenu Make Global 
Guideline te kiezen.

5.3.  ONDERDELEN VAN GLYPHS UITWISSELEN
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Enkele vormen zijn identiek zoals bijvoorbeeld de gebogen stroken in de d en de q waar 
het gewicht onderaan ligt. Andere vormen zijn verschillend, zoals bijvoorbeeld de gebogen 
stroken in de p en de b waar het gewicht bovenaan komt te liggen. Hier komt het 
onderdeel Transformaties uit de zijbalk goed van pas. De d kan geroteerd worden tot een 
p, een q kan geroteerd worden tot een b. Slechts enkele aanpassingen dienen dan nog te 
gebeuren. 

Glyphs zijn ook uit te wisselen tussen verschillende bestanden in Glyphs: selecteer in het 
overzicht van het originele bestand de glyphs die overplaatsen moeten worden naar het 
andere bestand. Houd tijdens het klikken de shift of de commandtoets in om meerdere 
glyphs tegelijk selecteren (met de muis over meerdere glyphs heen slepen kan ook). Voer 
dan het menu Edit -> Copy (kopiëren) uit. Activeer het venster van het tweede bestand  
en kies in het overzicht van alle glyphs het menu Edit -> Paste (plakken). Het nieuwe 
bestand bevat nu een kopie van de originele glyphs, met alle inhoud en gegevens die er 
aan gekoppeld zijn.

Kopiëren en plakken is niet enkel mogelijk tussen glyphs onderling, maar ook tussen 
vectorprogramma’s zoals Illustrator, FontLab, Glyphs, RoboFont enz. kunnen paden en 
nodes uitgewisseld worden. Illustrator wordt regelmatig gebruikt om letters te tekenen, 
en de lettervormen worden dan gekopieerd naar het lettertypeprogramma zoals Glyphs of 
FontLab. De ontwikkelaars van lettertypeprogramma’s raden dit af.

Bij het tekenen in Illustrator kan enkel de vorm van de glyph uitgewerkt worden. Deze moet 
nadien overgezet worden naar een lettertypeprogramma om een font te maken. Illustrator 
werkt echter met de eenheid centimeters, lettertypeprogramma’s werken in units. Na 
het overzetten moeten de paden geschaald worden om binnen de Em te passen. Er kan 
kwaliteitsverlies optreden, zoals handgrepen die niet meer recht staan of curves die niet 
meer mooi lopen.

Als er toch een grondige reden is om met Illustrator te werken, let dan op de schaal van de 
letters. In verkeerde afmetingen tekenen is vlug gebeurd en het is uiterst moeilijk om 
letters daarna op een juiste schaal in het lettertypeprogramma te plaatsen. Schakel de 
units van Illustrator over naar points tijdens de aanmaak van een nieuw document; of in 
de voorkeuren van het programma onder het onderdeel Units; of door een rechtermuisklik 
op de linealen en points te selecteren. 1 point in Illustrator is dan 1 unit in Glyphs. Door 
in Illustrator een hoogte van 1000 points aan te houden komt de hoogte van de glyph 
overeen met de Em-grootte. Mocht de UPM geen 1000 meer zijn zoals in het hoofdstuk 
“4.4.  De Waarden van UPM, grid en metrics” op pagina 19 besproken, werk dan binnen 
de nieuwe UPM-waarde. Alle informatie die de ontwikkelaars van Glyphs hier over geven 
kan teruggevonden worden op de webpagina www.glyphsapp.com/tutorials/importing-
from-illustrator.

Voorbeelden waarbij 
verschillende paden tussen 
de verschillende glyphs 
uitgewisseld kunnen worden, 
mits enkele aanpassingen.

5.4.  ONDERDELEN UIT ANDERE PROGRAMMA’S

http://www.glyphsapp.com/tutorials/importing-from-illustrator
http://www.glyphsapp.com/tutorials/importing-from-illustrator
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Glyphs horen bij elkaar en vormen binnen een woord een goede eenheid. Tijdens het 
ontwerpproces kunnen letters dus niet individueel bekeken worden, bekijk ze altijd als 
een samenhorend geheel. In Glyphs is dit zeer gemakkelijk: activeer tijdens het bewerken 
van een glyph het gereedschap Tekst (Text), het zevende gereedschap in het midden van 
de werkbalk. Typ nu andere letters, net als in een tekstverwerker zoals Microsoft Word 
of WordPerfect. Begin tijdens het ontwerpen met letters die op elkaar lijken (d, q, p, b), 
in een later stadium worden dit volledige woorden en zinnen. Hierdoor is te controleren 
of glyphs bij elkaar passen. De tabbalk van Glyphs heeft een enorm voordeel: open 
meerdere combinaties tegelijkertijd en wissel tussen deze verschillende combinaties 
zonder ze opnieuw te typen. Verschillende versies van dezelfde glyph vergelijken kan ook, 
zie hiervoor het hoofdstuk “7.  Werken met achtergrond en lagen” op pagina 42. Ga 
elke keer terug naar de eerste tab genaamd Font voor het overzicht van aanwezige glyphs. 
Dubbelklik op een andere glyph naar keuze om deze te openen in een nieuwe tab.

Tijdens het bewerken van een glyph verschijnen er onderaan in de werkruimte een aantal 
knoppen. De eerste knop activeert Features en wordt besproken in het hoofdstuk “3*  
Features schrijven” op pagina 73. De tweede knop, het oogje, activeert een tweede 
voorvertoning met als extra opties de instances (besproken in het hoofdstuk “9.  Masters 
en Instances” op pagina 49), zwart-wit omdraaien, horizontaal spiegelen en vervagen 
(werkt het font nog in slechte leesomstandigheden?). Deze voorvertoning in een ander 
venster openen kan met het menu Window -> Preview Panel (Paneel voorvertoning).

 

De eerste knop aan de rechterzijde schakelt de kerning in of uit. Dit wordt besproken in “8.3.  
Witruimten corrigeren: de kerning” op pagina 47. De volgende reeks van drie knoppen 
verandert de tekstrichting: links naar rechts, rechts naar links voor andere scripts van 
boven naar onder. Tenslotte is er in de hoek ook nog de weergavegrootte van het font: op 
bovenstaand voorbeeld is dat 75pt2.

2. Een punt (Point) in de typografie is de maateenheid waarin de hoogte uitgedrukt wordt waarin de letters gezet worden. Doorheen 
de geschiedenis heeft de punt verschillende waarden gekend. Met de digitale typografie is het DTP punten system (desktop 
publishing point) aangenomen en ligt 1 punt nu vast op 0.0138 inch wat overeen komt met 0.3527 mm

5.5.  GLYPHS VERGELIJKEN EN CONTROLEREN

Vervagen van een font maakt 
het mogelijk om te zien 
hoe het font in slechtere 
omstandigheden functioneert.
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VOORVERTONING
FontLab en RoboFont zijn niet zo goed in het tonen van glyphs binnen hun context. Zij doen dit 

beiden in een apart venster waarin de glyph zelf niet meer bewerkt kan worden. Open in 
FontLab het paneel Preview (Voorvertoning) met het menu Window -> Panels -> Preview. 
Geef bovenaan een zin in om weer te geven. Aan de rechterzijde kunnen enkele opties 
veranderd worden, zoals de tekstgrootte, spiegelingen en de kleuren omdraaien. RoboFont 
heeft geen apart venster om glyphs weer te geven, gebruik hiervoor het Space Center. Dat 
is terug te vinden onder de vierde knop op de werkbalk. Bovenaan kan een zin ingegeven 
worden die weergegeven zal worden. De tekstgrootte kan aan de rechterzijde aangepast 
worden, terwijl extra opties in het menu verborgen zijn.
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Hier volgen nog aanbevelingen om een glyph goed op te bouwen, zowel voor de tekenmethode 
als voor de richting van de paden. Want elke glyph kan op verschillende manieren 
getekend worden, maar wat is nu juist de allerbeste plaatsing van de nodes? 

Paden bevatten zo weinig mogelijk nodes, maar voldoende om de lettervorm goed uit te 
werken. Dit geeft het meeste controle over de vorm van de curven. Hoe meer nodes, hoe 
minder vloeiend een curve gemaakt kan worden. 

Op extrema (het meest uiterste punt van een pad) of op een hoekpunt staan sowieso nodes. 
In extrema met groene nodes liggen de handgrepen meestal ofwel exact loodrecht ofwel 
exact horizontaal, zeker voor eenvoudige letters zoals de o. Rainer Erich Scheichelbauer, 
medewerker aan Glyphs had de volgende opmerking over extrema: “[Extrema] zijn er ook 
vanwege technische reden: De wiskunde achter de beschrijving van curves veronderstelt 
dat alle curven maar één buiging hebben en die buiging nooit verder dan 90° gaat. Anders 
gaan veel functies mis, zoals het verschuiven van paden etc.” 

Handgrepen van hetzelfde padsegment mogen elkaar niet snijden. Maak hier extra knoopunten 
aan, waaronder extrema. 

De afstand van handgrepen mag niet nul zijn. Dit is een vaak voorkomend probleem na het 
importeren uit Illustrator. Er bestaat een plugin genaamd Fix Zero Handles om dit op te 
lossen. Zie het hoofdstuk “2*  Macro’s en scripts” op pagina 67 voor meer informatie 
over uitbreidingen op Glyphs. 

Paden dienen gesloten te zijn. Anders worden zij nooit opgevuld met een kleur en zijn 
dientengevolge niet zichtbaar .

Net zoals de UPM niet groter mag zijn dan 4095, is de breedte van een glyph beperkt van -8191 
tot +8191. Gaan de paden daar over, dan zal het font niet geëxporteerd kunnen worden. 
Sommige programma’s houden echter 4095 aan voor de totale breedte; paden die hier 
buiten vallen worden dan niet getoond. Dit is een beperking om rekening mee te houden.

5.5.  GOED GETEKENDE PADEN

https://github.com/mekkablue/FixZeroHandles
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In lettertypes worden deze aanbevelingen niet altijd gebruikt. De onderkastletter o uit de Didot 
van Linotype uit 1993, bevat bijvoorbeeld teveel punten. Waarschijnlijk is dit het resultaat 
van een conversie uit nog oudere lettertypes. Oudere lettertypestandaarden kenden 
andere tekenmethoden die meer nodes vereisten. Wat niet wil zeggen dat deze vorm op 
zich verkeerd is.

 

Alle nodes zijn rond of vierkant, maar éénje heeft de vorm van een driehoek. Deze driehoek 
geeft de richting van je lijn aan. Het is zeer belangrijk dat de paden in tegenwijzerzin 
(counterclockwise) gedraaid zijn! Een lijn die in tegenwijzerzin loopt zal met een zwarte 
kleur opgevuld worden, terwijl lijnen die met de wijzers mee lopen transparant blijven: de 
binnenvormen (counters) van de letters. Veel programma’s doen hun best om foute letters 
ook juist te interpreteren, hoewel er geen enkele garantie is op een goed resultaat. 

Corrigeer een foutieve richting door het pad te selecteren met het selectiegereedschap 
(dubbelklik op de lijn om de volledige contour selecteren) en dan het menu Layers -> 
Reverse contours (contourrichting omdraaien) ofwel rechtermuisklik -> Reverse Selected 
Contours (geselecteerde contouren omdraaien) te kiezen. De padrichting corrigeren is ook 
mogelijk net voor de voltooiing van het lettertype: selecteer alle glyphs in het overzicht 
met alle glyphs en kies het menu Layers -> Correct Path Direction (padrichting corrigeren).

De digitale o uit Didot (links) met 
te veel nodes en de digitale o uit 
Matilda, met exact genoeg nodes: 
genoeg om de curve vloeiend te 
tekenen, niet te veel om de curves 
te storen met extra knikken.

Beide paden lopen tegenwijzersin: 
programma’s zullen beide opvullen 
met een kleur zonder een opening 
vrij te laten.
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Zesentwintig onderkasten, zesentwintig kapitalen en een spatie zijn aanwezig in een nieuw 
font in Glyphs. Dat is voldoende voor een eerste aanzet tot een font te maken en om 
beslissingen te maken over de uiteindelijke vormgeving. Dit aantal is echter onvoldoende 
om een volledig font samen te stellen. De glyphs die vereist zijn voor een minimaal 
lettertype komen min of meer overeen met de filters links onderaan in de zijbalk van 
Glyphs: de oudste lettertypes bestaan uit 256 karakters. Dit is afkomstig uit de tijd van 
de eerste PostScript Type 1 lettertypes waarin het niet mogelijk was om meer glyphs te 
bewaren. Glyphs met accenten en andere vreemde tekens werden toen toegevoegd in een 
ander bestand.

Keer terug naar het algemene overzicht van alle glyphs. De eenvoudigste methode om nieuwe 
glyphs toe te voegen is het plusteken onderaan in de statusbalk. Hetzelfde gebeurt met 
het menu Glyph -> New Glyph. Op beide manieren wordt een nieuwe glyph aan het font 
toegevoegd met de naam NewGlyph. Klik op de naam om de glyph te hernoemen met een 
naam naar keuze. Op de naamgeving wordt later nog dieper ingegaan.

6.  GLYPHS TOEVOEGEN

6.1.  GLYPHS TOEVOEGEN EN VERWIJDEREN
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Een volgende manier om glyphs toe te voegen is om de namen in een lijst op te zoeken. Behalve 
voor zelf verzonnen symbolen kan de correcte engelse naam opgezocht worden via het 
menu Window -> Glyph Info. Het venster dat verschijnt geeft een overzicht van vele 
bestaande digitale glyphs, inclusief hun naam en de bijhorende Unicode (de unieke code 
van vele glyphs). Selecteer de glyph naar keuze en klik rechts onderaan op de knop ‘Add to 
font.’

De derde en meest efficiënte manier voor een beknopt font 
gaat via de zijbalk. Er zijn verschillende onderverdelingen 
terug te vinden; per categorie (Categories), per taal 
(language) en per eigen filter (Filter). Verfijn deze 
onderverdelingen door op het driehoekje te klikken. De 
subverdelingen eindigen met een getal, met een vinkje, 
ofwel met niets er achter. Het vinkje betekent dat alle 
glyphs uit die specifieke onderverdeling aanwezig zijn. 
Latin-Basic bestaat uit de zesentwintig kapitalen en 
onderkasten, is dus compleet en eindigt op een vinkje. 
Het getal toont aan hoeveel glyphs er per onderverdeling 
terug te vinden zijn samen met hoe veel glyphs er 
reeds in het font aanwezig zijn. Staat er niets achter 
een onderverdeling, dan plaatst het programma uit 
zichzelf niets in deze onderverdeling. Het maakt mogelijk 
wel gebruik van de lege onderverdelingen wanneer er 
manueel glyphs ingevoegd worden, zoals kleinkapitalen 
of ligaturen.

Voeg de glyphs uit een bepaalde onderverdeling toe door een 
rechter-muisklik op het getal er achter. (Houd op oudere 
Macs of voor oudere muizen de controltoets in tijdens 
het klikken.) Een lijst met de nog ontbrekende glyphs uit 
deze onderverdeling verschijnt. Selecteer de gewenste 
glyphs en klik onderaan op Generate (Genereren) om 
deze toe te voegen.

De Glyph Info bevat een 
database van 54 382 
verschillende glyphs met 
de naam, unicode, groep, 
subcategorie en script waar 
mogelijk.
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De vierde en de meest efficiënte manier om glyphs in te voeren in geavanceerde fonts gaat 
via het menu Font -> Add Glyphs… Dit menu opent een nieuw venster dat het mogelijk 
maakt om zelf de namen van de nieuwe glyph(s) in te geven, gescheiden door een komma. 
In dit voorbeeld worden drie verschillende methoden ingegeven die driemaal dezelfde 
glyph invoeren: ä, adieresis en a+dieresis=adieresis. Er zijn enkele verschillen met grote 
gevolgen: 

Een reële weergave zoals ä of een naam zoals adieresis voegt een nieuwe glyph toe aan het 
font. Glyphs vertaalt een ingave zoals ä automatisch naar de volledige naam: adieresis. Als 
de naam van de nieuwe glyph overeen komt met één van de namen uit het venster Glyphs 
Info, dan zal Glyphs ze herkennen en er tevens een Unicode-referentie aan toewijzen. 
Glyphs ingegeven op deze manier zijn leeg.

In een samensteling zoals bijvoorbeeld a+dieresis=adieresis creëert Glyph een samengestelde 
glyph: het bevat de glyph a en de glyph dieresis. Als de glyph a én de glyph dieresis reeds 
in het font aanwezig zijn, dan zal Glyphs de adieresis creëren met de reeds bestaande 
glyphs als componenten. Voor informatie over componenten, zie “6.4.  Repetitieve 
elementen: componenten” op pagina 39.Als de glyphs a en/of dieresis nog niet in het 
font aanwezig zijn dan kan Glyphs onmogelijk bepalen hoe deze combinatie er uit ziet. 
Glyphs zal dan ook deze glyphs toevoegen aan het font.

Glyphs toevoegen via het menu Font -> Add Glyphs… is uitermate geschikt om een lettertype te 
ontwikkelen met zeer veel onbestaande glyphs, zoals bijvoorbeeld Contextual Alternates 
(calt, contextuele alternatieven). Dit soort van glyphs komt in het volgende onderdeel aan 
bod.

Om een volledige set letters te bekomen worden er letters toegevoegd. Welke letters dat 
dat zullen zijn is afhankelijk van de ontwerper en van het toekomstige gebruik van het 
lettertype. Een goed overzicht van vele bestaande karakters in verschillende schriften 
is terug te vinden in het boek Schriftzeichen und Alphabete van Carl Faulmann (2012). 
De ontwerper heeft daarbovenop nog eens keuze tussen verschillende weergavestijlen: 
bestaat de set van letters enkel uit kapitalen en onderkasten, of worden er de 
kleinkapitalen ook nog aan toegevoegd. Over welke ligaturen zal het font beschikken? 
En worden er stylistische alternatieven aangebracht voor de gebruiker? Ken de 
microtypografische regels om hier beslissingen in te maken. Een mooi voorbeeld 
zijn de cijfers: het zal reeds opgevallen zijn dat de zijbalk van Glyphs de volgende 
onderverdelingen voor de cijfers bevat: Decimal Digit (decimalen), Oldstyle Figures 
(uithangende cijfers), Lining Figures (uitgelijnde cijfers), Tabular Figures (tabelcijfers), 
Tabular Oldstyle Figures (uithangende tabelcijfers) en Fractions (breuken). Dit zijn er 
behoorlijk veel. Zo veel soorten cijfers zijn er toch niet? Jawel, die zijn er wel. En elk soort 
cijfer heeft specifieke kenmerken:

Decimal Digit (decimalen) zijn de cijfers nul tot negen die standaard door het lettertype gebruikt 
zullen worden. Zij zijn een kopie van één van de vier soorten cijfers, meestal de tabelcijfers. 
De ontwerper kiest dus welke representatie van cijfers als standaard gebruikt worden. Zorg 
dat de decimalen aanwezig zijn in je font! Het zijn deze die gebruikt worden om te typen in 
een programma, als deze niet aanwezig zijn verschijnt er niets.

0123456789
Oldstyle Figures (uithangende cijfers), in het Engels ook Text figures, non-lining, non-aligning, 

Lowercase, Ranging, Hanging, Medieval, Billing, en Antique figures or Numerals… 
genoemd, in het Nederlands uithangende cijfers, hangende cijfers of mediaevalcijfers. Zij 
beschikken allemaal over verschillende hoogten en breedten. De 0, 1 en 2 zijn getekend 
op de x-hoogte, terwijl de 3, 4, 5, 7 en 9 onder de basislijn uitsteken en de 6 en 8 boven 

6.2.  WELKE GLYPHS TOE TE VOEGEN?
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de x-hoogte uitsteken. Deze cijfers ogen mooier in doorlopende tekst, vandaar de naam 
text figures. Zij zijn niet geschikt om in tabellen geplaatst te worden, daar hun breedte niet 
gelijk is en zij dus niet mooi onder elkaar komen te staan.

0123456789
Lining Figures (Uitgelijnde cijfers). Deze cijfers zijn uniform in de hoogte; zij zijn even hoog 

als de kapitalen en allemaal gepositioneerd op de basislijn. De overeenkomst met de 
uithangende cijfers zijn de verschillen in breedte.

De vorige twee groepen van cijfers, de Oldstyle Figures en de Lining Figures behoren beide tot 
de groep van Proportional Figures (proportionele cijfers).

0123456789
Tabular Figures (tabelcijfers). In het engels ook wel Titling figures of Majuscule Numerals 

genoemd, zijn zeer geschikt voor gebruik in tabellen omdat al deze cijfers even breed 
(inclusief de witruimten) en even hoog zijn. In tabellen worden zij hierdoor mooi op elkaar 
uitgelijnd.

0123456789
Tabular Oldstyle Figures (uithangende tabelcijfers). Deze cijfers zijn een samenstelling van de 

oldstyle figures en de tabular figures. Oldstyle figures krijgen hier een gelijke breedte.
De Tabular Figures en de Tabular Oldstyle Figures behoren tot de groep van de Tabular Figures 

(tabelcijfers).
Onder de onderverdeling Fractions (breuken) tenslotte brengt Glyphs de breuken onder: ¼, ½, 

¾, etc, met de bijbehorende numerators (tellers) ⁰¹²³⁴⁵⁶⁷⁸⁹ en denominators (noemers) 
₀₁₂₃₄₅₆₇₈₉.

Kijk zeker ook in de lijst met glyphs (Window -> Glyph Info) voor de namen van reeds 
bestaande glyphs. De ontwerper kiest uit al deze sets van cijfers welke hij toe zal voegen. 
Tekstprogramma’s zullen niet alle ingevoegde alternatieve glyphs automatisch gebruiken. 
Hoe tekstprogramma’s op het bestaan van de alternatieven gewezen wordt is uitgelegd 
in het hoofdstuk”3*  Features schrijven” op pagina 73 en hoe de correcte alternatieve 
glyphs in een tekstprogramma geactiveerd worden is uitgelegd in het hoofdstuk “4*  
Features activeren” op pagina 84. Een voorbeeld is uithangende cijfers gebruiken in 
plaats van tabelcijfers.

Bij het toevoegen van glyphs of voor zelf ontworpen karakters zijn er conventies in de 
naamgeving om op te volgen. Deze conventies zijn specifiek voor Glyphs zodat het 
programma weet wat voor type glyph het is en naargelang kan handelen. Controleer 
eerst of de gewenste glyph bestaat in de lijst met glyphs (Window -> Glyph Info). Het is 
aangeraden om enkel kapitalen en onderkasten te gebruiken in de naamgeving. Spaties 
en vreemde tekens zoals een Ô zijn niet toegelaten in de namen voor glyphs. Punten en 
underscores hebben een speciale betekenis. Hier volgen drie voorbeelden: kleinkapitalen, 
contextuele alternatieven en ligaturen.

Kleinkapitalen (Small Caps) krijgen bijvoorbeeld het achtervoegsel (suffix) .sc op het einde. 
Hierdoor kan Glyphs hen onderscheiden en zal Glyphs hen automatisch kunnen 
programmeren in een Feature. Zie hiervoor het onderdeel “3*  Features schrijven” op 
pagina 73.

Alternatieven voor een glyph zoals gebruikt in de Contextual Alternates (contextuele 
alternatieven) krijgen dezelfde naam als de standaard glyph, gevolgd door het 
achtervoegsel (suffix) .alt en direct gevolgd door een nummer. Deze set van glyphs 

6.3.  CONVENTIES IN DE NAAMGEVING
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vormen dan verschillende varianten op dezelfde glyph, zoals getoond op de volgende 
afbeelding: 

Dit is één glyph p gevolgd door vijf varianten. De reeks die bijgevolg ontstaat op de glyph p 
wordt: p, p.alt1, p.alt2, p.alt3, p.alt4, p.alt5 enz. Een ander soort van alternatieven 
zijn de stylistische alternatieven (Stylistic Alternates). De achtervoegsels voor dit 
soort van alternatieven zijn .ss01, .ss02, .ss03 enz tot .ss20. Het programmeren van 
contextuele alternatieven zal Glyphs niet op zich nemen. Stylistische alternatieven kan 
Glyphs wel programmeren, maar deze hebben als nadeel dat zij dan weer standaard niet 
gebruikt worden in de tekstverwerkingsprogramma’s. Voor de technische kant hiervan 
wordt opnieuw verwezen naar de appendix “3*  Features schrijven” op pagina 73. 
De geschreven code bepaalt waar en wanneer de alternatieven gebruikt worden in 
tekstprogramma’s.

TIP: Wie werkt met alternatieven gaat best naar de vijfde tab in de fontinformatie en schakelt de optie Keep alternates next to base glyph 
(houd alternatieven naast de basis-glyph) in. Dan plaatst Glyphs alternatieven in het overzicht naast de ‘oorspronkelijke’ glyph.

Een derde voorbeeld is werken met eigen ligaturen die niet tot de standaard behoren, dus niet 
de ligaturen fl of fi. Voor Glyphs wordt aangeraden om de namen van nieuwe ligaturen 
samen te stellen met een underscore, bijvoorbeeld het soms voorkomende c_h. Als deze 
combinatie ingevoegd wordt via het menu Glyphs -> Add Glyphs dan zal Glyphs zelf de c 
en de h samenvoegen tot een ligatuur. Het nadeel is dat deze combinatie in de Features 
opgenomen zal worden als dlig (Discretionary Ligatures, discrete ligaturen), met als 
gevolgd dat een gebruiker dit kan uitschakelen. Noem deze combinatie in plaats daarvan 
niet c_h, maar geef het de naam c_h.liga. Het achtervoegsel .liga zal er voor zorgen dat het 
als Standard Ligatures (standaard ligatuur) opgenomen wordt, waar de meeste gebruikers 
weinig aan veranderen tijdens het zetten van een tekst. Beide Features voor ligaturen zal 
Glyphs zelf opbouwen.

Er zijn nog speciale glyphs die Glyphs automatisch kan programmeren. Zoek in het menu Help-> Glyphs Help naar Glyph naming scheme 
for automatic feature generation. Dit is een lijst van alle Features die glyphs automatisch kan samenstellen, gebaseerd op een 
correcte naamgeving.

Vele voltooide fonts bevatten ettelijke duizenden glyphs. Maar toch kan het gebeuren dat een gebruiker een glyph opvraagt die niet in 
het font aanwezig is. Bijvoorbeeld als een gebruiker in het Cyrillische schrift begint te typen, maar de ontwerper heeft dit niet 
ontwikkeld. Er bestaan glyph(s) die aangeven wanneer een bepaalde glyph niet gevonden kan worden tijdens het gebruik in een 
tekstprograma. De glyphs die aangeven wanneer er een glyph niet beschikbaar is zijn de .notdef, de .null en de NULL (let op de 
punten in het begin van de naam). Glyphs voegt er één toe tijdens het exporteren, maar voeg deze glyphs handmatig toe om 
controle te krijgen over het uiterlijk. Meestal bevatten deze glyphs een staande rechthoek met een kruis door of een vraagteken.

GLYPHS VERWIJDEREN
Glyphs verwijderen kan door deze eerst in het overzicht te selecteren. Sleep met de muis 

over meerdere glyphs heen of houd tijdens het klikken de Shift of de Commandtoets om 
meerdere glyphs tegelijkertijd selecteren. Gebruik daarna het minteken in de statusbalk, 
ofwel het menu Font -> Remove Glyph. Deze actie kan niet ongedaan worden gemaakt, 
dus de lettervormen zijn definitief verdwenen.

Onderdelen die vaak voorkomen worden ingevoegd als componenten. Voeg bijvoorbeeld 
de ligatuur fl toe via het menu Glyph -> Add Glyphs… De nieuwe glyph is niet leeg: de 
bestaande f en l zijn hergebruikt. Deze twee glyphs zijn grijs weergegeven, het is een 
verwijzing naar een andere glyph. Wordt een van de glyphs f of l aangepast dan verandert 
de ligatuur fl tegelijkertijd. 

6.4.  REPETITIEVE ELEMENTEN: COMPONENTEN
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Glyphs blokkeert de componenten die het zelf plaatst. Voer rechtermuisklik -> disable 
automatic Alignment (automatisch uitlijnen uitschakelen) uit zodat ze te verplaatsen 
zijn. Dubbelklik op een grijze vorm om naar de oorspronkelijke glyph te gaan. Om de 
vorm enkel te veranderen binnen de actieve glyph, doe rechtermuisklik -> Decompose 
(ontbinden). Hierdoor wordt het component vervangen door paden en de bijbehorende 
nodes. Let wel dat het ontbonden component niet meer automatisch geüpdatet wordt 
wanneer er wijzigingen aan de oorspronkelijke glyph aangebracht worden.

Werken met componenten is niet enkel handig voor ligaturen, maar ook voor accenten. Teken 
eerst alle glyphs die geen componenten nodig hebben. Voeg daarna de nieuwe glyphs 
in waarbinnen deze bestaande glyphs gebruikt worden (fl, fi, é, è, ù, enz.). Uitleg voor 
accenten volgt nog. Glyphs met een leeg component bevatten een melding dat er een 
leeg component in staat. Door dubbel op dat bericht te klikken kan dat component alsnog 
gemaakt worden. Manueel een component in een glyph invoegen kan via rechtermuisklik 
-> Add Component (Component toevoegen).

Rechtermuisklik op een component en kies Show all glyphs containing this component (toon 
alle glyphs waarin dit component voorkomt) voor een overzicht van alle glyphs met 
een bepaald component. Het is ook mogelijk om een zoekopdracht uit te voeren in 
het overzicht van alle glyphs of een filter aan te maken die automatisch zoekt naar een 
bepaalde naam.

Voor een schreefhebbend lettertype is het mogelijk om de schreven van glyphs als component aan te maken. Hierdoor kan deze op één 
plaats aangepast worden, en blijven alle schreven identiek. Voeg hiervoor een nieuwe glyph/nieuwe glyphs toe met een duidelijke 
naam voor de herkenbaarheid.

Voor ligaturen zijn componenten bruikbaar, voor accenten dienen er ook ankers (Anchors) 
ingebracht te worden. Ankers zijn vastgelegde punten die componenten binnen een 
glyph positioneren. Creëer eerst de gewenste accenten in het font: doe dit in een glyph 
met de naam van het gewenste accent gevolgd door ‘comb.’ Maak bijvoorbeeld de glyph 
gravecomb aan en teken hierin de vorm van een accent grave. Plaats ankers met het 
menu Glyphs -> Set Anchors (plaats ankers). Glyphs plaatst de ankers (bruine punten) 
zo goed mogelijk, inclusief een correcte naamgeving waar mogelijk. Het is ook mogelijk 
om rechtermuisklik -> Add Anchor (anker toevoegen) uit te voeren. Ankers hernoemen 

6.5.  ACCENTEN: COMPONENTEN EN ANKERS
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gebeurt door te dubbelklikken op het oranje punt of door het anker te selecteren en 
enter te drukken. In de glyphs van accenten dient het de naam _top te hebben (met de 
underscore!).

Hierna is dit accent klaar voor gebruik. Ga terug naar alle glyphs waarop accenten geplaatst 
zullen worden en kies ook daar het menu Layers -> Set Anchors (plaats ankers). Er 
verschijnen meerdere ankers, met bovenaan een anker genaamd top (ditmaal zonder de 
underscore).

Klik eenmaal op het bovenste anker genaamd top voor een voorvertoning van alle accenten met 
een anker genaamd _top. In dit voorbeeld is dat enkel nog maar de accent grave. Voeg nu 
de glyph egrave toe aan het font, Glyphs vervolledigt die glyph. Corrigeer de positie van 
accenten door de ankers te verplaatsen in de glyph e of in de glyph grave. Op deze 
afbeelding staat het accent te dicht op de glyph e, hier zal de glyph van de accent grave 
nog verplaatst worden. 
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Selecteer een aantal paden en gebruik het menu Paths -> Selection to Background om de 
bestaande vormen in een achtergrond te plaatsen. Zo is er altijd een referentie terwijl er 
getekend wordt. De achtergrond bewerken of er in bijtekenen kan via het menu Paths -> 
Edit Background (Bewerk achtergrond). Kopieëren en plakken is ook mogelijk wanneer de 
achtergrond actief is. 

Lagen (Layers) binnen Glyphs dienen om het ontwerpproces te bewaren. Elke laag is eigenlijk 
een andere versies van de glyph die bewaard wordt om nadien terug te kunnen 
raadplegen. In het onderdeel Layers van de zijbalk is te zien dat er standaard enkel een 
laag met de naam Regular aanwezig is voor elke glyph. Deze naam of namen komen 
overeen met de ingestelde Masters, zie “9.  Masters en Instances” op pagina 49.

7.  WERKEN MET ACHTERGROND EN LAGEN
7.1.  ACHTERGROND

7.2.  LAGEN
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Klik op de knop Copy (kopiëren) onderaan de lijst zodat er een laag verschijnt met de huidige 
datum. Klik dubbel op deze laag om de naam te veranderen en bevestig na het typen met 
de entertoets. Visueel is er niets gebeurd wat verwarrend kan zijn: de letter ziet er nog 
steeds identiek uit als eerst. Maar toch wordt er nu gewerkt op een andere laag. Ze ziet er 
enkel nog hetzelfde uit als de laag Regular omdat er een kopie gemaakt is. Maak enkele 
aanpassingen aan aan de letter terwijl de nieuwe laag actief is. In dit voorbeeld wordt de 
letter ‘p’ even rechtgetrokken:

Vanaf nu is het mogelijk om tussen verschillende lagen te wisselen door op de naam te klikken. 
Verschillende lagen boven elkaar plaatsen kan door op het oogje te klikken. Er verschijnen 
dan grijze contouren van die specifieke laag. Verschillende lagen tegelijkertijd bekijken is 
mogelijk door dezelfde glyph verschillende keren naast elkaar te plaatsen en dan voor de 
verschillende glyphs een verschillende laag te activeren:

Lagen zijn voor iedere glyph verschillend. Elke glyph krijgt evenveel lagen als er masters zijn. (zie 
het hoofdstuk “9.  Masters en Instances” op pagina 49). Maak verder evenveel lagen 
als er nodig zijn per glyph. Een laag die beter is dan de standaard Regular kan omgewisseld 
worden: klik op het tandrad onderaan in het onderdeel Layers van de zijbalk en kies daar 
Use as Master (gebruik als Master). Glyphs verwisselt dan je geselecteerde laag met de 
Masterlaag.
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Na het opbouwen van een font door de benodigde glyphs in te voegen, de glyphs uit te tekenen 
en de glyphs op elkaar af te stellen worden ook de externe witruimten op elkaar afgesteld. 
Ontwerpers weten dat de witruimten in en tussen de letters visueel even groot dienen 
te ogen. Dit komt de leesbaarheid ten goede: de letters blijven genoeg onderscheidbaar 
(legible), maar blijven tevens een zekere samenhang vertonen (readable).

Pierre Simon Fournier (1742) beval de binnenruimte van de m aan om de andere letters op af te 
stellen. Walter Tracy (1986) raadt aan om een reeks van de glyphs n te gebruiken en aan de 
hand van deze glyph de linker en rechter witruimte van alle glyphs te bepalen. De ruimte 
die effectief gebruikt zal worden is deels afhankelijk van hoe wit of zwart het tekstbeeld 
zal worden en is deels afhankelijk van de interne ruimte in de glyphs. De ruimte tussen de 
letters mag iets kleiner zijn dan in de letters, maar niet groter. De vorm van de glyph dient 
visueel ook in het midden van de totale breedte van die glyph te staan:

De eerste methode om de glyph te positioneren is de waarden invullen in het grijze kader: het 
eerste getal is de witruimte van de linkerzijde van de kader tot het meest linkse stukje 
van de glyph. Wijzig deze waarde door er op te klikken. Het tweede getal is de totale 
breedte van de letter, hier afgestemd op 625 units. Het derde getal is de afstand van 
het meest rechtse stukje van de glyph tot en met de rechterzijde van het kader. Deze 
waarden kunnen negatief zijn wanneer de vorm van een glyph buiten het oranje kader 
steekt, bijvoorbeeld voor een f of een j. Een nul mag ook voorkomen, maar let dan op de 
samengang met de andere glyphs zodat zij geen storende overlappingen kunnen vormen.

De tweede methode om de glyphs te positioneren is met het toetsenbord: zo lang dat het 
gereedschap Tekst actief is kan de laatste waarde gewijzigd worden door de 
toetsencombinatie Command + de linker of rechterpijl. De toetsencombinatie Command 

8.  GLYPHS AFWERKEN

Een te krappe letterspatiëring maakt de letters minder legible.
Dit is een zin met een goede letterspatiëring.
Een te weide letterspatiëring maakt de zin moeilijker readable.

8.1.  DE LETTERS SPATIËREN (STELLEN)
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+ Shift + de linker of rechterpijl maakt sprongen per tiental. Door de toetsencombinatie 
Command+Control verplaatsen alle paden binnen de totale breedte die de glyph nu al 
heeft. Ook hier zal de shifttoets er voor zorgen dat de paden per tiental verschuiven. Op 
sommige computers zijn deze toetsencombinaties bezet voor andere toepassingen zoals 
Mac’s Spaces/Mission Control waardoor deze toetsencombinaties niet bruikbaar zijn: 
schakel dit uit in de systeemvoorkeuren van de computer. Het spatiëren van conventionele 
lettertypes wordt hier geïllustreerd met Verdana. De informatie over het spatiëren is 
gebaseerd op Letters of Credit van Walter Tracy (1986). 

HHHH
Het spatiëren van kapitalen begint bij de H. Plaats enkele karakters H langs elkaar. Meet de 

afstand van de interne witruimte en plaats de helft van deze afstand aan elke zijde. 
Verklein de buitenruimte nog een beetje totdat de reeks H’s gelijkmatig oogt, behalve als 
het een vet font betreft: dan is dit niet nodig. Tijdens dit proces is het mogelijk dat de 
schreven aangepassingen vereisen. Dit stellen wordt allemaal met het oog gedaan, waarbij 
het in- en uitzoomen op de reeks van glyphs van belang is om tot de juiste balans te 
komen. De verschillende weergavemogelijkheden in Glyphs kunnen helpen, zie “5.5.  
Glyphs vergelijken en controleren” op pagina 31. 

HHOHH
Plaats hierna hoofdletters O tussen de hoofdletters H’s. De witruimte van de O stel je aan beide 

zijden af totdat de vijf letters in balans zijn. 

HHOOHH
Of deze spatiëring correct is wordt bekeken met de combinatie HHOOHH. Mogelijk dient de 

spatiëring van de O in deze combinatie opnieuw herzien te worden, soms ook die van de 
H. Is de spatiëring correct, dan vormen deze letters de standaard om op verder te werken. 
Deel de kapitalen op in de volgende groepen: de letters met een rechte stam (B D E F H I J 
K L M N P R U), de letters met een ronding (C D G O P Q), de driehoekige letters (A V W X Y) 
en de vreemde letters (S T Z). Zijden van een kapitaal met een rechte stam krijgen dezelfde 
waarde als de H terwijl zijden met een ronde vorm dezelfde waarde krijgen als de O. Echter 
is gewoon kopiëren van de witruimte naar andere glyphs niet voldoende: elk karakter 
dient nagekeken te worden in combinaties met H’s en O’s.

Het spatiëren van de onderkasten gebeurt op een gelijkaardige manier als de kapitalen. Eerst 
wordt de letter n afgesteld en hiervoor wordt de helft van de interne ruimte gebruikt. Aan 
de rechterzijde van het karakter wordt de spatiëring mogelijk iets verkleind als de 
schouder van de n door zijn curve veel witruimte toevoegt. Optisch staat de lettervorm 
altijd in het midden van de omringende kader. 

nnnn
Waarschijnlijk dient de spatiëring ook weer verkleind te worden, tenzij het een vet font is. Ook 

hier is het mogelijk dat er aanpassingen aan de schreven dienen te gebeuren. 

nnoonon
Daarna wordt het karakter o in verschillende combinaties tussen de n’s ingevoegd en 

gespatieerd totdat het geheel gelijkmatig oogt. In een schreefloos font is in deze fase ook 
vaak te zien of de n’s niet te dicht op elkaar aansluiten. Van zodra al deze combinaties 
visueel gelijkmatig ogen wordt aan de rest de onderkasten begonnen: letters met 
een rechte stam (b d h i j k l m n p q r u), de letters met een ronding (b c d e o p q) de 
driehoekige letters (v w x y) en de vreemde letters (a f g s t z). Hierbij kan de spatiëring 
tussen twee karakters nooit groter mag zijn als de interne ruimte in het karakter n.
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nnoonon
In het spatiëren van een cursief font worden dezelfde principes gevolgd.
 

01234567890
De getallen worden bekeken per type. Proportionele cijfers vragen andere waarden dan 

tabelcijfers, ook omdat zij anders vormgegeven zijn. Hetzelfde geldt voor de leestekens: zij 
verschillen elk van vorm dus dienen elk apart bekeken te worden. Zij mogen niet te dicht 
mogen aansluiten bij de voorgaande letter, zodat zij duidelijk leesbaar blijven.

Uiteindelijk is het het oog dat beslist of een letter goed gesteld is, niet de waarden die ingegeven worden. De glyph dient optisch midden 
tussen twee andere glyphs te staan, en ook optisch in het midden te staan van het bruine kader.

Het uittesten van een font gebeurt in de werkruimte van Glyphs waar met het gereedschap 
Tekst (Text) lettercombinaties ingegeven worden. Zo zijn de voorgaande combinaties met 
de glyphs n en de glyphs o gemaakt. Zodra dit soort van combinaties correct zijn wordt 
er overgegaan naar o.a. pangramzinnen1. Deze zinnen moeten goed leesbaar zijn en 
over de volledige lijn even zwart ogen zonder extra opvallende donkere of witte plekken. 
Typ deze zinnen zelf of haal ze uit andere teksten met het menu Edit -> Copy en het 
menu Edit -> Paste (terwijl het gereedschap Tekst actief is). Glyphs bewaart ook enkele 
voorbeeldteksten in het menu Glyphs -> Preferences -> Tab 3: Sample Strings. Dit zijn 
allemaal tekstregels geschikt om lettertypes op uit te testen en er kunnen ook eigen zinnen 
toegevoegd worden, al dan niet met een hoofdletter (naar eigen voorkeur). Selecteer het 
menu Edit -> Select Sample Text terwijl een tab met een glyph actief is om het lettertype 
uit te testen met deze zinnen.

Staan er naar jouw zin te veel of te weinig glyphs per regel, dan kan je dat veranderen door in het menu Glyphs -> Preferences, tab 2: 
User Settings het getal achter Text View Width te veranderen.

1. Pangramzinnen zijn zinnen waarin alle letters van het alfabet voorkomen. In deze zin kan je dan zien of alle letters goed gespatieerd 
zijn, en of het gewicht van de letters goed zit, m.a.w. of de hoeveelheid zwart vergelijkbaar is. Hier enkele van de meest bekende 
Nederlandstalige pangramzinnen zijn. lynx c.q. vos prikt bh: dag zwemjuf! filmquiz bracht knappe ex-yogi van de wijs. pa’s wijze 
lynx bezag vroom het fikse aquaduct. op brute wijze ving de schooljuf de quasi-kalme lynx.

8.2.  PANGRAMZINNEN
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Het font is nu in grote lijnen ok. Typografen weten echter dat er na het spatiëren nog een andere 
taak op hen wacht: sommige combinaties van glyphs hebben een veel te grote witruimte, 
zoals in bijvoorbeeld de paren To, AVA enz. De o wordt in deze specifieke combinatie onder 
de T ingeschoven en de A’s onder de V omdat de witruimte anders te groot zou zijn. Dit 
wordt kernen genoemd.

Waar de kerning dient te gebeuren is afhankelijk van de vorm van de letters. Behalve de combinaties AVA en een kapitaal T met een kleine 
letter zijn er veel mogelijke combinaties terug te vinden in de Sample Strings van Glyphs.

KERNEN
Wanneer het gewenste kerningpaar zichtbaar is in glyphs kan er 
snel een waarde ingegeven worden in het grijze paneel onder 
de glyph. Links en rechts staat tweemaal Kerning vermeld. Geef 
een waarde in door hier op te klikken. Die waarde geldt dan 

enkel voor de combinatie met de glyph die op dit moment voor/achter de huidige glyph 
staat. De toetsencombinatie Command + Alt (=Option) + de linker of rechterpijl past deze 
waarden ook aan (voor de combinatie met de glyph die achter de actieve glyph volgt). De 
toetsencombinatie Command + Alt (=Option) + Shift + de linker of rechterpijl laat dit per 
tiental gebeuren. In dit voorbeeld gebeurt er een kerning van -70 tussen een kapitaal T en 
een onderkast o.

De ingevulde waarden worden ook in een tabel weergegeven. Deze tabel is terug te vinden 
onder het menu Window -> Kerning. Eerst worden glyphs weergegeven waarop een 
kerning is toegepast, daarna gevolgd door alle glyphs waarbij een kerning dient te 
gebeuren, gevolgd door de waarde van de kerning. Deze tabel toont dat in dit font een V 
gevolgd door een A een kerning van -50 nodig heeft, een A gevolgd door een V een kerning 
van -50 nodig heeft en een kapitaal T gevolgd door een onderkast o een kerning van -70 
nodig heeft. Natuurlijk breidt zo een lijst uit naargelang het font groter is. Klik op een glyph 
met een waarde om deze in de actieve werkruimte weer te geven.

KERNINGGROEPEN
Na verloop van tijd komen veel waarden regelmatig terug. 
Bijvoorbeeld de A, Â, Ä, enz. dienen allemaal gelijk behandeld 
te worden. Deze waarde overal ingeven, en vooral, deze 
waarde overal aanpassen bij wijzigingen vergt te veel tijd. 

Daarom zijn er kerninggroepen. Verwijder de waarden V-A en A-V uit de kerningtabel door 
hen te selecteren en op het minteken onderaan te klikken. Open daarna de kapitaal A in 
Glyphs. Onderaan in het grijze bord staat tweemaal Group. Vul hier een naam in om 
gelijkende letters in onder te brengen; in de kapitaal A kan dit een groep worden met de 
naam A. Doe dit daarna voor alle kapitalen A met een accent, maar eventueel ook voor 
andere kapitalen die dezelfde kerning nodig hebben. Pas nu nogmaals de kerning aan 
tussen de lettercombinatie AVA. Dit gebeurt op identiek dezelfde manier als hier boven, 
maar de kerningwaarde wordt direct toegepast op alle glyphs die zich in die kerninggroep 
bevinden. In het grijze palet staat er een gesloten slot: Dat wil zeggen dat je waarde -90 
gebonden is aan de kerninggroep A. Om een uitzondering te maken op één specifieke 
lettercombinatie, open dan het slot.

In de kerningtabel worden voor alle kerninggroepen een @ geplaatst. Een V gevolgd door een 
letter uit de groep @A zal altijd dezelfde kerning meekrijgen, net zoals een letter gevolgd 
uit de groep @A gevolgd door een V. In dit lettertype is dat twee maal een waarde -90. 
Om het werken met kerninggroepen te vergemakkelijken bestaat er het script Set Kerning 
Groups dat een deel van het werk overneemt. Voor de werking van scripts wordt verwezen 
naar hoofdstuk “2*  Macro’s en scripts” op pagina 67.

In het overzicht van alle beschikbare glyphs in jouw lettertype kan je kiezen voor de 
lijstweergave met Cover Flow. In deze weergave krijg je een goed overzicht over welke 
glyph tot welke kerninggroep behoort.

In de werkruimte schakelt de eerste knop aan de rechterzijde onderaan de kerning in en uit.  Vergelijk hiermee wat de kerning bijdraagt 
aan het font.

8.3.  WITRUIMTEN CORRIGEREN: DE KERNING

https://github.com/schriftgestalt/Glyphs-Scripts
https://github.com/schriftgestalt/Glyphs-Scripts
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FONTLAB
Glyphs spatiëren of kernen vereist nog een ander venster. Open een Metrics Window met 

het menu Window -> New Metrics Window. Schakel de tabellen in met de drie laatste 
knoppen op de werkbalk. Typ daarna met het eerste gereedschap aan de linkerzijde 
de gewenste lettercombinatie en verander daarna van gereedschap om de spatiëring 
of de kerning aan te passen: het derde gereedschap helpt bij het spatiëren, het vierde 
gereedschap past de kerning aan. Doe dit door te klikken op en te slepen met de letter 
waar een verandering nodig is. De bovenste tabel geeft de spatiëring weer, de tabel 
aan de rechterzijde geeft de kerning weer. In de tabellen kunnen de waarden nadien 
nog aangepast worden. Open het palet Window -> Panels -> Classes om een nieuwe 
kerninggroup aan te maken.

ROBOFONT
Gebruik het Space Center om de glyphs te spatiëren, de vijfde knop op de werkbalk om letters 

te kernen en de zesde knop om glyphs in kerninggroepen onder te brengen. RoboFont 
toont de waarden in tabellen. Kernen gebeurt door de lettercombinatie in te geven in het 
venster Kerning, gevolgd door een waarde.
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Binnen een lettertype bestaan er verschillende fonts: Light, Regular, Bold, Extra Bold, Italic, Bold 
Italic, enz. Omdat vele van deze fonts overeenkomsten bevatten kan de computer er 
enkele zelf genereren. De techniek bestaat eruit dat ontwerper enkele fonts uitwerkt, 
genaamd de masters. Deze blijven in het bestand van Glyphs bewaard. Na het uittekenen 
van deze masters definiëert de ontwerper instances. Deze instances zijn de verschillende 
fonts die het programma zal genereren. Elke instance bevat instructies voor het 
programma hoe veel dikker/dunner de uiteindelijke fonts zullen zijn dan de door de 
ontwerper getekende masters. Dat proces noemt interpoleren.

Alles wat tot nu toe getekend is, is dus in een master getekend. De masters beheren gebeurt in 
de tweede tab van de fontinformatie. Aan de linkerzijde worden de aanwezige masters 
opgelijst, aan de rechtzijde verschijnt alle informatie die bij de geselecteerde master hoort:

Wanneer een master uitgetekend is verschijnt er een icoon voor de naam. Wanneer de master 
niet uitgetekend is, is die ruimte leeg. Een nieuwe master toevoegen gebeurt met de plus 
links onder. De eerste optie voegt een lege master in, de tweede optie voegt een ander 
bestand in als nieuwe master en de derde optie creëert een kopie van de geselecteerde 
master. Kies onder de proporties het gewicht (weight) en de breedte (width) van de 

9.  MASTERS EN INSTANCES

Master

Instance Instance Instance Instance Instance Instance Instance Instance Instance Instance Instance Instance Instance Instance Instance Instance Instance Instance

Master

9.1.  MASTERS
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nieuwe Master(s)1. De waarde achter het gewicht en de breedte geeft de positie van de 
huidige master aan binnen alle masters. Voor de stam kan de dikte van bijvoorbeeld de 
stam in de glyph i opgemeten worden (per Master!). Voor de breedte kan de breedte van 
een glyph gekozen worden. Er kunnen op deze manier vijfentwintig verschillende masters 
uitgewerkt worden2 en in een grafiek worden deze zo gepositioneerd:

 

Light
Extended

SemiLight 
Extended

Regular
Extended

SemiBold
Extended

Bold
Extended

Light 
SemiExtended

SemiLight 
SemiExtended

Regular 
SemiExtended

SemiBold 
SemiExtended

Bold 
SemiExtended

Light
Regular

SemiLight
Regular

Regular
Regular

SemiBold
Regular

Bold
Regular

Light
SemiCondensed

SemiLight
SemiCondensed

Regular
SemiCondensed

SemiBold
SemiCondensed

Bold
SemiCondensed

Light
Condensed

SemiLight
Condensed

Regular
Condensed

SemiBold
Condensed

Bold
Condensed

De x-as geeft de verschillen in breedte weer en de y-as geeft de verschillen in het gewicht weer. 
Controleer zelf dat er geen twee masters op dezelfde plaats liggen. Een derde dimensie 
kan toegevoegd worden onder de optie Custom. De ontwikkelaars van Glyphs geven 
als voorbeeld een Display, een aanpassing naar schermen toe. Een andere mogelijke 
toepassing is een Irregular, de mate van vervorming binnen de glyphs.

1. De namen die hier gekozen worden hebben niets te maken met het uiteindelijke uiterlijk van het font. Het zijn enkel indicaties hoe de 
masters zich ten opzichte van elkaar verhouden.

2. Theoretisch gezien kunnen er vijfentwintig masters uitgewerkt worden. Er zijn er echter nooit zo veel nodig. Voorzie enkel de extremen 
waartussen de uiteindelijke fonts zich zullen positioneren.
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Light Extended
Light Extended Custom 1

Light Extended Custom 2
Light Extended Custom 3

Regular Extended
Regular Extended Custom 1

Regular Extended Custom 2
Regular Extended Custom 3

Bold Extended
Bold Extended Custom 1

Bold Extended Custom 2
Bold Extended Custom 3

Niet alle masters worden uitgewerkt: enkel de nodigde, meest extreme Masters. Glyphs kan 
alles ertussen zelf creëren. Voor eenvoudige lettertypes volstaan Masters met enkel een 
verschil in gewicht. Voor een uitgebreider lettertype zijn Masters met verschil in gewicht 
en breedte vereist. Het werken met Masters volgens een 3D assenstelsel tenslotte biedt de 
mogelijkheid om zeer snel een superfamilie te creëren: een lettertype dat ontzettend veel 
fonts bevat.

In de fontinformatie blijven de metrics meestal over alle masters heen identiek, behalve de 
x-hoogte die in de zwaardere masters iets groter kan worden. Alignment zones zullen in 
alle Masters verschillen, zie het hoofdstuk “10.  Hinten van een font” op pagina 56. Na 
het definiëren van de masters verschijnen er enkele nieuwe knoppen op de werkbalk van 
Glyphs. Deze knoppen maken het mogelijk om tussen de verschillende masters te wisselen 
en de verschillende masters uit te werken.

Masters zijn ideaal voor fonts die verwant zijn aan elkaar. Voor fonts die een andere vormgeving navolgen, zoals 
bijvoorbeeld de Italics, dient er een ander bestand aangemaakt te worden. Zorg er dan voor dat de naam 
van het lettertype identiek is. Vergelijken of beide bestanden even veel glyphs bevatten kan met het menu 
Edit -> Compare fonts…

Door het toevoegen van een Master worden er ook automatisch nieuwe lagen aangemaakt. Dit maakt het mogelijk om de verschillende 
masters over elkaar te vergelijken. Zie het hoofdstuk “7.  Werken met achtergrond en lagen” op pagina 42

Voor elke glyph dient elke master uitgetekend te worden en dit mag niet naar willekeur 
gebeuren. Een glyph dient over alle masters heen even veel nodes, handgrepen en ankers 
te bevatten. Daarbij mogen overeenkomstige groene nodes niet wijzigen naar blauwe 
nodes en moet het startpunt op dezelfde plaats blijven staan. Volgende afbeelding 
illustreert dit voor twee masters van de glyphs n.

9.2.  COMPATIBILITEIT VAN DE MASTERS
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Alle nodes komen overeen in alle masters. Wanneer een programma de instances (dus de 
uiteindelijke fonts) zal genereren berekent het de verschillen tussen de Masters en werkt 
daarop verder. Via het menu View -> Show Master Compatibility wordt de compatibiliteit 
zichtbaar gemaakt, inclusief de compatibiliteit van de ankers. De Regular blijft hier actief, 
de Bold wordt in een groene vorm weergegeven. klik op het pad om verbindingslijnen 
weer te geven tussen alle nodes. Deze lopen bijna evenwijdig. 

 

In het overzicht met glyphs verschijnt er een oranje driehoek boven elke glyph waarvan de 
masters niet compatibel zijn. Er bestaat in de navigatie van Glyphs ook een filter die alle 
glyphs met incompatibele Masters weergeeft. In de werkruimte verschijnt een oranje balk 
bovenaan de letter als glyphs niet compatibel zijn over de masters heen. In dit voorbeeld 
zijn er twee handgrepen méér in de Regular dan in de Bold Master. Programma’s kunnen 
hier niet mee overweg; de ontwerper zal een keuze moeten maken welke vorm het wordt. 
Merk ook op hoe de verbindingslijnen opeens niet meer evenwijdig lopen. Paden die 
rood kleuren zijn niet compatibel en de glyphs worden niet geïnterpoleerd. Gele paden 
hebben een foutieve hoek en het is mogelijk dat het interpoleren niet goed zal verlopen. 
De groene paden zijn ok. Wanneer een glyph uit meerdere onderdelen bestaat zullen ook 
deze in dezelfde volgorde moeten voorkomen.



53

 

De volgorde van de paden kan veranderd worden met het menu Filter -> Fix Compatibility. 
Versleep de glyphs zodat links en rechts overeen komen.

Wanneer alle masters van een glyph voltooid zijn kunnen deze langs elkaar geplaatst worden 
met het menu Edit -> Show all Masters. En zelfs als alles hier ok lijkt, zal er na het 
exporteren nog een controle uitgevoerd moeten worden; een minimale fout kan reeds 
de oorzaak zijn van fouten tijdens het exporteren. Zo zal een verschil in de hoek van de 
handgrepen over de master heen er voor kunnen zorgen dat curves verstoord worden 
door een knik. Dit wordt besproken onderaan de pagina op glyphsapp.com/tutorials/
multiple-masters-part-2-keeping-your-outlines-compatible. Nog een reden om de 
aanbevelingen van het onderdeel “5.5.  Goed getekende paden” op pagina 33 te volgen 
(waar mogelijk)! Door bijvoorbeeld horizontale handgrepen op extrema te plaatsen 
worden problemen vermeden.

De instances zijn de fonts die uit de masters zullen voortvloeien. De ontwerper tekent niets 
maar geeft enkel het gewenste verschil in lijndikte ten opzichte van de masters in. 
Het programma zal daarna de fonts creëren. Instances positioneren zich op of tussen 
getekende Masters. Als er bijvoorbeeld geen Masters uitgetekend zijn met een verschillend 
gewicht maar wel met een verschil in breedte, mogen er enkel instances geplaatst worden 
volgens de x-as:

9.3.  INSTANCES

https://glyphsapp.com/tutorials/multiple-masters-part-2-keeping-your-outlines-compatible
https://glyphsapp.com/tutorials/multiple-masters-part-2-keeping-your-outlines-compatible
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Regular
Regular

Regular
Extended

Regular
Little Extended

Open de tab Instances in fontinformatie en klik links onder op de plus om nieuwe instances te 
maken. Vul de benodigde gegevens in: onder de Style Name (Naam van de stijl) komt de 
naam die het font zal krijgen3. Het nummer achter de stijlnaam (de weight class) bepaalt 
de positie van het font in de menu’s van Adobe-programma’s. Onder Weight (gewicht) 
volgt de zwaarte van het font, gaande van Thin (Dun) tot Heavy (Zwaar)4 en onder 
Width (breedte) wordt de breedte ingegeven, gaande van Ultra Condensed (Extreem 
versmald) tot Ultra Extended (Extreem uitgebreid). Als de instance de Bold, Italic of de 
Bold Italic versie van het lettertype wordt, vink dan de bijbehorende opties aan onder 
Style Linking (stijlen linken). Het linken van stijlen is noodzakelijk voor o.a. Microsoft 
Windows en Microsoft Office en andere programma’s die enkel een onderscheid maken 
tussen Regular, Italic, Bold en Bold Italic. Vul achteraan de naam van het bijbehorende 
rechte font in, bijvoorbeeld Regular of Medium enz. Onder interpolatie wordt het gewicht 
en de breedte van dit font ingegeven. Deze waarden refereren naar de waarden die de 
masters meekregen. Het interpoleren gebeurt aan de hand van het grid, maar voor de 
lichtste gewichten kan dit problematisch zijn. Zet de Grid Spacing op nul om alle details te 
behouden.

3. Vul ok deze naam in zonder speciale tekens en beperk de lengte. Fonts met een lange naam kunnen voor problemen zorgen in 
Windows. De gecombineerde lengte van de familienaam en de stijlnaam mag niet langer zijn dan 20 karakters. Kort lange 
namen zoals Extended af. Om de volledige naam weer te geven in tekstprogramma’s kan er achter de Custom Parameter 
preferredSubfamilyName de volledige naam toegevoegd worden.

4. Welke waarden worden er ingevuld achter het gewicht? Om van een Master Light met waarde 20 naar een Master Bold met waarde 
120 te gaan wordt er vaak met even grote sprongen gewerkt. De Instances krijgen dan een gewicht van respectievelijk 20, 40, 
60, 80, 100 en 120. Het is dan echter duidelijk te zien dat dit visueel niet de beste oplossing is. Luc(as) de Groot verwoorde toen 
de interpolatietheorie (www.lucasfonts.com/about/interpolation-theory) en Pablo Impallari verfijnde dit nadien (www.impallari.
com/familysteps). De volledige uitleg is te vinden op glyphsapp.com/tutorials/multiple-masters-part-3-setting-up-instances en 
een script om automatisch instances te programmaren staat op github.com/mekkablue/Glyphs-Scripts/blob/master/Masters/
Insert%20instances.py.

http://www.lucasfonts.com/about/interpolation-theory
http://www.impallari.com/familysteps
http://www.impallari.com/familysteps
https://glyphsapp.com/tutorials/multiple-masters-part-3-setting-up-instances
http://github.com/mekkablue/Glyphs-Scripts/blob/master/Masters/Insert%20instances.py
http://github.com/mekkablue/Glyphs-Scripts/blob/master/Masters/Insert%20instances.py
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Een ontwerper creëert met paden de ‘ideale’ lettervorm. Hij kan daarbij wel anticiperen op de 
weergave/verwerkingstechnieken die de gebruiker toepast, maar een echte controle heeft 
de ontwerper hier niet over. Beeldschermen en printers van slechte kwaliteit zijn nog 
alomtegenwoordig en deze beïnvloeden de lettervorm: om de letters om te zetten naar het 
beeldscherm of naar het gedrukte papier worden deze gerasterd: omgezet naar zeer kleine 
vierkantjes of puntjes. Weg is de ideale lettervorm die de ontwerper voor ogen had. De 
kwaliteit van de uiteindelijke lettervorm is afhankelijk van het aantal vierkantjes of puntjes 
per oppervlakte. Voor een beeldscherm wordt dat uitgedrukt in pixels per inch (ppi), voor 
drukwerk is dit dots per inch (dpi).

Vooral op beeldschermen vormt dit nog een probleem omdat deze vierkantjes groter zijn dan 
de puntjes in een printer. Verschillende technieken werden ontwikkeld om dit probleem 
op te lossen. Er ontstond zelfs een groep van lettertypes (Verdana, Georgia, enz.) waarin 
lettervormen specifieke kenmerken meekregen om goed te ogen op het scherm.

Een technische oplossing werd gevonden met het hinten. Met deze techniek wordt een digitaal 
font aangepast tijdens het renderen (het omzetten van technische gegevens tot een beeld) 
om beter op het raster van het beeldscherm te passen. Deze correctie op de lettervormen 
gebeurt terwijl er getypt wordt. Een voorbeeld: onderstaande stukken tekst bevonden zich 
op dezelfde plaats op het beeldscherm en gebruikten dezelfde pixels maar in de tweede 
afbeelding werd het font gehint. Merk op dat vooral onder de basislijn en boven de 
x-hoogte minder grijze pixels verschijnen. Ook de tussenruimte tussen de letters heeft baat 
gehad bij dit hinten. 

 

10.  HINTEN VAN EEN FONT
10.1.  WAT IS HINTEN?
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Voor een gehint font is de Readability beter omdat de letters duidelijker afgetekend worden. De 
legibility wordt iets minder goed, omdat alle letters aangepast worden om te passen 
binnen hetzelfde grid van de pixels. Specifieke karakteristieken van glyphs kunnen 
daardoor wat van hun kracht verliezen. Onderstaande illustratie is opnieuw Matilda, 
ditmaal op 12pt en nog meer uitvergroot. De bovenste tekst is ongehint, de onderste tekst 
is door de computer gehint. Het hinten heeft een invloed op de Metrics van een font 
(x-hoogte, kapitalen, stokken en staarten), de strookdikte, de witruimte rondom en in de 
letters enz. 

 

Nog betere resultaten zouden behaald kunnen worden wanneer een font manueel gehint wordt. 
De ontwerper zal dan elke letter apart behandelen en manueel instructies voor het hinten 
toevoegen in elke glyph. Natuurlijk verschillen de resultaten per lettertypestandaard, per 
programma en per besturingssysteem. Windows & Adobe volgen de hinting informatie 
ingesloten in een font. Apple negeert de ingesloten hintinginformatie en past een eigen 
rendertechniek toe in hun eigen Mac-programma’s.

Lettertypes gebaseerd op PostScript (zoals OpenType) worden aangepast door de 
rendersoftware, dus ook met zonder of met een eenvoudige hinting ogen zij meestal 
behoorlijk. De kwaliteit is voor een groot deel afhankelijk van de gebruikte software. In 
lettertypes gebaseerd op TrueType wordt het rasteriseren gecontroleerd door in het font 
ingesloten instructies. Als er geen instructies aanwezig zijn wordt het renderen moeilijk. 
De techiek achter Postscript-gebaseerde fonts heeft als voordeel dat elk font behoorlijk 
gerenderd kan worden zonder veel moeite. Het voordeel van de techniek achter de 
TrueType-gebaseerde fonts is dat elke pixel beheerst kan worden.

Er wordt vaak beweerd dat hinten overbodig zal worden door de evolutie van de technieken. 
Maar ondanks de nieuwe evoluties in hardware en software blijft het hinten meer relevant 
dan ooit (Bil’ak, 2010). Wanneer het hinten overbodig wordt is nog niet geweten. Het 
vervolg van dit hoofdstuk geeft een basis mee in het hinten van Postscript (waaronder 
OpenType) en vertelt kort hoe TrueType hinting werkt.

De meeste programma’s voor het creëren van lettertypes bevatten een autohinter. Glyphs kan 
een font hinten op het moment van exporteren (zie het hoofdstuk “11.  Export en gebruik” 
op pagina 64). Hiervoor heeft het enkele gegevens nodig: de horizontale en verticale 
strookdikten en de uitlijningzones.

Vul de gewenste ideale strookdikten correct in onder Vertical Stems (verticale stroken) en 
Horizontal Stems (horizontale stroken). Er kunnen tot twaalf verschillende waarden 
ingevuld worden voor elke richting, maar hoe minder hoe beter. Limiteren tot vier 
waarden is optimaal: de strookdikten van de kapitalen en de strookdikten van de 

10.1.  AUTOMATISCH POSTSCRIPT HINTEN
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onderkast, zowel horizontaal als verticaal. Gebruik de meest voorkomende waarde eerst 
(meestal de waarde van de onderkast) en doe dit in alle masters met een consequente 
volgorde, zodat ook deze geïnterpoleerd kunnen worden.

Uitlijningzones (alignment zones) omvatten de delen van alle glyphs die ietsje boven de 
waarden van de metrics uit komen. Bijvoorbeeld de overshoot van de glyph o, de 
dwarsstreep van de t of een mogelijke scheve schreef bovenaan de n bevinden zich in zulk 
een zone. De staart van de j of de g bevinden zich in een andere zone. Open opnieuw de 
tab masters in de fontinformatie en klik op de ronde pijl boven het kader van de alignment 
zones. Als de metrics correct ingevuld zijn worden er automatisch vijf uitlijningzones 
gecreëerd, gebaseerd op de huidige vormen van de glyphs. De eerste waarde is de positie, 
meestal identiek aan de metrics. De tweede waarde is hoogte van de uitlijningszone. 
Wanneer het een top zone is (boven de positie), dan is die waarde positief, is het een 
bottom zone (onder de positie), dan wordt de waarde van de hoogte negatief. Klik op de 
waarden om eventueel te verfijnen. Uitlijningzones moeten zo klein als mogelijk zijn. De 
ontwikkelaars van Glyphs raden uitlijningzones groter dan 25 units af en vermelden ook 
dat uitlijningzones elkaar niet mogen raken of overlappen. Er is een maximum van vijf top 
zones en zes bottom zones.

In de werkruimte verschijnen deze uitlijningszones als oranje strepen doorheen de lettervormen. 
Wat boven of onder de metrics uitsteekt zou in zulk een zone terecht moeten komen. 
Wanneer een tekstverwerkingsprogramma begint met het renderen van deze letter 
op kleine grootte lijnt het alle delen van de glyph in een uitlijningszone op één lijn 
uit. De doorlopende tekst oogt hierdoor homogener. Bij het bewaren van een font zet 
Glyphs de uitlijningszones automatisch om naar BlueValues en OtherBlues. FamilyBlues, 
FamilyOtherBlues, BlueFuzz, BlueScale enz. kunnen onder Custom Parameter toegevoegd 
worden om het hinten optimaal af te stellen. Informeer je over deze parameters in de 
Adobe Type 1 Font Format-specificaties.

Hinting informatie wordt 
ingevuld in de Stem widths 
en de Alignment Zones. 
Onder Custom Parameter 
kunnen deze gegevens nog 
verfijnd worden.
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Met deze instructies kan het programma verder: glyphs zonder manuele hinting instructies 
zullen automatisch gehint worden. Exporteer het lettertype en test de automatische 
hinting uit op verschillende besturingssystemen en in verschillende programma’s. Fouten 
tegen het hinten die opvallen in een tekst worden nadien manueel  gecorrigeerd. Zorg bij 
manueel gehinte glyphs voor een goede afwerking daar de autohinter hier niet meer aan 
werkt.

Na het automatisch hinten kunnen er nog fouten gevonden worden, of kan het resultaat zelfs 
zwakker zijn dan gewenst. Dan worden er handmatige hinting instructies in het font 
ingebracht. Dit is een zeer tijdrovend karwei, Peter Bil’ak (2010) beschrijft de tijd voor 
verschillende technieken binnen TrueType: minstens tachtig uur voor zwart-wit hinting, 
tweeënzeventig uur voor het hinten in grijswaarden (horizontaal en verticaal) en ongeveer 
veertig uur voor ClearType hinting (horizontaal) en voor DirectWrite. En dit per font dat de 
256 basiskarakters bevat, dus niet voor het volledige lettertype.

Voor het hinten van een font gebaseerd op Postscript (waaronder OpenType) worden 
horizontale en verticale instructies gegeven om beter te passen op het raster van de pixels. 
Open een glyph naar keuze en start met rechtermuisklik -> Autohint. Enkele verticale en 
horizontale hints verschijnen.

10.2.  MANUEEL HINTEN IN POSTSCRIPT

Een o met alle uitlijningzones 
die in dit font gedefinieerd 
zijn, ook al zijn zij niet 
allemaal van toepassing op 
deze glyph.
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Dit zijn de instructies die renderprogramma’s meekrijgen terwijl zij de lettervorm omzetten naar 
de pixels van het beeldscherm. Samen met de uitlijningzones zorgen de horizontale hints 
voor de verticale uitlijning van de stroken. Verticale hints zorgen voor een horizontale 
verschuiving van nodes. Gedurende het proces van het renderen worden alle beïnvloed die 
zich in de hints bevinden.

Verwijder het teveel aan hints of voeg nieuwe hints toe waar nodig. Dit kan door 
rechtermuisklik -> Add horizontal hint of door rechtermuisklik -> Add vertical hint. Als er 
twee nodes geselecteerd zijn verschijnt de hint exact op die positie. Overloop daarna een 
voor een alle hints voor de correcte plaatsing. Pas waar nodig de positie (eerste waarde) 
en de breedte (tweede getal) aan door op de waarden te klikken. Of pas de positie van 
een hint aan door de hint te selecteren en de blauwe symbolen te verslepen. De blauwe 
cirkel komt overeen met de positie, de blauwe driehoek komt overeen met de breedte van 
de hint. Plaats deze als mogelijk op nodes zodat de hint gelinkt wordt aan de positie van 
de onderliggende nodes. Als de node ooit aangepast wordt past Glyph de hint mee aan. 
Wanneer alle hints verbonden zijn met knooppunten is het in een font met meerdere 
masters (“9.  Masters en Instances” op pagina 49) niet meer nodig om de andere 
masters te hinten.

Een E met mogelijke hints 
weergegeven als grijze 
stroken. De ontwerper beslist 
of de rechterzijde al dan niet 
gehint wordt, afhankelijk van 
het ontwerp.
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Hints zijn altijd positief (waarde van de breedte), groter dan nul en mogen elkaar nooit 
overlappen, behalve de hints met een verschillende richting (verticale hints mogen 
horizontale hints overlappen en omgekeerd).

Voorgaande hints zijn allen stem hints1 welke een horizontale of verticale stam of strook of een 
schreef van een glyph aanduiden. Een andere soort hint is de ghost hint welke verticale 
stroken afsluit en verschijnt op plaatsen waar een horizontale stem hint niet gebruikt kan 
worden.

Ghost hints worden gebruikt om verticale stroken te beëindigen waar er geen horizontale 
hint geplaatst kan worden. Bijvoorbeeld in deze letter uit het pixelfont Logica. Een 
schreefhebbende letter zou een hint onderaan de staart van de p krijgen.

1 Stem hints: Letterlijk vertaald als hints voor stammen of hints voor stroken, maar ook hier is de Engelse term meer gebruikt dan 
een Nederlandse vertaling dus de termen stem hints en ghost hints worden verder gebruikt.
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Plaats ook hier een hint, zoals bij een schreefhebbend lettertype zou gebeuren. Selecteer deze 
hint en kies voor rechtermuisklik -> Make Ghost Hint. Of selecteer eerst één enkele 
node en kies rechtermuisklik -> Place Horizontal Hint. Daarna kan in het informatiepalet 
gekozen worden of deze ghost hint bovenaan of onderaan uitlijnt (bottom ghost hint of top 
ghost hint). Verplaats ook hier de blauwe cirkel opnieuw naar een bestaande node voor 
het beste resultaat. Doe dit voor alle stammen die nog niet beëindigd zijn door een stem 
hint.

Sinds Glyphs 2 is het ook mogelijk om TrueType fonts te hinten. TrueType biedt veel meer 
mogelijkheden om de aanpassingen van de glyph op het raster van de pixels te 
controleren. Voeg de TrueType hinting informatie in met het gereedschap TrueType 

10.3.  HINTEN IN TRUETYPE

Een Ghost Hint onderaan 
de glyph p om dit uiteinde 
te beheren gedurende het 
hinten.
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Instructor, het laatste gereedschap op de werkbalk. De letters worden geprojecteerd 
op een nieuw grid, dat de pixels van het scherm voorstelt. Dit grid kan in het infopalet 
aangepast worden om meer of minder pixels te bevatten.

Met de TrueType Instructor wordt dan aangegeven hoe de letter het beste op dit grid past. 
De opties zijn terug te vinden in een rechtermuisklik: de OpenType hints overnemen 
of Anchor Points2 plaatsen. Bekijk de rode contourlijn om te zien hoe de letter zich 
aanpast aan de pixels van het beeldscherm. In bovenstaande afbeelding zijn er nog 
geen aanpassingen, na het toevoegen van hinting instructies zullen de zwarte en rode 
contourlijn zeer veel afwijken. In deze cursus wordt niet dieper ingegaan op het TrueType 
hinten, meer info is te vinden op www.microsoft.com/typography/hinting/hinttut2.htm.

2. Niet te verwarren met de ankers die de conponenten positioneren!

Het raster achter de Glyph 
geeft hier de pixels weer van 
het beeldscherm. De rode 
lijnen zijn de aanpassingen 
die zullen gebeuren aan de 
vorm van de letter. In dit 
voorbeeld is er nog veel werk 
om de glyph op de pixels af 
te stellen.

https://www.microsoft.com/typography/hinting/hinttut2.htm
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Zodra alles in het font/de fonts voltooid is wordt het volledige lettertype geëxporteerd zodat 
het in ander programma’s bruikbaar is. Controleer eerst of de correcte glyphs opgenomen 
worden in het lettertype. Glyphs die niet geëxporteerd mogen worden zijn in het overzicht 
uit te schakelen door rechtermuisklik -> Exports uit te vinken. Er verschijnt dan een rode 
cirkel met een streep door op de miniatuur van de glyph. Als alle adviezen uit voorgaande 
hoofdstukken nagevolgd zijn en het font/de fonts er perfect uit zien, kies dan het menu 
File -> Export. De kans is groot dat dit exporteren meerdere keren moet gebeuren omdat 
er mogelijk nog fouten in het lettertype gevonden worden tijdens het gebruik. 

In het venster dat verschijnt zijn er enkele opties. Bovenaan is otf geselecteerd: er wordt dus 
als een OpenType lettertypebestand geëxporteerd. OpenType is de laatst ontwikkelde 
standaard voor een digitaal lettertype. Het biedt een uitgebreid scala aan mogelijkheden, 
zoals de ondersteuning voor een zeer groot aantal glyphs (tot 65,536 verschillende glyphs), 
een eigen programmatie voor Features enz. De tweede optie, ufo, is een gegevensbestand 
dat het gemakkelijk maakt om fonts met andere lettertypeprogramma’s uit te wisselen, 
zoals met FontLab of RoboFont. De optie Metrics creëert een bestand dat per letter de 
maateenheden van het huidige lettertype bevat. Webfont tenslotte creëert fonts van een 
andere standaard, beter geschikt voor het internet. Webfonts zijn OpenType of TrueType 
fonts met een grotere compressie zodat de bestandsgrote afneemt en zij gemakkelijker 
over het internet doorgezonden kunnen worden.

Onder het paneel OpenType zijn er nog keuzes of de overlappingen in de lettervormen 
automatisch verwijderd mogen worden en of het lettertype automatisch gehint mag 
worden (zie vorig hoofdstuk, “10.  Hinten van een font” op pagina 56). Als de 
overlappingen nog niet verwijderd zijn kan deze eerste optie best aan staan. Het hinten 
staat meestal aan, wat voor normale gebruikers de beste optie is. De optie Bewaar als 
TTF (TrueType Font) creëert een TrueType font in plaats van een OpenType font. Deze 
optie kan ingeschakeld worden zodra een TrueType font gewenst is. Export Destination 
(Bestandslocatie om te exporteren) biedt de mogelijkheid om steeds naar dezelfde 
map te exporteren. Kies éénmaal een goede locatie door te klikken op de vermelde 
bestandslocatie. Klik daarna op Next… om het bestand aan te maken. glyphs exporteert 
het volledige lettertype, bestaande uit één of meerdere fonts. Als er geen instances 
ingegeven zijn (zie “9.3.  Instances” op pagina 53), dan zal glyphs enkel een Regular 
aanmaken. Als er instances gedefiniëerd zijn dan volgt Glyphs deze instellingen. Het 
gecreëerde bestand is bruikbaar om teksten mee te zetten op zowel Mac, Windows als 
Linux.

11.  EXPORT EN GEBRUIK
11.1.  LETTERTYPES EXPORTEREN
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Lettertypes installeren gebeurt op elk platform anders. Dubbelklik op het bestand en in het 
venster dat verschijnt wordt er altijd een optie aangeboden om het font of het volledige 
lettertype te installeren. Op Mac bestaat er ook de lettertypecatalogus (Font Book) 
dat alle lettertypes van het systeem beheert. Test het lettertype uit op zo veel mogelijk 
besturingssystemen en programma’s omdat elk programma mogelijk een andere manier 
van werken bevat. Corrigeer eventuele fouten vóór het commercieel uitbrengen van het 
lettertype. Een lettertype verwijderen gaat op Mac via de Lettertypecatalogus (Font Book) 
en op Windows door het bestand uit de map C:\Windows\Fonts te verwijderen.

Bij een herinstallatie van hetzelfde lettertype is het aan te raden om eerst de vorige versie van 
het lettertype te verwijderen en daarna het systeem opnieuw op te starten. Hiermee 
wordt vermeden dat het lettertype dat het lettertype mogelijk nog circuleert in het 
werkgeheugen van de Mac of PC. Installeer het lettertype opnieuw na het heropstarten. 
Uitgebreide informatie en andere mogelijkheden kunnen gevonden worden op www.
glyphsapp.com/tutorials/eliminating-font-cache-problems. Wanneer het lettertype niet 
in alle programma’s beschikbaar is, of programma’s nog steeds met een verouderde 
versie werken, verwijder het dan opnieuw en gebruik een programma zoals OnyX om 
het lettertype volledig uit het werkgeheugen van de computer te halen. OnyX is terug te 
vinden op www.titanium.free.fr.

Iedereen die met software van Adobe werkt,  zoals Photoshop of Indesign heeft nog een 
andere optie: Installeer het font in de map Macintosh HD/Programma’s/Adobe InDesign 
(NUMMER)/Fonts. Hierdoor is het font direct beschikbaar in InDesign, zonder een herstart 
van het systeem of een ander programma. Ook het updaten van een font is dan geen enkel 
probleem, zelfs zonder InDesign af te sluiten. Maak een map Font (met hoofdletter) aan 
op de locatie /Library/Application Support/Adobe om het font in alle Adobe-programma’s 
te gebruiken. Stel mogelijk ook de Export Destination in het export-menu van Glyphs 
in op één van deze locaties. De keerzijde van deze snelle oplossing is dat het font enkel 
beschikbaar is in  Adobe-programma’s, en niet voor het volledige besturingssysteem.

Waar op letten tijdens het uittesten van het lettertype in andere programma’s? Om te beginnen 
mogen er tijdens het gebruik geen witte of zwarte vlekken in de glyphs zichtbaar zijn. 
Als dit gebeurt dan is de overlap niet verwijderd of zijn de contouren niet in de juiste 
richting gedraaid. De overlap verwijderen gebeurt in het menu Filter -> Remove Overlap, 
de contourrichting in het menu Paths -> Reverse countours of Paths -> Correct Path 
Direction.

Bevat het font speciale Features (zie hoofdstuk “3*  Features schrijven” op pagina 73) dan is 
het belangrijk om ook deze Features te activeren en te testen. Zie hiervoor het hoofdstuk 
“4*  Features activeren” op pagina 84.

Corrigeer alle fouten in Glyphs en exporteer/installeer het lettertype opnieuw.

11.2.  FONTS INSTALLEREN

11.3.  LETTERTYPES UITTESTEN

http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems
http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems
http://www.titanium.free.fr
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Het is mogelijk om het actieve font weer te geven op een iPad, iPhone of iPod Touch. Open eerst 
in de app Glyphs het menu Glyphs -> Preferences. Controleer of Enable External Preview 
(Activeer externe voorvertoning) in de tab delen (Sharing) ingeschakeld is zodat Glyphs 
het font zal ‘uitzenden.’

Verbind daarna de gewenste iPad, iPhone of iPod Touch met hetzelfde draadloze netwerk 
als de Mac. Download vervolgens op dit toestel de Glyphs Viewer uit de App Store. Dit 
is de directe link naar de download: https://itunes.apple.com/us/app/glyphs-viewer/
id605391966. Op deze webpagina staat alle overige informatie, die af en toe geüpdatet 
kan worden.

Open daarna de app. Deze app zoekt in het netwerk naar alle actieve programma’s Glyphs 
die een font uitzenden en maakt daar een lijst van. Kies in die lijst het juiste programma 
waardoor een preview van het font opent op het toestel.

1*  DE IOS-APP

https://itunes.apple.com/us/app/glyphs-viewer/id605391966?mt=8
https://itunes.apple.com/us/app/glyphs-viewer/id605391966?mt=8


67

Sommige onderdelen van het werken op de computer worden geautomatiseerd door middel 
van macro’s of scripts1. Dat zijn kleine stukjes code die bepaalde acties uitvoeren. De 
gebruiker schrijft deze zelf op het moment dat deze nodig zijn, meestal om vaak herhaalde 
acties te automatiseren en zo een tijdwinst te maken. Op de volgende pagina’s wordt een 
beknopte basis meegegeven.

De gebruikte programmeertaal voor macro’s en scripts in de programma’s Glyphs, FontLab en 
RoboFont is Python 2.7. De taal Python is een hogere programmeertaal; wat er door de 
programmeur ingevoerd wordt sluit meer aan bij de natuurlijke menselijke taal maar niet 
zo zeer op de werkwijze van de computer. Python 2 kan aangeleerd worden op python.org, 
op codecademy.com, op learnpythonthehardway.org/book of op http://doc.robofont.com/
api/step-by-step/starting-with-python/. Python 3 kan aangeleerd worden op bijvoorbeeld 
python.org of automatetheboringstuff.com.

Noteer dat er enkele grote verschillen zijn tussen Python 2 en Python 3. De belangrijkste 
daarvan zijn zeer duidelijk omschreven op de webpagina: programeveryday.com/post/
differences-between-python-27x-and-python-3x/. Instructies geschreven in Python 3.x 
moet aangepast worden naar Python 2.7 voordat deze uitgevoerd kunnen worden binnen 
Glyphs.

Naast de programmeertaal is er ook nog de API (application programming interface). Dit is 
een reeks van instructies die gebruikt kunnen worden om te communiceren met een 
programma of besturingssysteem. De website van Glyphs bevat enkele pagina’s uitleg 
om te starten: www.glyphsapp.com/tutorials/scripting-glyphs-part-1. De volledige 
documentatie over hoe Python en Glyphs communiceren is terug te vinden op docu.
glyphsapp.com.

Een eigen macro schrijven is mogelijk in het Macro paneel dat terug te vinden is in het menu 
Window -> Macro Panel:

In de editor bovenaan het venster is de code terug te vinden. Deze wordt uitgevoerd zodra er op 
de knop Run gedrukt wordt (dit kan soms even duren). Het resultaat wordt weergegeven 
in de console onderaan (als de macro tenminste zo geschreven is dat deze iets in de 
console uitprint). Zodra de console vol staat kan deze gewist worden met de knop Clear.

1. De verschillen tussen macro’s en scripts zijn zeer klein. Eenvoudig gesteld is een macro een verzameling van intructies die uitgevoerd 
worden binnen een bestaand programma. Een script is een losstaand bestand dat instructies bevat die misschien door één 
programma, meerdere programma’s of misschien zelfs het besturingssysteem uitgevoerd kunnen worden. De verschillen zijn 
echter niet in elk programma merkbaar.

2*  MACRO’S EN SCRIPTS

2*1*  HET MACRO PANEEL

https://www.python.org
http://www.codecademy.com
http://learnpythonthehardway.org/book/
http://doc.robofont.com/api/step-by-step/starting-with-python/
http://doc.robofont.com/api/step-by-step/starting-with-python/
https://www.python.org
http://automatetheboringstuff.com
http://programeveryday.com/post/differences-between-python-27x-and-python-3x/
http://programeveryday.com/post/differences-between-python-27x-and-python-3x/
https://www.glyphsapp.com/tutorials/scripting-glyphs-part-1
http://docu.glyphsapp.com
http://docu.glyphsapp.com
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In het programmeren is elke tekstregel een statement2. Het voorgaande voorbeeld bevat 
één statement met aan de linkerzijde een keyword3 (print) en aan de rechterzijde een 
expressie (1+1). Deze expressie bestaat nog eens uit waarden (values) en een operator 
(operator). Het statement dat begint met het keyword print aan de linkerzijde zendt de 
uitkomst van de rechterzijde naar de console in een formaat dat door mensen leesbaar is. 
De uitkomst van 1+1 wordt geprint als 2.

Variabelen zijn veel voorkomend in code. Vergelijk een variabele met een doosje waarin eender 
wat opgeborgen kan worden. De naam van de variabele mag willekeurig zijn en bestaan uit 
onder andere letters, underscores (_) en cijfers (maar mag niet beginnen met een cijfer!).

In dit voorbeeld wordt de expressie 1+1 aan de rechterzijde opgelost en krijgt de variabele met 
de naam tijdelijk de waarde van die oplossing toegewezen, namelijk de waarde 2. Daarna 
wordt de variabele tijdelijk met zijn huidige waarde 2 overgedragen naar de volgende 
regel. In het volgende statement zorgt het keyword print ervoor dat de waarde van de 
variabele uitgeprint wordt in de console, namelijk opnieuw 2.

In regel twee van dit voorbeeld staat dezelfde variabele aan beide zijden van de 
toewijzingsoperator = (assignment operator in het Engels). Dat is toegestaan als een 
variable reeds een waarde meekrijgt uit een voorgaande regel. De computer kan dus aan 
de rechterzijde 2 + 1 + 1 invullen. Hierdoor krijgt de variabele tijdelijk na het voltooien van 
de tweede lijn code een nieuwe waarde: 4. Deze waarde wordt meegenomen naar lijn 3 
waar ze geprint wordt in de console. Dit alles gebeurt natuurlijk pas nadat er op de knop 
Run gedrukt wordt.

Variabelen kunnen ook gegevens uit het font overnemen. Dit wordt gedaan door naar bepaalde 
informatie uit het font te verwijzen, bijvoorbeeld de algemene informatie uit het actieve 
font:

2. Een statement is het kleinste op zich staande element dat één uit te voeren actie weergeeft.

3. Een keyword is een woord dat een speciale betekenis heeft in de programmeertaal zoals bijvoorbeeld het keyword print in Python 2.
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In de console is af te lezen dat het actieve font ‘Matilda’ heet, versie twee van dit font is en 
dat het één master en 5 instances bevat. Alle informatie uit fonts kan op deze manier 
opgevraagd worden, maar ook worden aangepast. Nogmaals, de volledige documentatie 
over hoe Python en Glyphs communiceren is terug te vinden op docu.glyphsapp.com.

Om regelmatig uitgevoerde stukken code niet te verliezen worden deze bewaard als een script. 
Hiervoor is er het menu Scripts met daarin het item Open Scripts Folder. Dat menu-item 
opent de volgende locatie in de Finder:

~/Library/Application Support/Glyphs/Scripts/
Dit is de plaats waar scripts (geschreven voor Glyphs) bewaard worden. De tilde verwijst naar de 

thuismap op de Mac, meestal de map met de naam van de gebruiker. De map Library is op 
de meeste Macs onzichtbaar en is niet direct toegankelijk in de Finder. Daarom is deze map 
beter bereikbaar uit het menu van Glyphs dan in de Finder zelf.

TIP: Als er een script toegevoegd wordt op deze locatie zal Glyphs dat niet automatisch detecteren. Om niet elke keer het programma 
opnieuw op te starten, klik op het menu ‘Scripts’ en houd daarna de Option-toets in. Het item Open Scripts Folder verandert in 
Reload scripts. Veel eenvoudiger!

Scripts kunnen geschreven worden met elk tekstverwerkingsprogramma, zoals bijvoorbeeld 
Teksteditor. Andere programma’s zijn Xcode (van Apple, developer.apple.com/xcode) of 
het veel eenvoudigere TextWrangler (van Bare Bones, www.barebones.com/products/
TextWrangler). Python buiten het programma Glyphs gebruiken kan ook. Installeer 
daarvoor het volledige paket Python van de website python.org. Hierdoor wordt de editor 
IDLE geïnstalleerd samen met nog vele andere programma’s die specifiek voor Python 
gebouwd zijn.

Let er op dat bestandsnamen van nieuwe scripts eindigen met de extensie .py! Het is mogelijk 
om de extensie handmatig om te zetten van .txt naar .py. Doe dit door tijdens het bewaren 
van het bestand de optie verberg extensie uit te schakelen en dan de extensie manueel te 
veranderen naar .py.

De inhoud van elk script begint met onderstaande structuur:
 

#MenuTitle: Titel van jouw script (en dat ook in het menu van Glyphs zal verschijnen). 
# -*- coding: utf-8 -*- 
__doc__=””” 
Een beschrijving van wat dit script doet. 
“”” 
Hier volgt de rest van het script

Onderstaande scripts zijn voorbeelden van Rainer Erich Scheichelbauer, de verantwoordelijke 
voor de Engels- en Duitstalige handleiding van Glyphs. Het eerste script verwijdert alle 
lokale hulplijnen uit de geselecteerde Glyphs. Het tweede script verwijdert alle hints uit 
het actieve font. Rainers’s andere voorbeelden op github.com/mekkablue/Glyphs-Scripts 
zijn een goede bron van inspiratie om te starten met eigen scripts.

2*2*  HET MENU SCRIPT

http://docu.glyphsapp.com
https://developer.apple.com/xcode/
http://www.barebones.com/products/TextWrangler/
http://www.barebones.com/products/TextWrangler/
https://www.python.org/
https://github.com/mekkablue/Glyphs-Scripts
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#MenuTitle: Delete guidelines 
# -*- coding: utf-8 -*- 
__doc__=””” 
Delete all local guidelines in selected glyphs. 
“”” 
import GlyphsApp 
 
selectedLayers = Glyphs.font.selectedLayers 
 
def process( thisLayer ): 
 thisLayer.guideLines = [] 
 
for thisLayer in selectedLayers: 
 thisGlyph = thisLayer.parent 
 print “Deleting guidelines in:”, thisGlyph.name 
 thisGlyph.beginUndo() 
 process( thisLayer ) 
 thisGlyph.endUndo()

 
#MenuTitle: Delete All Hints in Font 
# -*- coding: utf-8 -*- 
__doc__=””” 
Deletes all hints throughout the whole font. 
“”” 
import GlyphsApp 
 
Font = Glyphs.font 
totalDeletedHints = 0 
print “Deleting all hints in %s ...” % Font.familyName 
 
def deleteHintsInLayer( thisLayer ): 
 numOfHints = len( thisLayer.hints ) 
 for x in reversed( range( numOfHints )): 
  del thisLayer.hints[x] 
 return numOfHints 
 
def process( thisGlyph ): 
 deletedHintsCount = 0 
 for l in thisGlyph.layers: 
  deletedHintsCount += deleteHintsInLayer( l ) 
 return deletedHintsCount 
 
Font.disableUpdateInterface() 
for thisGlyph in Font.glyphs: 
 totalDeletedHints += process( thisGlyph ) 
Font.enableUpdateInterface() 
 
print “Done: removed %i hints.” % totalDeletedHints
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Behalve macro’s en scripts kunnen er ook plugins geschreven worden. Een plugin breidt de 
mogelijkheden van Glyphs uit, een voorbeeld is het FixZeroHandles van Rainer dat terug te 
vinden is op github.com/mekkablue/FixZeroHandles. Modules breiden de mogelijkheden 
van Python uit. Beiden worden beheerd in de vijfde tab in de voorkeuren van Glyphs.

2*3*  ADDONS: PLUGINS EN MODULES

https://github.com/mekkablue/FixZeroHandles


72

Ook voor FontLab en RoboFont is de gebruikte programmeertaal voor scripts Python. 
De programmeertaal blijft identiek, maar de manier hoe er met de programma’s 
gecommuniceerd wordt verschilt. Lees de bijbehorende documentatie om de API 
(Application Programming Interface) te leren.

FONTLAB
Een macro can ingegeven worden in het paneel Edit Macro dat terug te vinden is in het menu 

Window -> Panels. De knoppen bovenaan dat palet geven uitgebreide mogelijkheden. De 
output van een macro of script bevind zich niet in een console, maar in een apart palet 
Output dat zal verschijnen wanneer nodig. Specifieke informatie voor FontLab is te vinden 
op old.fontlab.com/python-scripting/ of op www.e-font.de/flpydoc/.

ROBOFONT
Alle benodigde vensters om scripts te schrijven staat in het menu Python en het menu 

Extensions. Het venster dat daar geopend kan worden laat toe om scripts in te 
voeren in de editor bovenaan. De eerste knop op de werkbalk activeert het script in 
RoboFont. Onderaan is de console waar de eventuele output verschijnt. Een tip: het 
programma RoboFont is volledig in Python geschreven. Dat maakt het zeer gemakkelijk 
om uitbreidingen op dit programma te schrijven, genaamd extensions (extensies). De 
volledige uitleg over Python en de RoboFont API is te vinden op http://doc.robofont.com/
api/step-by-step/starting-with-python/.

http://old.fontlab.com/python-scripting/
http://www.e-font.de/flpydoc/
http://doc.robofont.com/api/step-by-step/starting-with-python/
http://doc.robofont.com/api/step-by-step/starting-with-python/
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De diverse voorbeelden in de cursus tonen aan dat er een grote typografische verscheidenheid 
mogelijk is. Er zijn bijvoorbeeld vier manieren om cijfers weer te geven (zie “6.2.  Welke 
glyphs toe te voegen?” op pagina 37), er zijn kleinkapitalen in plaats van de kapitalen, 
ligaturen in plaats van de losse letters f en i of er zijn de verschillende alternatieve vormen 
voor elke letter zoals bijvoorbeeld in het lettertype FlipperWriting (zie “6.3.  Conventies in 
de naamgeving” op pagina 38). Dit zijn slechts enkele van de mogelijkheden die fonts 
kunnen bieden. En wie wil er nu niet dat tekst zo goed mogelijk oogt? Wat er gebeurt bij 
slordige teksten is uitgezocht in de studie van Kevin Larson en Rosalind Picard: The 
Aesthetics of Reading (2005). 

aAa -> aaa 

123 -> 123 

Het uittekenen van deze typografische rijkdom is voor een letterontwerper geen probleem. 
Het probleem is om de tekstprogramma’s die de letterzetter gebruikt attent te maken 
op deze mogelijkheden. Uit zichzelf zal een programma deze alternatieve glyphs niet 
gebruiken. Daarom worden er in het font zelf Features toegevoegd (los te vertalen als 
mogelijkheden). Features zijn acties die gebeuren zodra de letters gerenderd worden voor 
weergave op een scherm of voor de printer. Features kunnen bijvoorbeeld extra spatie 
tussen de kapitalen aangeven. Of doorverwijzingen die programma’s eventueel kunnen 
volgen om van een standaard glyph (bijvoorbeeld een kapitaal) doorverwezen te worden 
naar een niet-standaard glyph (bijvoorgeeld een kleinkapitaal).

Niet elk bestandsformaat om lettertypes te bewaren ondersteunt Features. De alleroudste 
standaarden zoals Bitmapfonts en Type1 ondersteunden geen enkele Feature. TrueType 
ondersteunt enkele Features en de laatste nieuwe standaarden OpenType (.otf) en Apple 
Advanced Typography (.aat) ondersteunen haast alle denkbare Features. Overzicht van de 
mogelijke Features staan op en.wikipedia.org/wiki/List_of_typographic_features, www.
microsoft.com/typography/otspec/featurelist.htm, developer.apple.com/fonts/TrueType-
Reference-Manual/RM09/AppendixF.html en www.typotheque.com/fonts/opentype_
feature_support. De laatste link toont duidelijk dat niet alle Features ondersteund zijn in 
elk programma. De volledige OpenType specificaties zijn terug te vinden op www.adobe.
com/devnet/opentype/afdko/topic_feature_file_syntax.html.

Omdat online uitleg vaak uitgebreid technisch is, ofwel juist te beknopt is, overloopt dit 
hoofdstuk stap voor stap alle vereiste kennis over font Features. OpenType Features 
worden in elk font-programma op dezelfde manier geschreven maar de manier hoe zij 
ingevoerd worden verschilt. Glyphs is heel goed uitgerust om Features op te stellen. 
FontLab, RoboFont en FontForge bieden enkel elementaire ondersteuning, Fontographer 
heeft geen ondersteuning voor OpenType Features.

3*  FEATURES SCHRIJVEN

https://en.wikipedia.org/wiki/List_of_typographic_features
http://www.microsoft.com/typography/otspec/featurelist.htm
http://www.microsoft.com/typography/otspec/featurelist.htm
https://developer.apple.com/fonts/TrueType-Reference-Manual/RM09/AppendixF.html
https://developer.apple.com/fonts/TrueType-Reference-Manual/RM09/AppendixF.html
https://www.typotheque.com/fonts/opentype_feature_support
https://www.typotheque.com/fonts/opentype_feature_support
http://www.adobe.com/devnet/opentype/afdko/topic_feature_file_syntax.html
http://www.adobe.com/devnet/opentype/afdko/topic_feature_file_syntax.html
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Zelf Features schrijven klinkt vaak moeilijker dan dat het in de realiteit is. Glyphs zal hier 
echter heel goed mee helpen. Eigenlijk zal Glyphs zelfs het merendeel van het werk op 
zich nemen. Werk eerst alle glyphs uit die het font moet bevatten. Open daarna in de 
fontinformatie de vierde tab, Features. Bij het openen is deze tab volledig leeg:

De kolom aan de linkerzijde bevat de gegevens die in een font toegevoegd kunnen worden. De 
knop met de ronde pijl en de tekst Update zorgt er voor dat Glyphs de Features aanmaakt 
die het zelf kan produceren. Hiervoor gebruikt het programma een analyse an alle 
aanwezige glyphs in het font. Fonts die niet meer vereisen dan bijvoorbeeld eenvoudige 
ligaturen of kleinkapitalen gaan niet verder dan deze knop (mits de correcte naamgeving is 
opgevolgd, zie “6.3.  Conventies in de naamgeving” op pagina 38). Glyphs doet dan de 
rest.

Het eerste onderdeel Prefix1 omvat alle scripten en talen die Glyphs detecteert in het font. Dit 
kunnen onder andere zijn: standaard (dflt), Latijns (latn), Cyrilisch (cyrl), Grieks (grek), 
Nederlands (NLD), Romeens (ROM), Turks (TRK) enzoverder maar ook Arabisch en meer 
zou hier verschijnen zodra specifieke glyphs uit die taal ingevoegd zijn.

1. Ook Prefix is net zoals Metrics en Features een woord dat uit het Engels overgekomen is, en dat hier niet vertaald zal worden.

3*1*  FEATURES IN GLYPHS
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Het tweede onderdeel, de Classes (klassen) zijn alle groeperingen van glyphs die op een of 
andere manier bij elkaar horen. Zij worden opgesomd met hun naam, gescheiden door 
een spatie.

En ten slotte zijn er de Features, welke later de eigenlijke veranderingen in de vormgeving van 
het font kunnen aanbrengen. Afhankelijk van de glyphs die aan het font toegevoegd zijn 
kan dit een hele lijst worden:
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Alle Features die in de linkerkolom opgelijst worden hebben elk een andere functie. De 
geselecteerde Feature liga is bijvoorbeeld verantwoordelijk voor de verwijzingen naar 
de ligaturen die in het font aanwezig zijn. aalt, wat staat voor Access All Alternates 
(toegang tot alle alternatieven) is een opsomming van alle Features die bepaalde 
glyphs zullen vervangen door andere glyphs. Dlig is in de lijst verschenen omdat in het 
hoofdstuk “6.3.  Conventies in de naamgeving” op pagina 38 de glyph c_h toegevoegd 
is. Dlig is een afkorting voor Discretionary Ligatures en omvat ligaturen die niet tot de 
standaard set ligaturen behoren. (Het zijn meestal historische varianten die niet meer 
zo vaak voorkomen en dus in de meeste programma’s enkel ingeschakeld worden als de 
gebruiker dit wenst.) De reeds behandelde ligatuur f met l komt ook terug, maar ook de 
ligatuur f_b.liga die voordien besproken werd. Door het achtervoegsel .liga weet Glyphs 
dat deze ligatuur niet in dlig thuis hoort en plaatst Glyphs deze in de Feature liga. Het 
hoofdstuk over de naamgeving behandeld ook de verschillende soorten cijfers. Als al deze 
verschillende soorten in het font toegevoegd zijn zal Glyphs de Features numr, dnom, 
frac, ord, lnum, pnum, tnum, onum, én zero automatisch aanmaken. Ten slotte is er 
bijvoorbeeld nog de Feature cpsp wat Capital Spacing (kapitaalspatiëring) betekent. Deze 
feature plaats opeenvolgende kapitalen verder uit elkaar om een grotere witruimte te 
creëren en er daardoor ook een beter tekstbeeld ontstaat.

Alle features die Glyphs automatisch kan bouwen zijn nu opgesteld. De volgorde kan veranderd 
worden door de namen in de linker kolom te verslepen: de Features die het meest 
bovenaan staan worden het eerst uitgevoerd.

Klik daarna op de knop Compile om de code in te voegen in het font. Hierna is het mogelijk 
om alle aanwezige Features in- of uit te schakelen als het font gebruikt wordt. Dit in- en 
uitschakelen gebeurt in de werkruimte met de eerste knop links onder; er verschijnt een 
lijst met alle Features. (Zie ook in het hoofdstuk “4*  Features activeren” op pagina 84.) 
Worden er nadien nieuwe glyphs toegevoegd, of worden Features handmatig aangepast, 
dan kunnen alle door Glyphs geschreven Features tegelijkertijd geupdatet worden door 
opnieuw op Update te klikken gevolgd door de knop Compile.

De werking van de code wordt duidelijk met behulp van de Feature liga in voorgaande 
afbeelding. De algemene doelstelling van deze Feature is ligaturen maken van elke letter f 
en daar op volgende letters met een punt of letters met een stok.

In deze Feature zijn enkele tekstregels terug te vinden en elke regel is verantwoordelijk voor 
één enkele actie. Daarbij wordt elke regel ook nog afgesloten met een puntkomma 
(semicolon) om aan te geven wanneer een nieuwe regel, genaamd een nieuwe statement, 
begint. Elk statement in de code is op te splitsen in twee delen: sub en by. Het eerste deel 
duid wannéér er iets moet gebeuren, het tweede deel geeft aan wàt er moet gebeuren.

Het eerste woord, sub, is een afkorting van substitute. Dit is Engels voor vervang. De afkorting 
en de volledige term mogen door elkaar gebruiken worden, het font begrijpt beide 
woorden. Daarna volgt de combinatie van glyphs waarop de statement in actie zal 
treden, weergegeven door de namen van de glyphs, gescheiden door spaties. In de eerste 
tekstregel in de afbeelding is dat waneer er een f gevolgd wordt door een i. Zodra deze 
opgeven combinatie voorkomt (in een tekst) wordt dit eerste statement actief.

Het tweede deel wordt aangevat met het woord by (het Engelse woord voor door) gevolgd 
door de benaming van een andere glyph. De aan de linkerzijde vermelde glyphs zullen 
vervangen worden door de glyph die aan de rechterzijde vermeld staat.

In normale mensentaal is een statement dus te vertalen als: als de combinatie van glyphs aan 
de linkerzijde voorkomt in de tekst, vervang deze dan door de glyph aan de rechterzijde 
van de code. Dit is het basisprincipe voor de Substitutie-Features. 

Features zelf schrijven begint met het opstellen van een doelstelling. Deze doelstelling 
omschrijft wat er verandert aan de vormgeving van het font tijdens het zetten van een 
tekst. Als voorbeeld wordt opnieuw het font FlipperWriting aangehaald. De Features 

3*2*  HOE DE CODE INTERPRETEREN?

3*3*  ZELF CODE SCHRIJVEN
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in dit font bootsen een handschrift na en maken van dit font een flipperfont: een font 
dat verschillende varianten per letter afwisselend weergeeft. De doelstelling hiervan is 
verwoord als: ‘de code moet er voor zorgen dat er nooit twee dezelfde glyphs naast elkaar 
voorkomen zodat er een gevoel van handschrift ontstaat.’

Alternatieve lettervormen toevoegen en tekenen is besproken in de hoofdstukken “6.3.  
Conventies in de naamgeving” op pagina 38 en “7.  Werken met achtergrond en lagen” 
op pagina 42. In dat hoofdstuk heetten de varianten voor de letter p: p zelf, p.alt1, 
p.alt2, p.alt3, p.alt4 en p.alt5. (Het aantal varianten was een keuze van de ontwerper.) Om 
tekstprogramma’s bewust te maken van het bestaan van deze verschillende alternatieve 
glyphs wordt een Feature uitgeschreven. 

Een doelstelling kan met verschillende soorten Features bereikt worden. Zoek in de overzichten 
van de mogelijke Features  de naam van een Feature dat geschikt is. In dit voorbeeld 
is de geschikte Feature calt van Contextual Alternates (contextuele alternatieven): 
alternatieven afhankelijk van de context waarin de letter zich bevindt. Open de 
fontinformatie en activeer de tab Features. Klik links onder op het plus-symbool en kies 
in het menu voor ‘Feature.’ Geef de nieuwe Feature de naam calt (zonder kapitaal) en 
activeer de Feature door er op te klikken. Aan de rechterzijde van de fontinformatie 
verschijnt een volledig leeg blad waarin de code geschreven wordt. Het veld onderaan 
dient voor notities tijdens het werk.

Elke statement dat zal instaan om varianten op een glyph te tonen begint met het woord 
sub (of voluit: substitute). Dit soort woorden dat een actie aanduid zijn de keywords en 
in programma’s worden zij vaak aangegeven door een kleur. Na het keyword volgt de 
combinatie waarin de statement actief wordt, in dit voorbeeld als er twee letters p op 
elkaar volgen. Schrijf dus:

 
sub p p

Maar: bovenstaande code zal beide letters p vervangen door één enkele glyph. Dit is niet de 
bedoeling daar de eerste glyph van de letter p moet blijven staan. Als er slechts één glyph 
vervangen moet worden is dat aangegeven met een apostrof. Let er op dat het juiste 
symbool gebruikt wordt: het rechte streepje, niét de hoge comma of andere vreemde 
varianten, deze werken niet.

 
sub p p’

De apostrof geef de glyph(s) aan die vervangen moet(en) worden. Staat er geen apostrof, dan 
worden alle opgegeven glyphs vervangen. Hier zijn enkele voorbeelden van correcte 
constructies:

 
sub naam naam’ 
sub naam naam’ naam 
sub naam’ naam

Volgende constructie is fout. De te vervangen glyphs moeten altijd het midden van de 
constructie staan én de te vervangen glyphs dienen elkaar op te volgen:

 
sub naam naam’ naam naam naam’ naam naam

Het tweede deel van het statement zal vervolgens aangeven wat er gebeurt als de 
lettercombinatie voorkomt: de tweede p die voorkomt wordt dan vervangen door een 
alternatief, namelijk p.alt1. Dit geheel wordt natuurlijk afgesloten met een puntkomma.

 
sub p p’ by p.alt1;

Druk daarna links onder op de knop Update. Dit is slechts eenmaal nodig zodat de Feature aalt 
(Access All Alternates) zich bewust wordt van de nieuw toegevoegde Feature calt en zijn 
inhoud. Druk daarna op de knop Compile (compileren, samenstellen) om de code in het 
font in te voegen. Op het eerste zicht gebeurt er niets. Open een nieuwe tab en typ een 
aantal maal p met het gereedschap Tekst (Text). Op dit moment is er nog steeds geen 
verschil tussen de verschillende verschillende letters p’s. Klik links onder op de eerste knop 
en schakel Contextual Alternates (calt) in. Pas hierna zal Glyphs het geschreven stukje 
code gebruiken. De p’s zijn daarna duidelijk al niet meer identiek aan elkaar:
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Dit werkt goed. De volgorde van de glyphs kan afgelezen worden in het grijze infokader 
onderaan: p, p.alt1, p, p.alt1, p, p.alt1, p, p.alt1. Daarna kan het volgende deel van de code 
geschreven worden, maar dat is even opletten: het eerste statement kreeg een reeks van 
p’s. Het tweede statement dient rekening te houden met veranderingen die mogelijk al 
door het eerste statement gemaakt zijn.

Analyseer welke reeks glyphs er effectief nog over blijven na het eeste statement. In de reeks 
p, p, p, p, p, p, p, p, p. wordt de eerste glyph uitgelicht en vergeleken met de geschreven 
statements. Er wordt gezocht naar een p voorafgegaan door een andere p. Maar de 
allereerste p heeft geen voorganger en er gebeurt dus niets. Daarna wordt de tweede 
glyph uitgelicht en vergeleken met alle statements. De glyph p wordt gevonden én er staat 
een andere p voor: dit is een match, het statement wordt uitgevoerd. De tweede glyph 
p wordt vervangen door de glyph met de naam p.alt1. Op dat moment bestaat de reeks 
van glyphs uit: p, p.alt1, p, p, p, p, p, p, p. Hierna zal de derde glyph uit deze nieuwe reeks 
uitgelicht worden. Houd dus in gedachten dat er al een substitutie heeft plaatsgevonden 
vóórdat de derde glyph bekeken wordt. Om de derde p uit deze reeks te vervangen is 
volgende statement nodig:

 
sub p.alt1 p’ by p.alt2;

Met dit statement is de derde glyph te beïnvloeden. De volgende statements in de Feature calt 
hebben dezelfde redenering: de reeks is niet meer p, p, p, p, p, p, p, p, p; er zijn reeds 
veranderingen aangebracht voordat deze statements aan de beurt kunnen komen

 
sub p.alt2 p’ by p.alt3; 
sub p.alt3 p’ by p.alt4; 
sub p.alt4 p’ by p.alt5; 
sub p.alt5 p’ by p;

De laatste regel is meestal nutteloos en wordt hier weergegeven als voorbeeld: na alternatief vijf 
is er geen andere alternatief meer en p vervangen door p levert geen visueel verschil op. 
In uitzonderlijke gevallen kan dit statement echter wel van pas komen, bijvoorbeeld om te 
verhinderen dat eventuele statements die later in de code staan nog uitgevoerd kunnen 
worden. Statements die na een match voorkomen worden niet meer gecontroleerd voor 
de uitgelichte letter.

Test de Feature opnieuw uit na elke aanpassing in de code. Druk opnieuw op de knop Compile, 
en ga terug naar de werkomgeving in Glyphs. De reeks is als volgt: p, p.alt1, p.alt2, p.alt3, 
p.alt4, p.alt5, p, p.alt1, p.alt2 enzoverder. Deze code werkt!

Hier staat nergens nog twee maal dezelfde p achter elkaar, en alle alternatieven wisselen af. De 
bestaande code is bruikbaar voor de overige vijfentwintig letters uit het alfabet, en ook 
nog eens voor alle hoofdletters, leestekens, accenten enzoverder. Dupliceer hiervoor de 
code en vervangen de naam p door de naam van een andere glyph. Moet dit flipperen 
echter op elke glyphs van het hele font toegepast worden, dan is het een beetje zot om 
deze code honderden keren steeds opnieuw te schrijven. Dit kan sneller met classes 
(klassen).
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Code die regelmatig herhaald wordt is te vereenvoudigen door het toevoegen van Classes 
(klassen). Klassen zijn groeperingen van glyphs met een bepaalde overeenkomst. In het 
voorbeeld van FlipperWriting beschikt niet enkel de letter p over alternatieven maar doen 
alle zesentwintig onderkastletters dat, samen met de spatie die zes keer van breedte 
verschilt. Dus alle alternatieven worden per nummer in een klasse ondergebracht. Maak 
een klasse aan door links onder in de fontinformatie te klikken op het plusteken en 
dan de optie Class uit het menu te selecteren. Geef deze klasse een herkenbare naam, 
bijvoorbeeld Standaard. De naam van een klasse mag letters, cijfers en enkele leestekens 
bevatten, maar geen spatie. Voeg de zesentwintig onderkasten en de spatie in door hun 
naam te noteren in de witruimte aan de rechterzijde. De namen zijn ook hier gescheiden 
door een witruimte.

 
space a b c d e f g h i j k l m n o p q r s t u v w x y z

Maak daarna klassen aan om alle variaties in te sorteren, per nummer. Bijvoorbeeld een klasse 
Alternatieven1 met de glyphs: Met het menu Edit -> Find -> Find and Replace is het 
mogelijk om zeer snel getallen aan te passen in de code. Dit werkt gemakkelijker dan alle 
getallen handmatig aan te passen.

 
space.alt1 a.alt1 b.alt1 c.alt1 d.alt1 e.alt1 f.alt1 g.alt1 h.alt1 i.alt1 j.alt1 k.alt1 l.alt1 m.alt1 n.alt1 o.alt1 p.alt1 q.alt1 r.alt1 s.alt1 
t.alt1 u.alt1 v.alt1 w.alt1 x.alt1 y.alt1 z.alt1

Pas daarna de code in de Feature calt aan. Verwijs ditmaal niet naar de glyph p, maar naar een 
volledige klasse. Dit gebeurt door een @ gevolgd door de naam van de klasse:

 
sub @Standaard @Standaard’ by @Alternatieven1; 
sub @Alternatieven1 @Standaard’ by @Alternatieven2; 
sub @Alternatieven2 @Standaard’ by @Alternatieven3; 
sub @Alternatieven3 @Standaard’ by @Alternatieven4; 
sub @Alternatieven4 @Standaard’ by @Alternatieven5; 
sub @Alternatieven5 @Standaard’ by @Standaard;

Waarbij de laatste regel opnieuw optioneel is en de apostrof natuurlijk blijft staan. Als er nu 
een van de zevenentwintig glyphs uit de eerste klasse gevolgd wordt door één van de 
zevenentwintig mogelijke glyphs uit een volgende klasse, dan wordt de glyph uit de 
tweede klasse vervangen door een alternatief. De volgorde van de glyphs in de klassen en 
het aantal glyphs in de klassen is belangrijk! Als de eerste glyph in de eerste klasse een A 
is, mag de eerste glyph in de tweede klasse geen B worden. Anders gaan de Features alles 
door elkaar gooien. En de klasse waarvan de glyphs vervangen moeten worden dient even 
veel glyphs te bevatten als de klasse waaruit de vervangende glyphs zal komen (anders 
kunnen er geen glyphs vervangen worden).

Druk opnieuw op Compile om deze nieuwe code uit te testen. In de werkruimte ziet de reeks 
van p’s er identiek uit als het voorgaande voorbeeld ondanks het verschil in code. Maar 
vanaf nu kunnen daar ook andere letters tussen getypt worden, elke letter zal nu flipperen. 
In het infokader onderaan zijn de namen van de glyphs te zien en volgen de normale glyph, 
de .alt1, .alt2, .alt3, .alt4 en .alt5 elkaar op: 

3*4*  CLASSES (KLASSEN)

   p                    p.alt1                     e.alt2            space.alt3           e.alt4                e.alt5                     e            f.alt1          f.alt2         f.alt3        …
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Niet enkel flipperfonts zijn mogelijk. Alle situaties waarin er bepaalde glyphs vervangen moeten 
worden door alternatieven zijn te programmeren. Onderstaand statement zal bijvoorbeeld 
de getypte naam van de auteur ‘Maarten Renckens’ vervangen door een speciale glyph 
die zijn handtekening bevat. Dit werkt in zeer veel tekstprogramma’s die Features 
ondersteunen.

 
sub M a a r t e n space R e n c k e n s by handtekening;

Voor het plezier kunnen er ook animaties in een font toegevoegd worden. Alles is mogelijk, 
bijvoorbeeld een poedel die over het scherm wandelt terwijl er getypt wordt. Cool!

Natuurlijk zijn er nog meer mogelijkheden die te uitgebreid zijn om hier in detail te behandelen. 
Zo is er het # (kardinaalteken, hekje). Alles wat achter dit teken volgt geldt als een 
opmerking voor de programmeur. De code leest dit niet maar voor mensen is dit een veel 
gebruikt geheugensteuntje. Glyphs geeft deze opmerkingen in het grijs weer.

Features kunnen ook gesplitst worden in verschillende delen om verschillende soorten 
alternatieven door elkaar te gebruiken. Als dit nodig is wordt een Feature opgesplitst in 
verschillende delen genaamd een lookup. Het zijn op zichzelf staande stukken code die 
een voor een doorlopen worden. In de tweede lookup zal dus niet meer verwezen worden 
naar de glyphs zoals ze getypt worden, maar naar de glyphs zoals ze weergegeven worden 
na het doorlopen van de eerste lookup. Bijvoorbeeld:

 
lookup Alternatieven{ 
sub @Glyphs @Glyphs’ by @Glyphs.alt1; 
sub @Glyphs.alt1 @Glyphs’ by @Glyphs.alt2; 
sub @Glyphs.alt2 @Glyphs’ by @Glyphs.alt3; 
sub @Glyphs.alt3 @Glyphs’ by @Glyphs.alt4; 
sub @Glyphs.alt4 @Glyphs’ by @Glyphs.alt5; 
}Alternatieven; 
lookup Nog_enkele_speciale_glyphs{ 
sub n.alt3’ period’ by n_met_aangesloten_punt; 
sub n.alt4’ period’ by n_met_aangesloten_punt; 
sub t.alt1’ t.alt2’ by t_t-grote-streep; 
sub t.alt4’ t.alt5’ by t_t-grote-streep.alt1; 
}Nog_enkele_speciale_glyphs;

Uitgebreidere code vereist natuurlijk ook meer aandacht. Dit 
kan zeer eenvoudig geïllustreerd worden met de ligatuur 
ffi. Als de Feature liga de litaturen fi en ffi bevat, dan kan 
dit op twee manieren geschreven worden: fi kan eerst 
vermeld worden of ffi kan eerst vermeld worden. Als fi 
eerst vermeld is in de code dan worden deze combinaties 
als eerste verwerkt. De combinatie f met f met i zal dan 
nooit meer kunnen voorkomen omdat de combinatie 
f met i reeds vervangen is door een ligatuur. Dat is de 
reden dat in theorie de langste combinatie eerst staat.

De meeste gebruikers merken dit niet omdat Glyphs in staat is 
om veel van deze fouten op te lossen bij het drukken op 
de knop Compile, tenminste voor eenvoudige code.

3*5*  NOG EEN BEETJE MEER CODE

sub f i
sub f f i

of

sub f f i
sub f i

?



81

De code in Features kan ettelijke duizenden statements bevatten. Als er na het klikken op 
Compile geen foutmelding volgt, kan men er van uitgaan dat de code zal werken. 
Natuurlijk speelt de hoeveelheid statements een rol: hoe meer, hoe trager het geheel 
zal werken. Verschijnt er na het schrijven van de Features en tijdens het compileren een 
fout dan toont de knop Show het statement waarin de fout voorkomt. Probeer altijd de 
foutmelding te begrijpen en er een logische oplossing voor te vinden. 

De meest voorkomende fout is het vergeten van de puntkomma op het einde van een 
statement. Voeg deze toe als Glyphs daar om vraagt:

Verder gebeurt het ook vaak dat de namen van glyphs en/of de namen van klassen verkeerd 
gespeld zijn. Of vergeet men om op Compile te drukken, waardoor de code niet werkt 
zoals verwacht. Een andere veel voorkomende fout is de offset overflow. Dit wil zeggen 
dat de code te uitgebreid wordt om nog in het font te passen. Onderstaande code uit de 
Feature calt van het font Poodle (de geanimeerde poedel) zal zulks een fout genereren:

 
sub p o o d l e @Uppercase @Uppercase @Uppercase by poodle.004; 
sub p o o d l e @Uppercase @Uppercase by poodle.003; 
sub p o o d l e @Uppercase by poodle.002; 
sub p o o d l e by poodle.001;

Begin om deze fout te begrijpen bij het vierde en laatste statement. Er is één combinatie van 
glyphs voordat de code een actie onderneemt. Dit statement is nog geen probleem.

Het statement daarboven omvat dezelfde combinatie van glyphs én voegt er nog eens 
zesentwintig verschillende letters aan toe (alle letters in de klas Uppercase). Er zijn opeens 
zesentwintig verschillende mogelijkheden voordat dit statement geactiveerd wordt. Dat is 
nog niet zo veel, dus er is nog steeds geen probleem.

Hierna is de tweede regel aan bod. Daarin word nogmaals naar de klas Uppercase verwezen. De 
zesentwintig mogelijke combinaties die reeds konden voorkomen krijgen er per stuk nog 
eens zesentwintig mogelijke opvolgers bij. In totaal zijn er dus zeshonderd zesenzeventig 
mogelijkheden waarin dit statement geactiveerd kan worden. Dat begint al te tellen.

Tenslotte volgt de eerste lijn waarin nogmaals naar de klas Uppercase verwezen kan worden. Na 
de combinatie van p o o d l e kunnen er zesentwintig verschillende letters voorkomen, elk 
gevolgd door nog eens zesentwintig verschillende mogelijke letters en daarna nogmaals 
gevolgd door zesentwintig verschillende mogelijke letters. Er zijn hier zeventienduizend 
vijfhonderd zesenzeventig verschillende combinaties mogelijk in dit statement. Dat is veel 
te veel voor het font.

3*6*  FOUTMELDINGEN BIJ HET COMPILEREN



82

Enkele beelden uit het ganimeerde  
font Poodle: al typend wandelt deze 
hond over het scherm. De film van 
de volledige  animatie is terug te 
vinden op vimeo.com/135148043

https://vimeo.com/135148043


83

FONTLAB
In FontLab gebeurt het invoeren van Features onder het menu Window -> Palettes. De 

benodigde panelen heten Classes en OpenType.
Bekijk op de afbeelding hoe Features in FontLab worden ingegeven! Dit programma vult niets 

automatisch aan en vraagt meer informatie dan het programma Glyphs. Druk op het 
plusteken om een nieuw Feature te maken en FontLab geeft een structuur aan zoals 
het ingegeven dient te worden. Net zoals in Glyphs is er in FontLab een knop Compile 
om de uitgeschreven Feature naar het font door te zenden. Het programma kan ook 
niet automatisch Features aanmaken, dus ook de Feature Aalt dient door de gebruiker 
geschreven te worden (zie afbeelding). Een class dient rechts onder in het palet Classes 
geschreven te worden en met de knop Accept wordt deze pas ingevoerd. In FontLab een 
voorbeeld geven van het OpenType Feature gebeurt met het menu Window -> Palettes 
-> preview. Ga naar de tab OpenType en duid de gewenste Features aan. Er is een 
voorbeeld hoe het font er uit zou zien zonder de Feature ingeschakeld en met de Feature 
ingeschakeld. Onderaan worden de namen van de weergegeven glyphs getoond.

ROBOFONT
Features worden ingevoegd met het menu File -> New Feature… Het venster dat verschijnt 

vraagt om een volledige Feature, inclusief de voor en achtervoegsels die Glyphs niet 
vraagt. Wanneer de Features voltooid zijn worden deze in het font ingevoegd met de 
eerste knop op de werkbalk. Selecteer daarna in de lijst de fonts waarin de Features 
ingevoegd moeten worden. Alle Features uit een font zijn toegankelijk via de tweede knop 
op de werkbalk van het overzicht.



84

De Features geschreven het hoofdstuk “3*  Features schrijven” op pagina 73 zijn bewaard in 
een geëxporteerd font. Soms lijkt het alsof deze code niet werkt in bepaalde 
tekstprogramma’s. Dat komt omdat de overeenkomstige feature niet aan staat. Dit is per 
programma verschillend. Daarbij komt nog dat hoe ouder het programma is, hoe minder 
features het waarschijnlijk zal ondersteunen. De Feature om van tabelcijfers naar 
proportionele cijfers te gaan kan soms wel eens een groter probleem zijn dan men eerst 
zou vermoeden. Als een programma het gewenste Feature niet ondersteunt, is er meestal 
een lijst voorzien waaruit de benodigde glyphs gekozen kunnen worden. Gelukkig! 

123 -> 123

Er zijn enkele belangrijke principes om in het achterhoofd te houden zodat niemand voor 
verassingen komt te staan op het moment dat een font in tekstprogramma’s gebruikt 
wordt.

Het eerste principe houdt in dat de code die ingevoegd is in het lettertype niet bewaard wordt 
in tekstdocumenten: wat een tekstprogramma bewaart zijn alleen de getypte letters. Enkel 
wanneer deze bewaarde letters gerenderd worden, m.a.w. op een scherm weergegeven 
worden of naar een printer verzonden worden, gaat het tekstprogramma kijken in het 
lettertype welke Features aanwezig zijn en welke code daar bij hoort. De code brengt 
dan de benodigde veranderingen aan in de vormgeving van de tekst (dus niet in het 
tekstbestand zelf)!

Het tweede principe om te onthouden is dat dit renderen Feature per Feature gebeurt en 
daarbinnen letter per letter. De tekstprogramma’s bekijken de letter waarop de focus 
ligt samen met de voorgaande en volgende letters. Daarna wordt er in de code gezocht 
naar overeenkomsten. Als de lettercombinatie voorkomt in de code dan noemt met dat 
een match en wordt de bijhorende actie toegepast op de gefocuste letter. Vanaf dan kan 
de letter niet meer veranderen (eenvoudig gesteld), behalve met andere Features of een 
ingreep van de gebruiker. Vervolgens wordt er een letter verder gesprongen in de tekst en 
wordt het proces herhaald tot het einde van de tekst.

Onthoud tenslotte nog dat de code volledig opnieuw begint op elke nieuwe tekstregel. Het is 
niet mogelijk om in de code verwijzingen naar andere tekstregels te maken, enkel naar op 
elkaar volgende letters (de spaties inbegrepen).

Zoals reeds eerder getoond ondersteunt Glyphs haast alle denkbare features en kan het deze 
ook zelf aanmaken. Features inschakelen kan in de werkruimte (niet in het overzicht van 
alle glyphs) met de knop links onder. In de lijst die daar verschijnt worden alle in het font 
aanwezige features opgelijst om ingeschakeld te worden.

4*  FEATURES ACTIVEREN

4*1*  HOE WORDT DE CODE TOEGEPAST?

4*2*  OPENTYPE IN GLYPHS
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Daar Adobe een belangrijke rol gespeeld heeft in de ontwikkeling van OpenType is het logisch 
dat hun belangrijkste tekstverwerkingsprogramma InDesign de OpenType Features 
ondersteunt. Om te zien welke ingeschakeld zijn, ga naar het menu Type -> Paragraph 
Styles (Alineastijlen). Dit venster geeft de verschillende opmaakstijlen weer die 
gedefinieerd werden voor snel gebruik in een tekst. Dubbelklik op Basic Paragraph (of op 
één van de andere items in de lijst als er andere opmaakstijlen bijgemaakt zijn). Ga in het 
venster dat opent naar de tab OpenType. Alle ondersteunde OpenType Features worden 
daar opgelijst.

4*3*  OPENTYPE IN INDESIGN
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De opties die toegepast worden op de Basic Paragraph gelden voor 
de volledige tekst in InDesign. Soms staat echter de gewenste 
feature aan, maar reageert het font niet. Als er een plusteken 
achter de naam Basic Paragraph staat, helpt het soms om de stijl 
te resetten: selecteer het op te maken deel van tekst en klik op de 
resetknop: het paragraafteken ¶ gevolgd door een plus met een 
streep door.

Als een Feature slechts voor één of enkele alinea’s gewenst is, selecteer 
het stuk tekst waarop een bepaalde Feature toegepast moet 
worden. Klik vervolgens in het palet Paragraph Styles op het 
vierkantje onderaan om een nieuwe opmaakstijl te creëren en 
dubbelklik om de instellingen te veranderen. Vergeet niet om de 
nieuwe opmaakstijl een duidelijke naam te geven! De instellingen 
die nu aangepast worden omvatten alles wat betrekking heeft 
tot de opmaak van tekst. Deze ene opmaakstijl kan op meerdere 
plaatsen in de tekst toegepast worden zodat de instellingen 
slechts eenmaal gezet moeten worden.

VOOR EEN (KLEIN) STUK TEKST
Om kleine stukken tekst een gelijke opmaak te geven wordt er gewerkt met Character styles. 

Dat is haast hetzelfde als Paragraph Styles maar kan toegepast worden op kleine stukken 
tekst in plaats van een volledige allinea. Open het bijbehorende palet via het menu Type -> 
Character Styles. De werkwijze is identiek als voor Paragraph Styles..

VOOR LOSSE STUKKEN
Als een OpenType Feature slechts op een kort stuk tekst gewenst is, selecteer dan eerst die 

stukken tekst, woorden of lettertekens. Open daarna het palet Character in het menu Type 
-> Character. Via het menu rechtsboven is er ook toegang tot de individuele OpenType 
Features.
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De informatie over het toepassen van OpenType in kleine stukken tekst zal 
zeer spoedig veranderen. Ontwerpers en typografen van over de 
hele wereld hebben op het ATypI congres van 2014 (Association Typographique Internationale: Archive 
Better UI for Better Typography, 2014) een petitie gestart om OpenType beter toegankelijk te maken voor 
de gebruikers van Adobe programma’s. Hoe Adobe hier de komende jaren op zal reageren is nog niet 
duidelijk.

In het programma Microsoft Word (versie 10.4 uit 2010) zijn de OpenType Features standaard 
uitgeschakeld. Het is in te schakelen via het menu Opmaak -> Lettertype en dan op de 
tab Geavanceerd. In het midden staat een onderdeel Geavanceerde typografie waar alle 
features opgelijst staan die Word ondersteunt.

4*4*  OPENTYPE IN MICROSOFT WORD
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De meeste apps die door Apple gemaakt worden of het systeem van de Mac volgen hebben een 
eigen manier om OpenType Features te ondersteunen. In de programma’s Pages, Numbers 
Keynote, teksteditor enzoverder is dat terug te vinden in het menu Opmaak -> Lettertypen 
-> Toon Lettertypen. Hierdoor opent er een nieuw venster:

 

Klik in dit venster op de eerste knop in de werkbalk, het tandrad. Daar is het item Typografie… 
terug te vinden dat een nieuw palet opent. Dit palet geeft de features weer van het font 
dat in het venster Lettertypen geselecteerd wordt. Dit kunnen ook features zijn uit de 
standaard Apple Advanced Typography, een tegenhanger van de OpenType standaard.

Ook hedendaagse webbrowsers ondersteunen de OpenType Features. Het gebruik van deze 
features wordt bepaald door de webontwikkelaar in de css en is niet door de gebruikers te 
beïnvloeden. Bij het gebruik van Features op het web wordt er rekening gehouden met de 
verschillende browsers. Bijvoorbeeld:

elementName { 
font-variant-numeric: tabular-nums; 
-moz-font-feature-settings: “tnum”; 
-webkit-font-feature-settings: “tnum”; 
font-feature-settings: “tnum”;

}

Een zeer goed overzicht van verschillende features en de benamingen is terug te vinden op: 
https://helpx.adobe.com/typekit/using/open-type-syntax.html. Op deze website is ook 
vermeld welke OpenType Features standaard ingeschakeld zijn voor webbrowsers. 
Controleer bij de ontwikkeling van een website welke browsers de gewenste Features al 
dan niet ondersteunen.

4*5*  OPENTYPE FEATURES IN APPLE APPS

4*6*  OPENTYPE FEATURES OP HET WEB

https://helpx.adobe.com/typekit/using/open-type-syntax.html
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Het is tijdrovend om elke keer met de muis naar de menu’s te gaan om daar het correcte item 
te vinden en uit te voeren. Daarom zijn er de sneltoetsen ontwikkeld. Sneltoetsen zijn 
een toetsencombinatie, meestal startend met de Commandtoets, waarmee je snel een 
commando uit een menu kan bereiken, zonder eerst met de muis het menu te moeten 
openen. De exacte toetsencombinatie behorende tot een opdracht is altijd terug te 
vinden aan de rechterzijde van de menu’s. Hier worden de meest belangrijke combinaties 
opgesomd.

5*  SNELTOETSEN IN GLYPHS

5*1*  SNELTOETSEN VAN MAC OS X
Een nieuw document aanmaken 
Het document bewaren 
Op het beeld inzoomen 
Op het beeld uitzoomen 
De openstaande tab/venster sluiten 
Het programma afsluiten 
Selecteer alles 
Iets kopiëren naar het klembord 
Iets plakken vanuit het klembord 
Een zoekopdracht uitvoeren 
Naar een ander programma gaan

De fontinformatie oproepen 
Nieuwe glyphs toevoegen 
Open een nieuwe tab 
Toon de voorgaande letter 
Toon de volgende letter 
Toon/verberg het palet
Wisselen tussen de verschillende masters 
Enkel in de werkruimte: 
Activeer het selectiegereedschap
Activeer het gereedschap Teken 
Activeer de Gum 
Activeer de Rechthoek of de Cirkel 
Activeer het gereedschap Roteren 
Activeer het gereedschap Schalen 
Activeer het gereedschap Tekst 
Activeer het gereedschap Handje
Enkel waneer het gereedschap Tekst actief is:
Verander de witruimte aan de rechterzijde (met tien) 
verplaats de lettervorm binnen de kader
Verander de kerning aan de linkerzijde (met tien)
Verander de kerning aan de rechterzijde (met tien)

Command + n 
Command + s 
Command + = 
Command + + 
Command + w 
Command + q 
Command + a 
Command + c 
Command + v 
Command + f 
Command + tab (meermaals tab) 

Command + i 
Command + shift + g 
Command + t 
home / laptop: fn + linkerpijl 
end / laptop: fn + rechterpijl 
Command + alt (=Option) + p
Command + shift + Nummertoets 
 
v / tijdelijk gebruik: Command
p 
e 
f / wissel met shift + f 
r 
s 
t 
h / tijdelijk gebruik: spatiebalk

cmd+(shift)+pijl links / rechts
cmd+control+(shift)+pijl links / rechts
ctrl+alt+(shift)+pijl links / rechts
cmd+alt+(shift)+pijl links / rechts

5*2*  SNELTOETSEN VAN GLYPHS
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